summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-03-03 23:48:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-03-03 23:48:32 +0000
commit3695edfba336d0b3a5da8e515fe7f57d4d900af3 (patch)
treefbc18b101c9c77e9dfde9148ef06980d3ecf12b4 /gnome-extra
parentVersion bump of oracle-jdk-bin:8 wrt bug #542044 (diff)
downloadgentoo-2-3695edfba336d0b3a5da8e515fe7f57d4d900af3.tar.gz
gentoo-2-3695edfba336d0b3a5da8e515fe7f57d4d900af3.tar.bz2
gentoo-2-3695edfba336d0b3a5da8e515fe7f57d4d900af3.zip
Version bump, fix bug #518174. Move vala_src_prepare call after potential eautoreconf, fix configure to properly detect/use python, make unittest run within a dbus session, do not install docs in multiple paths.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zeitgeist/ChangeLog13
-rw-r--r--gnome-extra/zeitgeist/files/zeitgeist-0.9.15-fix-array-length-string-join.patch29
-rw-r--r--gnome-extra/zeitgeist/files/zeitgeist-0.9.15-python-detection.patch38
-rw-r--r--gnome-extra/zeitgeist/zeitgeist-0.9.15.ebuild104
4 files changed, 182 insertions, 2 deletions
diff --git a/gnome-extra/zeitgeist/ChangeLog b/gnome-extra/zeitgeist/ChangeLog
index 8ccf9a3cca65..727fb2a09454 100644
--- a/gnome-extra/zeitgeist/ChangeLog
+++ b/gnome-extra/zeitgeist/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-extra/zeitgeist
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zeitgeist/ChangeLog,v 1.43 2014/07/04 02:32:45 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zeitgeist/ChangeLog,v 1.44 2015/03/03 23:48:32 eva Exp $
+
+*zeitgeist-0.9.15 (03 Mar 2015)
+
+ 03 Mar 2015; Gilles Dartiguelongue <eva@gentoo.org> +zeitgeist-0.9.15.ebuild,
+ +files/zeitgeist-0.9.15-fix-array-length-string-join.patch,
+ +files/zeitgeist-0.9.15-python-detection.patch:
+ Version bump, fix bug #518174. Move vala_src_prepare call after potential
+ eautoreconf, fix configure to properly detect/use python, make unittest run
+ within a dbus session, do not install docs in multiple paths.
04 Jul 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unneeded useflag description from metadata.xml
diff --git a/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-fix-array-length-string-join.patch b/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-fix-array-length-string-join.patch
new file mode 100644
index 000000000000..857df8a11856
--- /dev/null
+++ b/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-fix-array-length-string-join.patch
@@ -0,0 +1,29 @@
+From 201bd67de450320520a12e2b0c465c8eb6818bd2 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Mon, 17 Mar 2014 20:57:49 +0100
+Subject: [PATCH] WhereClause: Fix array-length to work with string.joinv of
+ vala-0.24
+
+---
+ libzeitgeist/where-clause.vala | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/libzeitgeist/where-clause.vala b/libzeitgeist/where-clause.vala
+index a830599..d981914 100644
+--- a/libzeitgeist/where-clause.vala
++++ b/libzeitgeist/where-clause.vala
+@@ -211,7 +211,11 @@ namespace Zeitgeist
+ */
+ private T[] generic_array_to_unowned_array<T> (GenericArray<T> gptrarr)
+ {
++#if VALA_0_24
++ long[] pointers = new long[gptrarr.length];
++#else
+ long[] pointers = new long[gptrarr.length + 1];
++#endif
+ Memory.copy(pointers, ((PtrArray *) gptrarr)->pdata,
+ (gptrarr.length) * sizeof (void *));
+ return (T[]) pointers;
+--
+2.3.0
+
diff --git a/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-python-detection.patch b/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-python-detection.patch
new file mode 100644
index 000000000000..79184f70a2ba
--- /dev/null
+++ b/gnome-extra/zeitgeist/files/zeitgeist-0.9.15-python-detection.patch
@@ -0,0 +1,38 @@
+From dd46d6f8db69ee8d291d63251d841e73070cd526 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 4 Jan 2015 00:09:14 +0100
+Subject: [PATCH] Make python module detection match detected python
+
+Some distribution might provided multiple python and configure can know
+about which exactly though AM_PATH_PYTHON.
+---
+ configure.ac | 11 ++++++-----
+ 1 file changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index acf7daa..6136ad6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -269,13 +269,14 @@ if test "x$HAVE_RAPPER" = "xno"; then
+ fi
+
+ # check for python-rdflib
++AM_PATH_PYTHON([2.7])
++
+ AC_MSG_CHECKING([for python-rdflib])
+-echo "import rdflib" | python - 2>/dev/null
+-if test $? -ne 0 ; then
+- AC_MSG_FAILURE([failed. Please install the python-rdflib package.])
+-else
++AS_IF([$PYTHON -c "import rdflib" 2>/dev/null], [
+ AC_MSG_RESULT([yes])
+-fi
++], [
++ AC_MSG_FAILURE([failed. Please install the python-rdflib package.])
++])
+
+ #################################################
+ # Summary
+--
+2.3.0
+
diff --git a/gnome-extra/zeitgeist/zeitgeist-0.9.15.ebuild b/gnome-extra/zeitgeist/zeitgeist-0.9.15.ebuild
new file mode 100644
index 000000000000..cf7f41162f12
--- /dev/null
+++ b/gnome-extra/zeitgeist/zeitgeist-0.9.15.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zeitgeist/zeitgeist-0.9.15.ebuild,v 1.1 2015/03/03 23:48:32 eva Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=true
+PYTHON_COMPAT=( python2_7 )
+VALA_MIN_API_VERSION=0.22
+
+inherit autotools-utils bash-completion-r1 eutils python-r1 vala versionator
+
+DIR_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Service to log activities and present to other apps"
+HOMEPAGE="http://launchpad.net/zeitgeist/"
+SRC_URI="http://launchpad.net/zeitgeist/${DIR_PV}/${PV}/+download/${P}.tar.xz
+ http://dev.gentoo.org/~eva/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+ LGPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+datahub downloads-monitor extensions +fts icu introspection nls plugins sql-debug telepathy"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ downloads-monitor? ( datahub )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ !gnome-extra/zeitgeist-datahub
+ dev-libs/json-glib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ media-libs/raptor:2
+ >=dev-libs/glib-2.26.0:2
+ >=dev-db/sqlite-3.7.11:3
+ sys-apps/dbus
+ datahub? ( x11-libs/gtk+:3 )
+ extensions? ( gnome-extra/zeitgeist-extensions )
+ fts? ( dev-libs/xapian[inmemory] )
+ icu? ( dev-libs/dee[icu?,${PYTHON_USEDEP}] )
+ introspection? ( dev-libs/gobject-introspection )
+ plugins? ( gnome-extra/zeitgeist-datasources )
+ telepathy? ( net-libs/telepathy-glib )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # pure-python module is better managed manually, see src_install
+ sed -e 's:python::g' \
+ -i Makefile.am || die
+
+ # Fix direct invocation of python in configure
+ epatch "${FILESDIR}"/${PN}-0.9.15-python-detection.patch
+
+ # Fix vapi dependencies
+ epatch "${FILESDIR}"/${PN}-0.9.14-gio-backport.patch
+
+ # Fix query generation, from master
+ epatch "${FILESDIR}"/${PN}-0.9.15-fix-array-length-string-join.patch
+
+ autotools-utils_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --with-session-bus-services-dir="${EPREFIX}/usr/share/dbus-1/services"
+ $(use_enable sql-debug explain-queries)
+ $(use_enable datahub)
+ $(use_enable downloads-monitor)
+ $(use_enable telepathy)
+ $(use_enable introspection)
+ $(use_with icu dee-icu)
+ )
+
+ use nls || myeconfargs+=( --disable-nls )
+ use fts && myeconfargs+=( --enable-fts )
+
+ python_setup
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test TESTS_ENVIRONMENT="dbus-run-session"
+}
+
+src_install() {
+ dobashcomp data/completions/zeitgeist-daemon
+ autotools-utils_src_install
+ cd python || die
+ python_moduleinto ${PN}
+ python_foreach_impl python_domodule *py
+
+ # Redundant NEWS/AUTHOR installation
+ rm -r "${D}"/usr/share/zeitgeist/doc/ || die
+}