summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-29 18:30:53 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-29 18:30:53 +0000
commitded892e0bd4d1170f00cdf9e403bc98f7bbd9cbc (patch)
treeb3ae6f7b0161bda91b7b93c9b3562a0c18c7857f /gnome-extra/synapse
parentInitial commit. Bug #401123. Thanks to Hypnos <hypnos75@gmail.com> (diff)
downloadgentoo-2-ded892e0bd4d1170f00cdf9e403bc98f7bbd9cbc.tar.gz
gentoo-2-ded892e0bd4d1170f00cdf9e403bc98f7bbd9cbc.tar.bz2
gentoo-2-ded892e0bd4d1170f00cdf9e403bc98f7bbd9cbc.zip
Add underlinking patch, moved to autotools-utils.eclass
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/synapse')
-rw-r--r--gnome-extra/synapse/ChangeLog6
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.8.2-underlinking.patch16
-rw-r--r--gnome-extra/synapse/synapse-0.2.8.2.ebuild23
3 files changed, 37 insertions, 8 deletions
diff --git a/gnome-extra/synapse/ChangeLog b/gnome-extra/synapse/ChangeLog
index 67bb2017edce..695b8a3b1c3c 100644
--- a/gnome-extra/synapse/ChangeLog
+++ b/gnome-extra/synapse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/synapse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/synapse/ChangeLog,v 1.8 2012/01/29 16:45:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/synapse/ChangeLog,v 1.9 2012/01/29 18:30:53 jlec Exp $
+
+ 29 Jan 2012; Justin Lecher <jlec@gentoo.org> synapse-0.2.8.2.ebuild,
+ +files/synapse-0.2.8.2-underlinking.patch:
+ Add underlinking patch, moved to autotools-utils.eclass
*synapse-0.2.8.2 (29 Jan 2012)
diff --git a/gnome-extra/synapse/files/synapse-0.2.8.2-underlinking.patch b/gnome-extra/synapse/files/synapse-0.2.8.2-underlinking.patch
new file mode 100644
index 000000000000..5073bbc38fac
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.8.2-underlinking.patch
@@ -0,0 +1,16 @@
+ src/ui/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/ui/Makefile.am b/src/ui/Makefile.am
+index 3790ed2..78686ee 100644
+--- a/src/ui/Makefile.am
++++ b/src/ui/Makefile.am
+@@ -42,7 +42,7 @@ synapse_LDADD = \
+ $(top_builddir)/src/core/libsynapsecore.la \
+ $(top_builddir)/src/plugins/libplugins.la \
+ $(top_builddir)/src/tile-view/libtileview.la \
+- $(NULL)
++ $(NULL) -lm
+
+ if HAVE_INDICATOR
+ synapse_VALAFLAGS += --pkg appindicator-0.1 -D HAVE_INDICATOR
diff --git a/gnome-extra/synapse/synapse-0.2.8.2.ebuild b/gnome-extra/synapse/synapse-0.2.8.2.ebuild
index 876cfd24a0e3..3e9f041c8ba3 100644
--- a/gnome-extra/synapse/synapse-0.2.8.2.ebuild
+++ b/gnome-extra/synapse/synapse-0.2.8.2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/synapse/synapse-0.2.8.2.ebuild,v 1.1 2012/01/29 16:45:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/synapse/synapse-0.2.8.2.ebuild,v 1.2 2012/01/29 18:30:53 jlec Exp $
EAPI=4
-inherit gnome2-utils
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils gnome2-utils
DESCRIPTION="A program launcher in the style of GNOME Do"
HOMEPAGE="http://launchpad.net/synapse-project/"
@@ -41,20 +43,27 @@ DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/synapse-0.2.8.2-underlinking.patch
+ )
+
pkg_preinst() {
gnome2_icon_savelist
}
src_prepare() {
sed -i -e 's/GNOME/GNOME;GTK/' data/synapse.desktop.in
+ autotools-utils_src_prepare
}
src_configure() {
- VALAC="$(type -P valac-0.12)" \
- econf \
- $(use_enable ayatana indicator yes) \
- $(use_enable plugins librest yes) \
- $(use_enable zeitgeist)
+ local myeconfargs=(
+ $(use_enable ayatana indicator yes)
+ $(use_enable plugins librest yes)
+ $(use_enable zeitgeist)
+ VALAC="$(type -P valac-0.12)"
+ )
+ autotools-utils_src_configure
}
pkg_postinst() {