summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-30 22:14:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-30 22:14:05 +0000
commitb17ab27455066b776ccf317bdd7e4c0d2c5f6e83 (patch)
tree7f26a37399a29399299f83cf51816b3b2b49aba5 /gnome-extra/gnome-games
parent bump to 0.2.5 - * Fix unremovable files in trash (#523139). * Fix recursive ... (diff)
downloadgentoo-2-b17ab27455066b776ccf317bdd7e4c0d2c5f6e83.tar.gz
gentoo-2-b17ab27455066b776ccf317bdd7e4c0d2c5f6e83.tar.bz2
gentoo-2-b17ab27455066b776ccf317bdd7e4c0d2c5f6e83.zip
bump to 2.22.3. Lots of fixes, notably in GLChess and Sudoku. Updated translations.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-extra/gnome-games')
-rw-r--r--gnome-extra/gnome-games/ChangeLog7
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.22.3.ebuild129
2 files changed, 135 insertions, 1 deletions
diff --git a/gnome-extra/gnome-games/ChangeLog b/gnome-extra/gnome-games/ChangeLog
index 58b944e9aaab..4858d2842737 100644
--- a/gnome-extra/gnome-games/ChangeLog
+++ b/gnome-extra/gnome-games/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-games
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.238 2008/06/11 12:48:01 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.239 2008/06/30 22:14:05 eva Exp $
+
+ 30 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-games-2.22.3.ebuild:
+ bump to 2.22.3. Lots of fixes, notably in GLChess and Sudoku. Updated
+ translations.
11 Jun 2008; Rémi Cardona <remi@gentoo.org> gnome-games-2.22.2.1.ebuild:
use games-ggz.eclass to update /etc/ggz.modules, patch by nyhm
diff --git a/gnome-extra/gnome-games/gnome-games-2.22.3.ebuild b/gnome-extra/gnome-games/gnome-games-2.22.3.ebuild
new file mode 100644
index 000000000000..79db6dbef380
--- /dev/null
+++ b/gnome-extra/gnome-games/gnome-games-2.22.3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.22.3.ebuild,v 1.1 2008/06/30 22:14:05 eva Exp $
+
+# make sure games is inherited first so that the gnome2
+# functions will be called if they are not overridden
+inherit games games-ggz eutils gnome2 python autotools virtualx
+
+DESCRIPTION="Collection of games for the GNOME desktop"
+HOMEPAGE="http://live.gnome.org/GnomeGames/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="artworkextra guile opengl"
+
+RDEPEND=">=gnome-base/libgnomeui-2.16.0
+ >=gnome-base/libgnome-2.16.0
+ >=dev-python/pygtk-2.10
+ >=dev-python/gnome-python-desktop-2.17.3
+ >=x11-libs/gtk+-2.12
+ >=gnome-base/gconf-2
+ >=x11-libs/cairo-1
+ >=dev-libs/libxml2-2.4.0
+ >=gnome-base/librsvg-2.14
+ >=media-libs/gstreamer-0.10.11
+ >=gnome-base/libglade-2
+ >=dev-libs/glib-2.6.3
+ >=dev-games/libggz-0.0.14
+ >=dev-games/ggz-client-libs-0.0.14
+ guile? ( >=dev-scheme/guile-1.6.5 )
+ artworkextra? ( gnome-extra/gnome-games-extra-data )
+ opengl? ( dev-python/pygtkglext )
+ !games-board/glchess"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.53
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.10.40
+ >=gnome-base/gnome-common-2.12.0
+ >=app-text/scrollkeeper-0.3.8
+ app-text/gnome-doc-utils"
+
+# Others are installed below; multiples in this package.
+DOCS="AUTHORS HACKING MAINTAINERS TODO"
+
+# dang make-check fails on docs with -j > 1. Restrict them for the moment until
+# it can be chased down.
+RESTRICT="test"
+
+pkg_setup() {
+ # create the games user / group
+ games_pkg_setup
+
+ G2CONF="${G2CONF}
+ --with-scores-group=${GAMES_GROUP}
+ --enable-noregistry=\"${GGZ_MODDIR}\"
+ --with-platform=gnome
+ --with-sound=gstreamer
+ --enable-scalable"
+
+ if use guile; then
+ if has_version =dev-scheme/guile-1.8*; then
+ local flags="deprecated regex"
+ built_with_use dev-scheme/guile ${flags} || die "guile must be built with \"${flags}\" use flags"
+ fi
+ else
+ ewarn "USE='-guile' implies that Aisleriot won't be installed"
+ G2CONF="${G2CONF} --enable-omitgames=aisleriot"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Resolve symbols at execution time in setgid binaries
+ epatch "${FILESDIR}/${PN}-2.14.0-no_lazy_bindings.patch"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ eautoreconf
+}
+
+src_test() {
+ Xemake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Documentation install for each of the games
+ for game in \
+ $(find . -maxdepth 1 -type d ! -name po ! -name libgames-support); do
+ docinto ${game}
+ for doc in AUTHORS ChangeLog NEWS README TODO; do
+ [ -s ${game}/${doc} ] && dodoc ${game}/${doc}
+ done
+ done
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ # Avoid overwriting previous .scores files
+ local basefile
+ for scorefile in "${D}"/var/lib/games/*.scores; do
+ basefile=$(basename $scorefile)
+ if [ -s "${ROOT}/var/lib/games/${basefile}" ]; then
+ cp "${ROOT}/var/lib/games/${basefile}" \
+ "${D}/var/lib/games/${basefile}"
+ fi
+ done
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ games-ggz_update_modules
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ games-ggz_update_modules
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages
+}