summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-13 06:14:00 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-13 06:14:00 +0000
commitbfca9c88fb7b28e2f94e2c2188da8cdcf8e8e9a4 (patch)
treef2ffc36264c94d8b3068e14af10045841c96a6d3 /gnome-extra/evolution-kolab
parentAdd evolution-kolab to gnome-3.4 mask. (diff)
downloadgentoo-2-bfca9c88fb7b28e2f94e2c2188da8cdcf8e8e9a4.tar.gz
gentoo-2-bfca9c88fb7b28e2f94e2c2188da8cdcf8e8e9a4.tar.bz2
gentoo-2-bfca9c88fb7b28e2f94e2c2188da8cdcf8e8e9a4.zip
New ebuild for the Evolution Kolab groupware plugin (bug #427120, thanks to riepernet).
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/evolution-kolab')
-rw-r--r--gnome-extra/evolution-kolab/ChangeLog13
-rw-r--r--gnome-extra/evolution-kolab/evolution-kolab-3.4.3.ebuild64
-rw-r--r--gnome-extra/evolution-kolab/files/evolution-kolab-3.4.3-no-hello-world.patch27
-rw-r--r--gnome-extra/evolution-kolab/files/evolution-kolab-3.4.3-no-tests.patch51
-rw-r--r--gnome-extra/evolution-kolab/metadata.xml5
5 files changed, 160 insertions, 0 deletions
diff --git a/gnome-extra/evolution-kolab/ChangeLog b/gnome-extra/evolution-kolab/ChangeLog
new file mode 100644
index 000000000000..88926eb53daa
--- /dev/null
+++ b/gnome-extra/evolution-kolab/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for gnome-extra/evolution-kolab
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-kolab/ChangeLog,v 1.1 2012/08/13 06:14:00 tetromino Exp $
+
+*evolution-kolab-3.4.3 (13 Aug 2012)
+
+ 13 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +evolution-kolab-3.4.3.ebuild,
+ +files/evolution-kolab-3.4.3-no-hello-world.patch,
+ +files/evolution-kolab-3.4.3-no-tests.patch, +metadata.xml:
+ New ebuild for the Evolution Kolab groupware plugin (bug #427120, thanks to
+ riepernet).
+
diff --git a/gnome-extra/evolution-kolab/evolution-kolab-3.4.3.ebuild b/gnome-extra/evolution-kolab/evolution-kolab-3.4.3.ebuild
new file mode 100644
index 000000000000..585443c29c35
--- /dev/null
+++ b/gnome-extra/evolution-kolab/evolution-kolab-3.4.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-kolab/evolution-kolab-3.4.3.ebuild,v 1.1 2012/08/13 06:14:00 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Evolution module for connecting to Kolab groupware servers"
+HOMEPAGE="https://live.gnome.org/Evolution/Kolab"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="" # doc (gtk-doc fails); kerberos (does nothing useful for now)
+
+RDEPEND=">=mail-client/evolution-${PV}:2.0
+ >=gnome-extra/evolution-data-server-${PV}
+ >=dev-db/sqlite-3.7:3
+ >=dev-libs/glib-2.30:2
+ >=dev-libs/libical-0.44
+ dev-libs/libxml2
+ dev-libs/nss
+ >=gnome-base/gconf-2:2
+ >=net-libs/libsoup-2.36:2.4
+ >=net-libs/libsoup-gnome-2.36:2.4
+ >=net-misc/curl-7.19[ssl]
+ >=x11-libs/gtk+-3.2:3
+"
+DEPEND="${RDEPEND}
+ dev-util/gperf
+ >=dev-util/intltool-0.35.5
+ sys-devel/gettext
+ virtual/pkgconfig
+ dev-util/gtk-doc-am
+"
+# doc? (
+# app-text/docbook-xml-dtd:4.3
+# >=dev-util/gtk-doc-1.14 )
+# eautoreconf needs gtk-doc-am
+
+RESTRICT="test" # test suite is non-functional
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS"
+ G2CONF="${G2CONF} --without-krb5" # --with-krb5 does nothing useful
+}
+
+src_prepare() {
+ # We do not want to install a "hello world" program.
+ epatch "${FILESDIR}/${P}-no-hello-world.patch"
+ # Disable test suite: parts fail, other parsts require connection to a live
+ # kolab server, plus it installs test executables to /usr/bin
+ epatch "${FILESDIR}/${P}-no-tests.patch"
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ rm -rv "${ED}usr/doc" || die "rm failed"
+}
diff --git a/gnome-extra/evolution-kolab/files/evolution-kolab-3.4.3-no-hello-world.patch b/gnome-extra/evolution-kolab/files/evolution-kolab-3.4.3-no-hello-world.patch
new file mode 100644
index 000000000000..06ffeea50b60
--- /dev/null
+++ b/gnome-extra/evolution-kolab/files/evolution-kolab-3.4.3-no-hello-world.patch
@@ -0,0 +1,27 @@
+From 2a75e25ce2abbacd3c37f0a6ebd51e55d9f358d2 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 13 Aug 2012 01:37:42 -0400
+Subject: [PATCH 1/2] Do not build 'Hello World' program
+
+---
+ src/Makefile.am | 4 ----
+ 1 files changed, 0 insertions(+), 4 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 49b56fe..8188a11 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -10,10 +10,6 @@ SUBDIRS = \
+ eplugin \
+ tests
+
+-bin_PROGRAMS = evolution_kolab
+-
+-evolution_kolab_SOURCES = \
+- main.c
+
+ AM_CPPFLAGS = \
+ -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
+--
+1.7.8.6
+
diff --git a/gnome-extra/evolution-kolab/files/evolution-kolab-3.4.3-no-tests.patch b/gnome-extra/evolution-kolab/files/evolution-kolab-3.4.3-no-tests.patch
new file mode 100644
index 000000000000..7eacb0376b9c
--- /dev/null
+++ b/gnome-extra/evolution-kolab/files/evolution-kolab-3.4.3-no-tests.patch
@@ -0,0 +1,51 @@
+From 883cfa1e5af137444dc91739a0c6831fa43014b8 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 13 Aug 2012 01:40:01 -0400
+Subject: [PATCH 2/2] Disable test suite
+
+---
+ configure.ac | 1 -
+ src/Makefile.am | 3 +--
+ src/libekolabconv/Makefile.am | 2 +-
+ 3 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index aead4bb..ba24382 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -72,7 +72,6 @@ PKG_CHECK_MODULES(GTK, gtk+-3.0)
+ PKG_CHECK_MODULES(SOUP, libsoup-2.4 libsoup-gnome-2.4)
+ PKG_CHECK_MODULES(CURL, libcurl)
+ PKG_CHECK_MODULES(ICAL, libical)
+-PKG_CHECK_MODULES(GMIME, gmime-2.4)
+ PKG_CHECK_MODULES(EVOLUTION, evolution-plugin-3.0 libebook-1.2 libecal-1.2)
+
+ dnl ***********
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 8188a11..cf7c209 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -7,8 +7,7 @@ SUBDIRS = \
+ libekolab \
+ addressbook \
+ calendar \
+- eplugin \
+- tests
++ eplugin
+
+
+ AM_CPPFLAGS = \
+diff --git a/src/libekolabconv/Makefile.am b/src/libekolabconv/Makefile.am
+index 2de4832..dbb6411 100644
+--- a/src/libekolabconv/Makefile.am
++++ b/src/libekolabconv/Makefile.am
+@@ -1,5 +1,5 @@
+ ## Process this file with automake to produce Makefile.in
+
+-SUBDIRS = main test
++SUBDIRS = main
+
+ -include $(top_srcdir)/git.mk
+--
+1.7.8.6
+
diff --git a/gnome-extra/evolution-kolab/metadata.xml b/gnome-extra/evolution-kolab/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-extra/evolution-kolab/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>