summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-16 19:36:17 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-16 19:36:17 +0000
commit4fc0e700cb7ba6cf1c969f92e1074d3dab93ebe7 (patch)
treeb751eb5e97e44bf63f7d08d463a6b00cf637a765 /gnome-extra/bug-buddy
parentremove GAMES_LICENSE_CHECK (diff)
downloadgentoo-2-4fc0e700cb7ba6cf1c969f92e1074d3dab93ebe7.tar.gz
gentoo-2-4fc0e700cb7ba6cf1c969f92e1074d3dab93ebe7.tar.bz2
gentoo-2-4fc0e700cb7ba6cf1c969f92e1074d3dab93ebe7.zip
Revision bump to revert upstream commit that was causing gnome-session to be always running in debug mode (bug #348722), and to prevent old gnomebreakpad from trying to be loaded (bug #348351).
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/bug-buddy')
-rw-r--r--gnome-extra/bug-buddy/ChangeLog9
-rw-r--r--gnome-extra/bug-buddy/bug-buddy-2.32.0-r1.ebuild55
2 files changed, 63 insertions, 1 deletions
diff --git a/gnome-extra/bug-buddy/ChangeLog b/gnome-extra/bug-buddy/ChangeLog
index 4a2970b41917..c474525892a3 100644
--- a/gnome-extra/bug-buddy/ChangeLog
+++ b/gnome-extra/bug-buddy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/bug-buddy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/bug-buddy/ChangeLog,v 1.186 2010/10/22 19:40:13 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/bug-buddy/ChangeLog,v 1.187 2010/12/16 19:36:17 pacho Exp $
+
+*bug-buddy-2.32.0-r1 (16 Dec 2010)
+
+ 16 Dec 2010; Pacho Ramos <pacho@gentoo.org> +bug-buddy-2.32.0-r1.ebuild:
+ Revision bump to revert upstream commit that was causing gnome-session to be
+ always running in debug mode (bug #348722), and to prevent old gnomebreakpad
+ from trying to be loaded (bug #348351).
22 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
-bug-buddy-2.26.0.ebuild, -bug-buddy-2.28.0.ebuild,
diff --git a/gnome-extra/bug-buddy/bug-buddy-2.32.0-r1.ebuild b/gnome-extra/bug-buddy/bug-buddy-2.32.0-r1.ebuild
new file mode 100644
index 000000000000..26bb8d6aa0ad
--- /dev/null
+++ b/gnome-extra/bug-buddy/bug-buddy-2.32.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/bug-buddy/bug-buddy-2.32.0-r1.ebuild,v 1.1 2010/12/16 19:36:17 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+DESCRIPTION="A graphical bug reporting tool"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="Ximian-logos GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="eds"
+
+RDEPEND=">=gnome-base/libbonobo-2
+ >=dev-libs/glib-2.16:2
+ >=dev-libs/libxml2-2.4.6
+ >=x11-libs/gtk+-2.14:2
+ >=net-libs/libsoup-2.4
+ >=gnome-base/libgtop-2.13.3
+ >=gnome-base/gconf-2
+ || ( dev-libs/elfutils dev-libs/libelf )
+ >=sys-devel/gdb-5.1
+ eds? ( >=gnome-extra/evolution-data-server-1.3 )"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable eds)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Revert this commit as it causes gnome-session to always run in debug mode, bug #348722
+ EPATCH_OPTS="-R" epatch "${FILESDIR}/${PN}-2.32.0-gnomesession-debug.patch"
+}
+
+pkg_postinst() {
+ # Prevent old gnomebreakpad to be requested, bug #348351
+ local gconftool="${EROOT}usr/bin/gconftool-2"
+ local GCONF_CONFIG_SOURCE="$("${gconftool}" --get-default-source | sed "s;:/;:${ROOT};")"
+
+ "${gconftool}" --direct --config-source "${GCONF_CONFIG_SOURCE}" --type=string \
+ --set /apps/gnome_settings_daemon/gtk-modules/gnomebreakpad false || die
+
+ gnome2_pkg_postinst
+}