summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-09-08 15:12:25 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-09-08 15:12:25 +0000
commit1dea7ecca52842df7246f8643657096c1a8c1035 (patch)
tree003c160ee3155708491787a4d91c4c42cb1887dd /gnome-base
parentVersion bump. (diff)
downloadgentoo-2-1dea7ecca52842df7246f8643657096c1a8c1035.tar.gz
gentoo-2-1dea7ecca52842df7246f8643657096c1a8c1035.tar.bz2
gentoo-2-1dea7ecca52842df7246f8643657096c1a8c1035.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-desktop/ChangeLog8
-rw-r--r--gnome-base/gnome-desktop/gnome-desktop-3.8.4.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/gnome-base/gnome-desktop/ChangeLog b/gnome-base/gnome-desktop/ChangeLog
index 54cf2a6f641f..9c869ae9c304 100644
--- a/gnome-base/gnome-desktop/ChangeLog
+++ b/gnome-base/gnome-desktop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-desktop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-desktop/ChangeLog,v 1.314 2013/08/15 11:40:05 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-desktop/ChangeLog,v 1.315 2013/09/08 15:12:25 eva Exp $
+
+*gnome-desktop-3.8.4 (08 Sep 2013)
+
+ 08 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-desktop-3.8.4.ebuild:
+ Version bump.
*gnome-desktop-2.32.1-r2 (15 Aug 2013)
diff --git a/gnome-base/gnome-desktop/gnome-desktop-3.8.4.ebuild b/gnome-base/gnome-desktop/gnome-desktop-3.8.4.ebuild
new file mode 100644
index 000000000000..37093ca8b042
--- /dev/null
+++ b/gnome-base/gnome-desktop/gnome-desktop-3.8.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-desktop/gnome-desktop-3.8.4.ebuild,v 1.1 2013/09/08 15:12:25 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Libraries for the gnome desktop that are not part of the UI"
+HOMEPAGE="https://git.gnome.org/browse/gnome-desktop"
+
+LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
+SLOT="3/7" # subslot = libgnome-desktop-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x86-solaris"
+
+# cairo[X] needed for gnome-bg
+COMMON_DEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.35:2
+ >=x11-libs/gdk-pixbuf-2.21.3:2[introspection?]
+ >=x11-libs/gtk+-3.3.6:3[introspection?]
+ >=x11-libs/libXext-1.1
+ >=x11-libs/libXrandr-1.3
+ x11-libs/cairo:=[X]
+ x11-libs/libxkbfile
+ x11-libs/libX11
+ x11-misc/xkeyboard-config
+ >=gnome-base/gsettings-desktop-schemas-3.5.91
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-desktop-2.32.1-r1:2[doc]
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.6
+ sys-devel/gettext
+ x11-proto/xproto
+ >=x11-proto/randrproto-1.2
+ virtual/pkgconfig
+"
+
+# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xproto
+# Includes X11/extensions/Xrandr.h that includes randr.h from randrproto (and
+# eventually libXrandr shouldn't RDEPEND on randrproto)
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ # Note: do *not* use "--with-pnp-ids-path" argument. Otherwise, the pnp.ids
+ # file (needed by other packages such as >=gnome-settings-daemon-3.1.2)
+ # will not get installed in ${pnpdatadir} (/usr/share/libgnome-desktop-3.0).
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-distributor=Gentoo \
+ --enable-desktop-docs \
+ $(use_enable introspection) \
+ ITSTOOL=$(type -P true)
+}