summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-07-29 21:57:58 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-07-29 21:57:58 +0000
commite2c458ecba23694c8fd79130e5ef4a7c8baf451f (patch)
tree67ee23026b6aa59cc9cfd5e9f06bdaade407c531 /games-util/gslist
parentamd64 stable, bug #277722 (diff)
downloadgentoo-2-e2c458ecba23694c8fd79130e5ef4a7c8baf451f.tar.gz
gentoo-2-e2c458ecba23694c8fd79130e5ef4a7c8baf451f.tar.bz2
gentoo-2-e2c458ecba23694c8fd79130e5ef4a7c8baf451f.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'games-util/gslist')
-rw-r--r--games-util/gslist/ChangeLog10
-rw-r--r--games-util/gslist/files/gslist-0.8.8-build.patch41
-rw-r--r--games-util/gslist/gslist-0.8.8.ebuild36
-rw-r--r--games-util/gslist/metadata.xml5
4 files changed, 89 insertions, 3 deletions
diff --git a/games-util/gslist/ChangeLog b/games-util/gslist/ChangeLog
index 038695a21891..197a2ed0a607 100644
--- a/games-util/gslist/ChangeLog
+++ b/games-util/gslist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/gslist
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/ChangeLog,v 1.2 2008/03/18 01:50:59 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/ChangeLog,v 1.3 2009/07/29 21:57:58 nyhm Exp $
+
+*gslist-0.8.8 (29 Jul 2009)
+
+ 29 Jul 2009; Tristan Heaven <nyhm@gentoo.org> +gslist-0.8.8.ebuild,
+ +files/gslist-0.8.8-build.patch, metadata.xml:
+ Version bump
18 Mar 2008; Tristan Heaven <nyhm@gentoo.org>
files/gslist-0.8.2-build.patch, gslist-0.8.2.ebuild:
diff --git a/games-util/gslist/files/gslist-0.8.8-build.patch b/games-util/gslist/files/gslist-0.8.8-build.patch
new file mode 100644
index 000000000000..bd38f2006fe3
--- /dev/null
+++ b/games-util/gslist/files/gslist-0.8.8-build.patch
@@ -0,0 +1,41 @@
+--- Makefile
++++ Makefile
+@@ -1,26 +1,30 @@
+-CFLAGS += -O2 -s
++CFLAGS += -Wall -D_GNU_SOURCE
+ PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+ SRC = src/gslist.c src/enctype1_decoder.c src/enctype2_decoder.c src/enctype_shared.c src/mydownlib.c src/gsnatneg.c
+ #LIBS = -lpthread /usr/lib/libGeoIP.a /usr/lib/libz.a
+ #SQLIBS = /usr/lib/libmysqlclient.a /usr/lib/libm.a
+-SQLIBS = -lmysqlclient
+ LIBS = -lpthread -lGeoIP -lz
+ O = $(SRC:.c=.o)
+
+-all: gslist gslistsql
++ifneq ($(GSWEB),0)
++CFLAGS += -DGSWEB
++endif
++
++ifneq ($(SQL),0)
++CFLAGS += -DSQL
++LIBS += -lmysqlclient
++endif
+
+-gslist:
+- $(CC) $(SRC) $(CFLAGS) -o gslist $(LIBS) -DGSWEB
+- $(CC) $(SRC) $(CFLAGS) -o gslistsql $(SQLIBS) $(LIBS) -DGSWEB -DSQL
++gslist: $(O)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o gslist $(O) $(LIBS)
+
+ clean:
+- rm -f gslist gslistsql src/gslist.o src/enctype1_decoder.o src/enctype2_decoder.o src/enctype_shared.o src/enctypex_decoder.o src/mydownlib.o src/gsnatneg.o
++ rm -f gslist $(O)
+
+ install:
+ install -m 755 -d $(BINDIR)
+ install -m 755 gslist $(BINDIR)/gslist
+- install -m 755 gslistsql $(BINDIR)/gslistsql
+
+ .PHONY:
+ clean install
diff --git a/games-util/gslist/gslist-0.8.8.ebuild b/games-util/gslist/gslist-0.8.8.ebuild
new file mode 100644
index 000000000000..842a94ca56a1
--- /dev/null
+++ b/games-util/gslist/gslist-0.8.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/gslist-0.8.8.ebuild,v 1.1 2009/07/29 21:57:58 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="A GameSpy server browser"
+HOMEPAGE="http://aluigi.altervista.org/papers.htm#gslist"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="web"
+
+RDEPEND="dev-libs/geoip"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ emake clean
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake SQL=0 $(use web || echo GSWEB=0) || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ dodoc ${PN}.txt
+ prepgamesdirs
+}
diff --git a/games-util/gslist/metadata.xml b/games-util/gslist/metadata.xml
index d3c2cc926f0b..bda4ebb3956a 100644
--- a/games-util/gslist/metadata.xml
+++ b/games-util/gslist/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>games</herd>
+ <herd>games</herd>
+ <use>
+ <flag name='web'>Enable the web interface</flag>
+ </use>
</pkgmetadata>