summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-17 12:24:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-17 12:24:17 +0000
commit042788985597f156b4bbdb365b4e62de27c86bc3 (patch)
tree86b10c046207acfe32dd17a3e745e871cea1b1f9 /games-util/grfcodec
parentAdd ftime detection patch. Mark ~x86-fbsd. #409623 (diff)
downloadgentoo-2-042788985597f156b4bbdb365b4e62de27c86bc3.tar.gz
gentoo-2-042788985597f156b4bbdb365b4e62de27c86bc3.tar.bz2
gentoo-2-042788985597f156b4bbdb365b4e62de27c86bc3.zip
Version bump to latest release and remove overshadowed version. Needed for new openttd.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'games-util/grfcodec')
-rw-r--r--games-util/grfcodec/ChangeLog11
-rw-r--r--games-util/grfcodec/files/grfcodec-0_pre2306-build.patch144
-rw-r--r--games-util/grfcodec/grfcodec-0_pre2306.ebuild41
-rw-r--r--games-util/grfcodec/grfcodec-6.0.0.ebuild47
4 files changed, 56 insertions, 187 deletions
diff --git a/games-util/grfcodec/ChangeLog b/games-util/grfcodec/ChangeLog
index 0021932d1059..76b1bbaa5eff 100644
--- a/games-util/grfcodec/ChangeLog
+++ b/games-util/grfcodec/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-util/grfcodec
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/ChangeLog,v 1.10 2011/07/23 16:42:43 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/ChangeLog,v 1.11 2012/04/17 12:24:17 scarabeus Exp $
+
+*grfcodec-6.0.0 (17 Apr 2012)
+
+ 17 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org> +grfcodec-6.0.0.ebuild,
+ -files/grfcodec-0_pre2306-build.patch, -grfcodec-0_pre2306.ebuild:
+ Version bump to latest release and remove overshadowed version. Needed for new
+ openttd.
23 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> grfcodec-5.1.1.ebuild:
ppc/ppc64 stable wrt #375387
diff --git a/games-util/grfcodec/files/grfcodec-0_pre2306-build.patch b/games-util/grfcodec/files/grfcodec-0_pre2306-build.patch
deleted file mode 100644
index 3cde281527c8..000000000000
--- a/games-util/grfcodec/files/grfcodec-0_pre2306-build.patch
+++ /dev/null
@@ -1,144 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 50e420c..c0e877b 100644
---- a/Makefile
-+++ b/Makefile
-@@ -62,29 +62,32 @@ endif
- else
- INSTALLPATH=$(INSTALLPATH_MSYS_MINGW)
- endif
--else
-+else
- INSTALLPATH=$(INSTALLPATH_LINUX)
- endif
- endif
-
- # use 386 instructions but optimize for pentium II/III
--CFLAGS = -g -D$(TYPESIZE) -O3 -I. -O1 -idirafter$(BOOST_INCLUDE) -Wall -Wno-uninitialized $(CFLAGAPP)
-+CFLAGS += -D$(TYPESIZE) -I. -idirafter$(BOOST_INCLUDE) -Wall -Wno-uninitialized
-+CXXFLAGS += -D$(TYPESIZE) -I. -idirafter$(BOOST_INCLUDE) -Wall -Wno-uninitialized
-
- ifeq ($(DEBUG),1)
- CFLAGS += -DDEBUG
-+CXXFLAGS += -DDEBUG
- endif
-
- ifeq ($(MACHINE),mingw32)
- CFLAGS += -DMINGW
-+CXXFLAGS += -DMINGW
- endif
-
- ifeq ($(ISCYGWIN),1)
- ifeq ($(NOCYGWIN),1)
- CFLAGS += -DMINGW -mno-cygwin
-+CXXFLAGS += -DMINGW -mno-cygwin
- endif
- endif
-
--CXXFLAGS = $(CFLAGS)
-
-
- # Somewhat automatic detection of the correct boost include folder
-@@ -171,7 +174,7 @@ endif
- PAL_FILES = pals/$(subst &,.bcp pals/,$(PALORDER)).bcp
-
- # deafult targets
--all: $(GRFCODEC) $(GRFDIFF) $(GRFMERGE)
-+all: version.h $(GRFCODEC) $(GRFDIFF) $(GRFMERGE)
- remake: clean all
-
- ${MAKEFILELOCAL}:
-@@ -181,15 +184,15 @@ ${MAKEFILELOCAL}:
-
- $(GRFCODEC): $(GRFCODECSRC:%.c=%.o)
- $(_E) [LD] $@
-- $(_C)$(CXX) -o $@ $(CFLAGS) $^ $(LDOPT)
-+ $(_C)$(CXX) -o $@ $(CXXFLAGS) $^ $(LDOPT)
-
- $(GRFDIFF): $(GRFDIFFSRC:%.c=%.o) grfmrg.o
- $(_E) [LD] $@
-- $(_C)$(CXX) -o $@ $(CFLAGS) $^ $(LDOPT)
-+ $(_C)$(CXX) -o $@ $(CXXFLAGS) $^ $(LDOPT)
-
- $(GRFMERGE): $(GRFMERGESRC:%.c=%.o)
- $(_E) [LD] $@
-- $(_C)$(CXX) -o $@ $(CFLAGS) $^ $(LDOPT)
-+ $(_C)$(CXX) -o $@ $(CXXFLAGS) $^ $(LDOPT)
-
-
- clean:
-@@ -219,9 +222,7 @@ FORCE:
- $(_E) [REBUILD] $(@:%_r=%)
- $(_C)rm -f $(@:%_r=%)
- $(_C)$(MAKE) ${_S} $(@:%_r=%)
-- $(_E) [STRIP/UPX] $(@:%_r=%)
- $(_C)$(STRIP) $(@:%_r=%)
-- $(_C)upx $(_Q) --best $(@:%_r=%)
-
- release: $(GRFCODEC)_r $(GRFDIFF)_r $(GRFMERGE)_r
-
-@@ -230,9 +231,7 @@ grfmrgc.bin: grfmerge.os $(GRFMERGESRC:%.c=%.os)
- $(_C)rm -f $@
- $(_E) [LD] $@
- $(_C)$(CC) -o $@ $(CFLAGS) -Os $^
-- $(_E) [STRIP/UPX] $@
- $(_C)$(STRIP) $@
-- $(_C)upx $(_Q) --best $@
-
- grfmrg.c: grfmrgc.bin grfmrgc.pl
- $(_E) [PERL] $@
-@@ -291,15 +290,18 @@ ttdpal.h: $(PAL_FILES) pal2c.pl
-
- %.o.d:
- $(_E) [CPP DEP] $@
-- $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG $*.c* -MF $@
-+ $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG error.c getopt.c grfcomm.c grfmerge.c path.c -MF $@
-+ $(_C)$(CXX) $(CXXFLAGS) -DMAKEDEP -MM -MG file.cc grfcodec.cc grfdiff.cc info.cc pcxfile.cc pcxsprit.cc readinfo.cc sprites.cc -MF $@
-
- %.os.d:
- $(_E) [CPP DEP] $@
-- $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ $*.c*
-+ $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ error.c getopt.c grfcomm.c grfmerge.c path.c
-+ $(_C)$(CXX) $(CXXFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ file.cc grfcodec.cc grfdiff.cc info.cc pcxfile.cc pcxsprit.cc readinfo.cc sprites.cc
-
--%.obj.d: $(wildcard %.c*)
-+%.obj.d:
- $(_E) [CPP DEP] $@
-- $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ $*.c*
-+ $(_C)$(CC) $(CFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ error.c getopt.c grfcomm.c grfmerge.c path.c
-+ $(_C)$(CXX) $(CXXFLAGS) -DMAKEDEP -MM -MG -MT ${subst .d,,$@} -MF $@ file.cc grfcodec.cc grfdiff.cc info.cc pcxfile.cc pcxsprit.cc readinfo.cc sprites.cc
-
- ifndef NO_MAKEFILE_DEP
- -include $(GRFCODECSRC:%.c=%.o.d)
-diff --git a/Makefile.common b/Makefile.common
-index c559c0a..fe99591 100644
---- a/Makefile.common
-+++ b/Makefile.common
-@@ -5,9 +5,7 @@ FORCE:
- $(_E) [REBUILD] $(@:%_r=%)
- $(_C)rm -f $(@:%_r=%)$(EXE)
- $(_C)make -f $(MAKEFILE) $(_S) $(@:%_r=%)
-- $(_E) [STRIP/UPX] $(@:%_r=%)
- $(_C)strip $(@:%_r=%)$(REL_EXE)
-- $(_C)upx $(_Q) --best $(@:%_r=%)$(REL_EXE)
-
- release: grfcodec_r grfdiff_r grfmerge_r
-
-@@ -16,9 +14,7 @@ grfmrgc.bin: grfmerge.os $(GRFMERGESRC:%.c=%.os)
- $(_C)rm -f $@
- $(_E) [LD] $@
- $(_C)$(CC) -o $@ $(CFLAGS) -Os $^
-- $(_E) [STRIP/UPX] $@
- $(_C)strip $@
-- $(_C)upx $(_Q) --best $@
-
- grfmrg.c: grfmrgc.bin grfmrgc.pl
- $(_E) [PERL] $@
-@@ -32,7 +28,7 @@ ttdpal.h: $(PAL_FILES) pal2c.pl
-
- readinfo.o: readinfo.cc
- $(_E) [CPP] $@
-- $(BOOST_WARN)
-+ $(BOOST_WARN)
- $(_C)$(CXX) -c -o $@ -MMD -MG -MF $@.d $(CXXFLAGS) $<
-
- %.o : %.c
diff --git a/games-util/grfcodec/grfcodec-0_pre2306.ebuild b/games-util/grfcodec/grfcodec-0_pre2306.ebuild
deleted file mode 100644
index 0cfee6e6043e..000000000000
--- a/games-util/grfcodec/grfcodec-0_pre2306.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/grfcodec-0_pre2306.ebuild,v 1.7 2010/10/15 13:49:56 maekke Exp $
-
-EAPI=2
-inherit eutils toolchain-funcs
-
-MY_PV=${PV/0_pre/r}
-DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
-HOMEPAGE="http://binaries.openttd.org/extra/grfcodec/"
-SRC_URI="http://binaries.openttd.org/extra/grfcodec/${MY_PV}/${PN}-${MY_PV}-source.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE=""
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DEPEND="dev-lang/perl
- dev-libs/boost"
-RDEPEND=""
-
-src_prepare() {
- cat > Makefile.local <<-__EOF__
- CC = $(tc-getCC)
- CXX = $(tc-getCXX)
- CFLAGS = ${CFLAGS}
- CXXFLAGS = ${CXXFLAGS}
- LDOPT = ${LDFLAGS}
- STRIP = :
- V = 1
- __EOF__
-
- epatch "${FILESDIR}"/${P}-build.patch
-}
-
-src_install() {
- dobin ${PN} grf{diff,merge} || die
- dodoc *.txt Changelog || die
-}
diff --git a/games-util/grfcodec/grfcodec-6.0.0.ebuild b/games-util/grfcodec/grfcodec-6.0.0.ebuild
new file mode 100644
index 000000000000..294b518c81af
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-6.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/grfcodec-6.0.0.ebuild,v 1.1 2012/04/17 12:24:17 scarabeus Exp $
+
+EAPI=4
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=mercurial
+ EHG_REPO_URI="http://hg.openttdcoop.org/${PN}"
+fi
+
+inherit toolchain-funcs ${SCM}
+
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/grfcodec"
+[[ -z ${SCM} ]] && SRC_URI="http://binaries.openttd.org/extra/${PN}/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+[[ -n ${SCM} ]] && S=${WORKDIR}/${PN}
+
+DEPEND="!games-util/nforenum
+ dev-lang/perl
+ dev-libs/boost
+ media-libs/libpng"
+RDEPEND=""
+
+src_prepare() {
+# Set up Makefile.local so that we respect CXXFLAGS/LDFLAGS
+cat > Makefile.local <<-__EOF__
+ CXX = $(tc-getCXX)
+ CXXFLAGS = ${CXXFLAGS}
+ LDOPT = ${LDFLAGS}
+ UPX =
+ V = 1
+ FLAGS=
+ __EOF__
+}
+
+src_install() {
+ dobin ${PN} grf{diff,id,merge} nforenum
+ doman docs/*.1
+ dodoc changelog.txt docs/*.txt
+}