summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-01-22 20:16:13 +0000
committerHanno Böck <hanno@gentoo.org>2010-01-22 20:16:13 +0000
commite1d2ba9484b93b4fcef5819cea3ce6e3e046a30d (patch)
tree2d57e81e65d5ae0e876fdfbfb354a14eb699a365 /games-util/dzip/dzip-2.9-r3.ebuild
parentstable ppc, bug 285395 (diff)
downloadgentoo-2-e1d2ba9484b93b4fcef5819cea3ce6e3e046a30d.tar.gz
gentoo-2-e1d2ba9484b93b4fcef5819cea3ce6e3e046a30d.tar.bz2
gentoo-2-e1d2ba9484b93b4fcef5819cea3ce6e3e046a30d.zip
dzip fix zlib segfaults and 64 bit breakage
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'games-util/dzip/dzip-2.9-r3.ebuild')
-rw-r--r--games-util/dzip/dzip-2.9-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/dzip/dzip-2.9-r3.ebuild b/games-util/dzip/dzip-2.9-r3.ebuild
new file mode 100644
index 000000000000..7ae8bd0b980b
--- /dev/null
+++ b/games-util/dzip/dzip-2.9-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/dzip/dzip-2.9-r3.ebuild,v 1.1 2010/01/22 20:16:12 hanno Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="compressor/uncompressor for demo recordings from id's Quake"
+HOMEPAGE="http://speeddemosarchive.com/dzip/"
+SRC_URI="http://speeddemosarchive.com/dzip/dz${PV/./}src.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-system-zlib-r2.patch
+ epatch "${FILESDIR}"/${P}-scrub-names.patch #93079
+ epatch "${FILESDIR}/dzip-amd64.diff"
+ mv -f Makefile{.linux,}
+}
+
+src_install () {
+ dobin dzip || die "dobin failed"
+ dodoc Readme || die "dodoc failed"
+}