summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-02 22:09:29 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-02 22:09:29 +0000
commitf1b040097a372fb7f4ca924dbe01bac3beb51ba4 (patch)
tree61f243854d7403d9c6e08f71a9f9471517d3e8a2 /games-strategy
parentamd64 stable, bug #224221 (diff)
downloadgentoo-2-f1b040097a372fb7f4ca924dbe01bac3beb51ba4.tar.gz
gentoo-2-f1b040097a372fb7f4ca924dbe01bac3beb51ba4.tar.bz2
gentoo-2-f1b040097a372fb7f4ca924dbe01bac3beb51ba4.zip
Revision bump to fix a number of bugs. Among those are: GCC-4.{2,3} support, subtle python crashes and varied typoes. Also closes bug 220409. Dropped ppc keywords, a bug to readd them in the works.
(Portage version: 2.1.5.3)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boson/ChangeLog11
-rw-r--r--games-strategy/boson/boson-0.13-r1.ebuild51
2 files changed, 60 insertions, 2 deletions
diff --git a/games-strategy/boson/ChangeLog b/games-strategy/boson/ChangeLog
index 8aa697f120b8..e05a8dcf85d2 100644
--- a/games-strategy/boson/ChangeLog
+++ b/games-strategy/boson/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-strategy/boson
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/ChangeLog,v 1.31 2007/10/12 09:53:37 pylon Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/ChangeLog,v 1.32 2008/06/02 22:09:29 loki_val Exp $
+
+*boson-0.13-r1 (02 Jun 2008)
+
+ 02 Jun 2008; Peter Alfredsen <loki_val@gentoo.org> +boson-0.13-r1.ebuild:
+ Revision bump to fix a number of bugs. Among those are: GCC-4.{2,3}
+ support, subtle python crashes and varied typoes. Also closes bug 220409.
+ Dropped ppc keywords, a bug to readd them in the works.
12 Oct 2007; Lars Weiler <pylon@gentoo.org> boson-0.13.ebuild:
stable ppc, bug #195007
diff --git a/games-strategy/boson/boson-0.13-r1.ebuild b/games-strategy/boson/boson-0.13-r1.ebuild
new file mode 100644
index 000000000000..9692abe0e731
--- /dev/null
+++ b/games-strategy/boson/boson-0.13-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/boson-0.13-r1.ebuild,v 1.1 2008/06/02 22:09:29 loki_val Exp $
+
+inherit eutils flag-o-matic kde-functions cmake-utils
+
+MY_P=${PN}-all-${PV}
+DESCRIPTION="real-time strategy game, with the feeling of Command&Conquer(tm)"
+HOMEPAGE="http://boson.sourceforge.net/"
+SRC_URI="mirror://sourceforge/boson/${MY_P}.tar.bz2
+ mirror://gentoo/${P}-patches.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/openal"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.6-r1
+ app-text/docbook-to-man"
+
+need-kde 3
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="code/AUTHORS code/ChangeLog code/README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_SOURCE="${WORKDIR}/${P}-patches"
+ EPATCH_SUFFIX="patch"
+ epatch
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ for sgmlman in "${WORKDIR}/${P}-patches"/man-pages/*.sgml; do
+ docbook-to-man "${sgmlman}" > "${sgmlman%.sgml}".6 || die
+ doman "${sgmlman%.sgml}".6 || die
+ done
+}