summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-16 21:54:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-16 21:54:47 +0000
commit528f59ab4976245abc14d3efce08cdf3b99f73bc (patch)
tree1860aa0e62b288b826b447a535de9c1e828fc16a /games-strategy
parentChanged ebuild ... config to emerge --config for bug #109482. (diff)
downloadgentoo-2-528f59ab4976245abc14d3efce08cdf3b99f73bc.tar.gz
gentoo-2-528f59ab4976245abc14d3efce08cdf3b99f73bc.tar.bz2
gentoo-2-528f59ab4976245abc14d3efce08cdf3b99f73bc.zip
Fix by ph for build error with gcc-3.x #109476 by Mike Bonar.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/lgeneral/ChangeLog8
-rw-r--r--games-strategy/lgeneral/files/lgeneral-1.2_beta6-gcc3.patch14
-rw-r--r--games-strategy/lgeneral/lgeneral-1.2_beta6.ebuild5
3 files changed, 23 insertions, 4 deletions
diff --git a/games-strategy/lgeneral/ChangeLog b/games-strategy/lgeneral/ChangeLog
index 46aadd9e41e5..7432c982e7da 100644
--- a/games-strategy/lgeneral/ChangeLog
+++ b/games-strategy/lgeneral/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/lgeneral
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/lgeneral/ChangeLog,v 1.15 2005/10/15 04:04:19 mr_bones_ Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/lgeneral/ChangeLog,v 1.16 2005/10/16 21:54:47 vapier Exp $
+
+ 16 Oct 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/lgeneral-1.2_beta6-gcc3.patch, lgeneral-1.2_beta6.ebuild:
+ Fix by ph for build error with gcc-3.x #109476 by Mike Bonar.
*lgeneral-1.2_beta6 (15 Oct 2005)
diff --git a/games-strategy/lgeneral/files/lgeneral-1.2_beta6-gcc3.patch b/games-strategy/lgeneral/files/lgeneral-1.2_beta6-gcc3.patch
new file mode 100644
index 000000000000..8106249dce51
--- /dev/null
+++ b/games-strategy/lgeneral/files/lgeneral-1.2_beta6-gcc3.patch
@@ -0,0 +1,14 @@
+Patch by Mike Bonar to fix building with newer gcc versions
+
+http://bugs.gentoo.org/109476
+
+--- src/main.c
++++ src/main.c
+@@ -136,7 +136,6 @@
+ case 'h':
+ if (ctlspec[1] == 0 || strcasecmp(ctlspec, "human") == 0) ctl = PLAYER_CTRL_HUMAN;
+ break;
+- default:
+ }
+ if (ctl != PLAYER_CTRL_CPU && ctl != PLAYER_CTRL_HUMAN)
+ abortf("Invalid player control: %s\n", ctlspec);
diff --git a/games-strategy/lgeneral/lgeneral-1.2_beta6.ebuild b/games-strategy/lgeneral/lgeneral-1.2_beta6.ebuild
index 6aac19fc1095..4c8600c6be7f 100644
--- a/games-strategy/lgeneral/lgeneral-1.2_beta6.ebuild
+++ b/games-strategy/lgeneral/lgeneral-1.2_beta6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/lgeneral/lgeneral-1.2_beta6.ebuild,v 1.1 2005/10/15 04:04:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/lgeneral/lgeneral-1.2_beta6.ebuild,v 1.2 2005/10/16 21:54:47 vapier Exp $
inherit eutils games
@@ -25,7 +25,8 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
cd "${S}"
- #epatch "${FILESDIR}"/${PV}-gcc4.patch
+ epatch "${FILESDIR}"/${PV}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-gcc3.patch #109476
# Build a temporary lgc-pg that knows about /var/tmp/portage in work/lgc-pg:
cp -pPR "${S}" "${WORKDIR}/lgc-pg" || die "cp failed."
}