summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-12-24 15:36:37 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-12-24 15:36:37 +0000
commit21322278cad76f7c5e78e69fa11cd26164bea5c6 (patch)
tree79e8c3e46404c4c5bb6b8e4a4048a8e50670b84b /games-strategy
parentFix against ghc-7.6. (diff)
downloadgentoo-2-21322278cad76f7c5e78e69fa11cd26164bea5c6.tar.gz
gentoo-2-21322278cad76f7c5e78e69fa11cd26164bea5c6.tar.bz2
gentoo-2-21322278cad76f7c5e78e69fa11cd26164bea5c6.zip
Use QA_PREBUILT. Bug #429504
(Portage version: 2.1.11.38/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/majesty-demo/ChangeLog5
-rw-r--r--games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild19
2 files changed, 14 insertions, 10 deletions
diff --git a/games-strategy/majesty-demo/ChangeLog b/games-strategy/majesty-demo/ChangeLog
index 924ac781ff7f..c0ee6d2a4fcd 100644
--- a/games-strategy/majesty-demo/ChangeLog
+++ b/games-strategy/majesty-demo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/majesty-demo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/majesty-demo/ChangeLog,v 1.11 2012/02/08 21:33:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/majesty-demo/ChangeLog,v 1.12 2012/12/24 15:36:37 tupone Exp $
+
+ 24 Dec 2012; Tupone Alfredo <tupone@gentoo.org> majesty-demo-1.0.0.ebuild:
+ Use QA_PREBUILT. Bug #429504 by Diego Elio Pettenò
08 Feb 2012; Mike Frysinger <vapier@gentoo.org> majesty-demo-1.0.0.ebuild:
Move to new unpacker eclass for unpack_makeself.
diff --git a/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild b/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild
index e14beddabe15..70cec7d3f176 100644
--- a/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild
+++ b/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild,v 1.12 2012/02/08 21:33:05 vapier Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/majesty-demo/majesty-demo-1.0.0.ebuild,v 1.13 2012/12/24 15:36:37 tupone Exp $
+EAPI=4
inherit eutils unpacker games
DESCRIPTION="Control your own kingdom in this simulation."
@@ -33,20 +33,21 @@ S=${WORKDIR}
dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/maj_demo"
src_install() {
- dodoc README* || die "dodoc"
+ dodoc README*
insinto "${dir}"
exeinto "${dir}"
- doins -r data quests || die "doins data"
- doins majesty.{bmp,xpm} majestysite.url || die "doins"
- cp "${S}"/majesty.xpm "${S}"/majesty-demo.xpm || die "copy icon"
- doicon majesty-demo.xpm || die "doicon"
+ doins -r data quests
+ doins majesty.{bmp,xpm} majestysite.url
+ cp "${S}"/majesty.xpm "${S}"/majesty-demo.xpm
+ doicon majesty-demo.xpm
# I am only installing the static version for now
if use x86 || use amd64; then
- doexe bin/Linux/x86/glibc-2.1/maj_demo || die "doexe"
+ doexe bin/Linux/x86/glibc-2.1/maj_demo
elif use ppc; then
- doexe bin/Linux/ppc/glibc-2.1/maj_demo || die "doexe"
+ doexe bin/Linux/ppc/glibc-2.1/maj_demo
fi
games_make_wrapper maj_demo ./maj_demo "${dir}" "${dir}"
prepgamesdirs