summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-10 04:25:54 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-10 04:25:54 +0000
commit186bc878b563398cedf06b9cd0769fceeee87b59 (patch)
tree958b4fcaea8e363b8d827989fc589aa005c3dd23 /games-sports
parentPulling 0.11.8. Force >=xfree-4.3.0-r4, so it doesn't overwrite files xfree p... (diff)
downloadgentoo-2-186bc878b563398cedf06b9cd0769fceeee87b59.tar.gz
gentoo-2-186bc878b563398cedf06b9cd0769fceeee87b59.tar.bz2
gentoo-2-186bc878b563398cedf06b9cd0769fceeee87b59.zip
ver bump
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/foobillard/ChangeLog7
-rw-r--r--games-sports/foobillard/files/digest-foobillard-2.91
-rw-r--r--games-sports/foobillard/foobillard-2.9.ebuild46
3 files changed, 53 insertions, 1 deletions
diff --git a/games-sports/foobillard/ChangeLog b/games-sports/foobillard/ChangeLog
index 97daa0cc146c..5dc0319d453e 100644
--- a/games-sports/foobillard/ChangeLog
+++ b/games-sports/foobillard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/foobillard
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.2 2003/09/12 15:38:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.3 2003/11/10 04:25:54 vapier Exp $
+
+*foobillard-2.9 (09 Nov 2003)
+
+ 09 Nov 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*foobillard-2.8 (17 Jul 2003)
diff --git a/games-sports/foobillard/files/digest-foobillard-2.9 b/games-sports/foobillard/files/digest-foobillard-2.9
new file mode 100644
index 000000000000..99aeed7b750a
--- /dev/null
+++ b/games-sports/foobillard/files/digest-foobillard-2.9
@@ -0,0 +1 @@
+MD5 b8b10d7d3ade07a9e0c497165beadbca foobillard-2.9.tar.gz 1136620
diff --git a/games-sports/foobillard/foobillard-2.9.ebuild b/games-sports/foobillard/foobillard-2.9.ebuild
new file mode 100644
index 000000000000..0ed9782c7869
--- /dev/null
+++ b/games-sports/foobillard/foobillard-2.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-2.9.ebuild,v 1.1 2003/11/10 04:25:54 vapier Exp $
+
+inherit games
+
+DESCRIPTION="8ball, 9ball, snooker and carambol game"
+HOMEPAGE="http://foobillard.sunsite.dk/"
+SRC_URI="http://foobillard.sunsite.dk/dnl/${P}.tar.gz"
+
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="sdl"
+
+DEPEND="virtual/x11
+ virtual/opengl
+ >=media-libs/freetype-2.0.9
+ >=media-libs/libpng-1.2.1
+ || (
+ sdl? ( media-libs/libsdl )
+ ( virtual/glu virtual/glut )
+ )"
+
+src_compile() {
+ local myconf=""
+ [ "`ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5`" == "nvidia" ] \
+ && myconf="--enable-nvidia" \
+ || myconf="--disable-nvidia"
+ myconf="${myconf} `use_enable sdl SDL`"
+ use sdl \
+ && myconf="${myconf} --disable-glut" \
+ || myconf="${myconf} --enable-glut"
+
+ egamesconf \
+ --enable-sound \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README README.FONTS AUTHORS NEWS ChangeLog
+ prepgamesdirs
+}