summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-12 16:48:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-12 16:48:07 +0000
commite70f3b58bac31f15e3f6aa65d9342b04ffc5fb2d (patch)
tree89d894a8c27f881315434280066bebcacb6b7ab4 /games-simulation
parentx86 stable (diff)
downloadgentoo-2-e70f3b58bac31f15e3f6aa65d9342b04ffc5fb2d.tar.gz
gentoo-2-e70f3b58bac31f15e3f6aa65d9342b04ffc5fb2d.tar.bz2
gentoo-2-e70f3b58bac31f15e3f6aa65d9342b04ffc5fb2d.zip
Install menu entry, bug #159849
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/cannonsmash/ChangeLog7
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild22
2 files changed, 16 insertions, 13 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index df305fae0013..d34ca45a297e 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/cannonsmash
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.16 2006/11/03 03:03:09 nyhm Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.17 2007/03/12 16:48:07 nyhm Exp $
+
+ 12 Mar 2007; Tristan Heaven <nyhm@gentoo.org> cannonsmash-0.6.6.ebuild:
+ Install menu entry, bug #159849
03 Nov 2006; Tristan Heaven <nyhm@gentoo.org> cannonsmash-0.6.6.ebuild:
Add nls dependencies
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index ae9e0358d07d..c976d1120cae 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.12 2006/11/03 03:03:09 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.13 2007/03/12 16:48:07 nyhm Exp $
inherit eutils games
MY_OGG=danslatristesse2-48.ogg
DESCRIPTION="3D tabletennis game"
HOMEPAGE="http://cannonsmash.sourceforge.net/"
-SRC_URI="mirror://sourceforge/cannonsmash/csmash-${PV}.tar.gz
+SRC_URI="mirror://sourceforge/${PN}/csmash-${PV}.tar.gz
vorbis? ( http://nan.p.utmc.or.jp/${MY_OGG} )"
LICENSE="GPL-2"
@@ -15,12 +15,11 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="vorbis nls"
-RDEPEND="x11-libs/libXmu
- virtual/opengl
+RDEPEND="virtual/opengl
virtual/glu
- >=media-libs/libsdl-1.2.4
- >=media-libs/sdl-mixer-1.2.3
- >=media-libs/sdl-image-1.2.2
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
=x11-libs/gtk+-2*
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
@@ -36,10 +35,9 @@ src_unpack() {
"${FILESDIR}"/${P}-sizeof-cast.patch \
"${FILESDIR}"/${P}-gcc41.patch
if use vorbis ; then
- cp "${DISTDIR}"/${MY_OGG} "${S}"/ || die "cp failed"
sed -i \
-e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
- || die "setting ogg loc"
+ || die "sed failed"
fi
}
@@ -57,8 +55,10 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
if use vorbis ; then
insinto "${GAMES_DATADIR}"/csmash
- doins ${MY_OGG} || die "doins failed"
+ doins "${DISTDIR}"/${MY_OGG} || die "doins failed"
fi
+ newicon win32/orange.ico ${PN}.ico
+ make_desktop_entry csmash "Cannon Smash" /usr/share/pixmaps/${PN}.ico
dodoc AUTHORS CREDITS README*
prepgamesdirs
}