summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-06-29 11:31:56 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-06-29 11:31:56 +0000
commitc3cb0f43a34eb42699b83ee05f3c8a63fbf575df (patch)
treec14c1ae9df20b778a4b5875fc437b3c450c6863c /games-simulation
parentIntroduce this driver as requested by M.A.R. Osorio via mail (diff)
downloadgentoo-2-c3cb0f43a34eb42699b83ee05f3c8a63fbf575df.tar.gz
gentoo-2-c3cb0f43a34eb42699b83ee05f3c8a63fbf575df.tar.bz2
gentoo-2-c3cb0f43a34eb42699b83ee05f3c8a63fbf575df.zip
Ported to python-single-r1 (used funnyboat-1.5-r1 as an example). Added workaround to stable ebuild to run python2 (bug #381809 by Chris Mayo).
(Portage version: 2.2.0_alpha182_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/singularity/ChangeLog9
-rw-r--r--games-simulation/singularity/singularity-0.30c-r1.ebuild48
-rw-r--r--games-simulation/singularity/singularity-0.30c.ebuild8
3 files changed, 61 insertions, 4 deletions
diff --git a/games-simulation/singularity/ChangeLog b/games-simulation/singularity/ChangeLog
index eadac36a01cb..310207c3b229 100644
--- a/games-simulation/singularity/ChangeLog
+++ b/games-simulation/singularity/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-simulation/singularity
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/ChangeLog,v 1.21 2013/02/07 22:16:13 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/ChangeLog,v 1.22 2013/06/29 11:31:56 slyfox Exp $
+
+*singularity-0.30c-r1 (29 Jun 2013)
+
+ 29 Jun 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +singularity-0.30c-r1.ebuild, singularity-0.30c.ebuild:
+ Ported to python-single-r1 (used funnyboat-1.5-r1 as an example). Added
+ workaround to stable ebuild to run python2 (bug #381809 by Chris Mayo).
07 Feb 2013; Ulrich Müller <ulm@gentoo.org> singularity-0.30c.ebuild:
Move Creative Commons licenses to shorter names.
diff --git a/games-simulation/singularity/singularity-0.30c-r1.ebuild b/games-simulation/singularity/singularity-0.30c-r1.ebuild
new file mode 100644
index 000000000000..ce847aeb8c5a
--- /dev/null
+++ b/games-simulation/singularity/singularity-0.30c-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/singularity-0.30c-r1.ebuild,v 1.1 2013/06/29 11:31:56 slyfox Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+inherit eutils python-single-r1 games
+
+MUSIC=endgame-${PN}-music-006
+DESCRIPTION="A simulation of a true AI. Go from computer to computer, pursued by the entire world"
+HOMEPAGE="http://www.emhsoft.com/singularity/"
+SRC_URI="http://endgame-singularity.googlecode.com/files/${P}-src.tar.gz
+ music? ( http://endgame-singularity.googlecode.com/files/${MUSIC}.zip )"
+
+LICENSE="GPL-2 CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+music"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ media-libs/sdl-mixer[vorbis]"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ rm -f code/{,*}/*.pyc data/*.html || die # Remove unecessary files
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r code data ${PN}.py || die "doins failed"
+ python_optimize "${ED%/}/${GAMES_DATADIR}"/${PN}
+
+ if use music ; then
+ doins -r ../${MUSIC}/music || die "doins failed"
+ fi
+ games_make_wrapper ${PN} "${EPYTHON} ${PN}.py" "${GAMES_DATADIR}/${PN}"
+ dodoc README.txt TODO Changelog AUTHORS
+ prepgamesdirs
+}
diff --git a/games-simulation/singularity/singularity-0.30c.ebuild b/games-simulation/singularity/singularity-0.30c.ebuild
index 4a635dc96142..2237294f1c4c 100644
--- a/games-simulation/singularity/singularity-0.30c.ebuild
+++ b/games-simulation/singularity/singularity-0.30c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/singularity-0.30c.ebuild,v 1.4 2013/02/07 22:16:13 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/singularity-0.30c.ebuild,v 1.5 2013/06/29 11:31:56 slyfox Exp $
EAPI=2
inherit eutils games
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="+music"
-RDEPEND="dev-python/pygame
+RDEPEND="=dev-lang/python-2*
+ dev-python/pygame
media-libs/sdl-mixer[vorbis]"
DEPEND="${RDEPEND}
app-arch/unzip"
@@ -31,7 +32,8 @@ src_install() {
if use music ; then
doins -r ../${MUSIC}/music || die "doins failed"
fi
- games_make_wrapper ${PN} "python ${PN}.py" "${GAMES_DATADIR}/${PN}"
+ # uses python-2 style exceptions
+ games_make_wrapper ${PN} "python2 ${PN}.py" "${GAMES_DATADIR}/${PN}"
dodoc README.txt TODO Changelog AUTHORS
prepgamesdirs
}