summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-08-04 14:27:56 +0000
committerLars Weiler <pylon@gentoo.org>2007-08-04 14:27:56 +0000
commit7d33efedef2cac5b5c26a9ea6476192bf05141dd (patch)
tree220ecad3da3ae948f6fb403a230dc10e7ce61e5f /games-simulation
parentCleanup. (diff)
downloadgentoo-2-7d33efedef2cac5b5c26a9ea6476192bf05141dd.tar.gz
gentoo-2-7d33efedef2cac5b5c26a9ea6476192bf05141dd.tar.bz2
gentoo-2-7d33efedef2cac5b5c26a9ea6476192bf05141dd.zip
More cleanup — with UTF-8 character in ChangeLog…
(Portage version: 2.1.3.2)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog5
-rw-r--r--games-simulation/openttd/files/digest-openttd-0.5.06
-rw-r--r--games-simulation/openttd/openttd-0.5.0.ebuild188
3 files changed, 4 insertions, 195 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index e7665104f127..23b4a929dac2 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.47 2007/08/04 14:25:38 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.48 2007/08/04 14:27:56 pylon Exp $
+
+ 04 Aug 2007; Lars Weiler <pylon@gentoo.org> -openttd-0.5.0.ebuild:
+ More cleanup — with UTF-8 character in ChangeLog…
04 Aug 2007; Lars Weiler <pylon@gentoo.org> -openttd-0.4.8.ebuild:
Cleanup.
diff --git a/games-simulation/openttd/files/digest-openttd-0.5.0 b/games-simulation/openttd/files/digest-openttd-0.5.0
deleted file mode 100644
index 5dc073d05659..000000000000
--- a/games-simulation/openttd/files/digest-openttd-0.5.0
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 37892f1fdded957f956766642a9e877d openttd-0.5.0-scenarios.tar.bz2 917117
-RMD160 f6ea4a4004bb0c90de9283a92b14da4bd99bc33c openttd-0.5.0-scenarios.tar.bz2 917117
-SHA256 c89e652aca1a9ad9f0f4936dd99cd8a9c96f4c53450990ff87d87483f8e74a31 openttd-0.5.0-scenarios.tar.bz2 917117
-MD5 39f77afae6f4a8ba245c4f7a51b2692a openttd-0.5.0-source.tar.bz2 3029813
-RMD160 7da82a6ab3bf58fd59dfef46920d15271e722682 openttd-0.5.0-source.tar.bz2 3029813
-SHA256 dec6761a291fa48e52911485d465689c3622c4eec9e66732bb9713e69220885c openttd-0.5.0-source.tar.bz2 3029813
diff --git a/games-simulation/openttd/openttd-0.5.0.ebuild b/games-simulation/openttd/openttd-0.5.0.ebuild
deleted file mode 100644
index b2d29229f2e0..000000000000
--- a/games-simulation/openttd/openttd-0.5.0.ebuild
+++ /dev/null
@@ -1,188 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.0.ebuild,v 1.4 2007/05/26 12:10:23 opfer Exp $
-
-inherit eutils games
-
-SCENARIOS="${P}-scenarios.tar.bz2"
-
-DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
-HOMEPAGE="http://www.openttd.com/"
-SB="mirror://sourceforge/openttd"
-SRC_URI="${SB}/${P}-source.tar.bz2
- scenarios? ( ${SB}/${SCENARIOS} )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
-IUSE="alsa debug dedicated png scenarios timidity unicode zlib"
-
-DEPEND="!dedicated? ( media-libs/libsdl >=media-libs/fontconfig-2.3.2 )
- png? ( media-libs/libpng )
- scenarios? ( app-arch/unzip )
- zlib? ( sys-libs/zlib )
- unicode? ( virtual/libiconv )"
-RDEPEND="${DEPEND}
- !dedicated? (
- timidity? ( media-sound/timidity++ )
- !timidity? ( alsa? ( media-sound/alsa-utils ) )
- )"
-
-S=${WORKDIR}/${P}-source
-
-pkg_setup() {
- if ! use dedicated && ! built_with_use media-libs/libsdl X ; then
- die "Please emerge media-libs/libsdl with USE=X"
- fi
- games_pkg_setup
-}
-
-src_unpack() {
- unpack ${P}-source.tar.bz2
- if use scenarios ; then
- cd ${S}/scenario/
- unpack ${SCENARIOS}
- fi
- cd ${S}
- # Don't pre-strip binaries (bug #137822)
- sed -i -e '/+= -s$/s/-s//' Makefile || die "sed failed"
- # Don't install into prefixed DATA_DIR
- sed -i -e \
- 's#DATA_DIR_PREFIXED:=$(PREFIX)/$(DATA_DIR)#DATA_DIR_PREFIXED:=$(DATA_DIR)#' \
- Makefile || die "sed failed"
-}
-
-src_compile() {
- local myopts=""
- use debug && myopts="${myopts} DEBUG=1"
- use dedicated && myopts="${myopts} DEDICATED=1"
- use png && myopts="${myopts} WITH_PNG=1"
- use zlib && myopts="${myopts} WITH_ZLIB=1"
- use unicode && myopts="${myopts} WITH_ICONV=1"
- if ! use dedicated ; then
- myopts="${myopts} WITH_SDL=1"
- if ! use timidity; then
- use alsa && myopts="${myopts} MIDI=/usr/bin/aplaymidi"
- fi
- fi
-
- # parallel build not supported
- emake -j1 \
- MANUAL_CONFIG=1 \
- UNIX=1 \
- WITH_NETWORK=1 \
- INSTALL=1 \
- RELEASE=${PV} \
- USE_HOMEDIR=1 \
- DEST_DIR=${D} \
- PERSONAL_DIR=.openttd \
- PREFIX=${GAMES_PREFIX} \
- DATA_DIR=${GAMES_DATADIR}/${PN} \
- CUSTOM_LANG_DIR=${GAMES_DATADIR}/${PN}/lang \
- ${myopts} \
- || die "emake failed"
-}
-
-src_install() {
- dogamesbin openttd || die "dogamesbin failed"
-
- insinto "${GAMES_DATADIR}/${PN}/data"
- doins data/* || die "doins failed (data)"
-
- insinto "${GAMES_DATADIR}/${PN}/lang"
- doins lang/*.lng || die "doins failed (lang)"
-
- if use scenarios ; then
- insinto "${GAMES_DATADIR}/${PN}/scenario"
- doins scenario/* || die "doins failed (scenario)"
- fi
-
- insinto "${GAMES_DATADIR}/${PN}/scripts"
- doins scripts/*.example || die "doins failed (scripts)"
-
- for i in {16,32,48,64,128}; do
- insinto /usr/share/icons/hicolor/${i}x${i}/apps
- newins media/openttd.${i}.png openttd.png
- done
-
- if ! use dedicated ; then
- if use timidity || use alsa ; then
- make_desktop_entry "openttd -m extmidi" "OpenTTD" openttd
- else
- make_desktop_entry openttd "OpenTTD" openttd
- fi
- else
- newinitd "${FILESDIR}"/openttd.initd openttd
- fi
-
- dodoc readme.txt known-bugs.txt changelog.txt docs/Manual.txt docs/console.txt docs/multiplayer.txt
- dohtml -a html,gif,png,svg docs/*
- newdoc scripts/readme.txt readme_scripts.txt
- doman docs/openttd.6
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- echo
- einfo "In order to play, you must copy the following 6 files from "
- einfo "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
- echo
- einfo "From the WINDOWS version you need: "
- einfo " sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
- einfo "OR from the DOS version you need: "
- einfo " SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
- echo
- einfo "File names are case sensitive so make sure they are "
- einfo "correct for whichever version you have."
- echo
-
- if ! use scenarios ; then
- einfo "Scenarios are now included in a seperate package. To "
- einfo "install them as well please remerge with the "
- einfo "\"scenarios\" USE flag."
- echo
- else
- einfo "Scenarios are installed to ${GAMES_DATADIR}/${PN}/scenario,"
- einfo "you will have to symlink them to ~/.openttd/scenario in order"
- einfo "to use them."
- einfo "Example:"
- einfo " mkdir -p ~/.openttd/scenario"
- einfo " ln -s ${GAMES_DATADIR}/${PN}/scenario/* ~/.openttd/scenario/"
- echo
- fi
-
- if use dedicated ; then
- einfo "You have chosen the dedicated USE flag which builds a "
- einfo "version of OpenTTD to be used as a game server which "
- einfo "does not require SDL. You will not be able to play the "
- einfo "game, but if you don't pass this flag you can still use "
- einfo "it as a server in the same way, but SDL will be required."
- echo
- ewarn "Warning: The init script will kill all running openttd"
- ewarn "processes when run, including any running client sessions!"
- echo
- else
- if use timidity || use alsa ; then
- einfo "If you want music, you must copy the gm/ directory"
- einfo "to ${GAMES_DATADIR}/${PN}/"
- einfo "You can enable MIDI by running:"
- einfo " openttd -m extmidi"
- echo
- if use timidity ; then
- einfo "You also need soundfonts for timidity, if you don't"
- einfo "know what that is, do:"
- echo
- einfo "emerge media-sound/timidity-eawpatches"
- else
- einfo "You have emerged with 'aplaymidi' for playing MIDI."
- einfo "You have to set the environment variable ALSA_OUTPUT_PORTS."
- einfo "Available ports can be listed by using 'aplaymidi -l'."
- fi
- else
- einfo "timidity and/or alsa not in USE so music will not be played during the game."
- fi
- echo
- fi
-}