summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2013-02-20 21:26:32 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2013-02-20 21:26:32 +0000
commit5a6c08b02141cca693de38e683b5b3e827a052cf (patch)
treeac2c02d57cdf33a74adbcaa3e18cbbd08526cc84 /games-simulation
parentVersion bump, bug 458202. (diff)
downloadgentoo-2-5a6c08b02141cca693de38e683b5b3e827a052cf.tar.gz
gentoo-2-5a6c08b02141cca693de38e683b5b3e827a052cf.tar.bz2
gentoo-2-5a6c08b02141cca693de38e683b5b3e827a052cf.zip
Version bump, bug 458202. Thanks to Christian Schmitt for some ideas.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key B1E955DB)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/flightgear/ChangeLog11
-rw-r--r--games-simulation/flightgear/files/flightgear-2.0.0-sdl.patch11
-rw-r--r--games-simulation/flightgear/files/flightgear-2.4.0-svn.patch10
-rw-r--r--games-simulation/flightgear/flightgear-2.10.0.ebuild80
-rw-r--r--games-simulation/flightgear/flightgear-2.4.0.ebuild59
5 files changed, 89 insertions, 82 deletions
diff --git a/games-simulation/flightgear/ChangeLog b/games-simulation/flightgear/ChangeLog
index ed42eb34869d..471387e7f73c 100644
--- a/games-simulation/flightgear/ChangeLog
+++ b/games-simulation/flightgear/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-simulation/flightgear
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.62 2012/12/09 15:09:51 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.63 2013/02/20 21:26:32 reavertm Exp $
+
+*flightgear-2.10.0 (20 Feb 2013)
+
+ 20 Feb 2013; Maciej Mrozowski <reavertm@gentoo.org> +flightgear-2.10.0.ebuild,
+ -files/flightgear-2.0.0-sdl.patch, -files/flightgear-2.4.0-svn.patch,
+ -flightgear-2.4.0.ebuild:
+ Version bump, bug 458202. Thanks to Christian Schmitt for some ideas.
09 Dec 2012; Agostino Sarubbo <ago@gentoo.org> flightgear-2.8.0.ebuild:
Stable for ppc, wrt bug #425838
diff --git a/games-simulation/flightgear/files/flightgear-2.0.0-sdl.patch b/games-simulation/flightgear/files/flightgear-2.0.0-sdl.patch
deleted file mode 100644
index 835d0f4c0006..000000000000
--- a/games-simulation/flightgear/files/flightgear-2.0.0-sdl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2008-09-08 12:57:35.000000000 -0400
-+++ configure.ac 2008-09-08 12:58:50.000000000 -0400
-@@ -268,6 +268,8 @@
- AC_SEARCH_LIBS(glutGetModifiers, [ glut freeglut ])
- if test "x$enable_sdl" = "xyes"; then
- AC_SEARCH_LIBS(SDL_Init, SDL)
-+ CFLAGS="$CFLAGS `sdl-config --cflags`"
-+ CXXFLAGS="$CXXFLAGS `sdl-config --cflags`"
- fi
- ;;
-
diff --git a/games-simulation/flightgear/files/flightgear-2.4.0-svn.patch b/games-simulation/flightgear/files/flightgear-2.4.0-svn.patch
deleted file mode 100644
index a62bb2310fc0..000000000000
--- a/games-simulation/flightgear/files/flightgear-2.4.0-svn.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- utils/TerraSync/terrasync.cxx.old 2011-10-18 20:31:14.893605854 +0200
-+++ utils/TerraSync/terrasync.cxx 2011-10-18 20:32:58.580593547 +0200
-@@ -61,6 +61,7 @@
- # include <svn_client.h>
- # include <svn_cmdline.h>
- # include <svn_pools.h>
-+# include <svn_version.h>
- # else
- # undef HAVE_SVN_CLIENT_H
- # endif
diff --git a/games-simulation/flightgear/flightgear-2.10.0.ebuild b/games-simulation/flightgear/flightgear-2.10.0.ebuild
new file mode 100644
index 000000000000..2dafc3e3f6e4
--- /dev/null
+++ b/games-simulation/flightgear/flightgear-2.10.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-2.10.0.ebuild,v 1.1 2013/02/20 21:26:32 reavertm Exp $
+
+EAPI=5
+
+inherit games cmake-utils
+
+DESCRIPTION="Open Source Flight Simulator"
+HOMEPAGE="http://www.flightgear.org/"
+SRC_URI="mirror://flightgear/Source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fgpanel jpeg +jsbsim oldfdm subversion test +udev +yasim"
+
+COMMON_DEPEND="
+ dev-db/sqlite:3
+ >=dev-games/openscenegraph-3.0.1[png]
+ ~dev-games/simgear-${PV}[jpeg?,subversion?]
+ sys-libs/zlib
+ virtual/opengl
+ udev? ( virtual/udev )
+ fgpanel? (
+ media-libs/freeglut
+ media-libs/libpng
+ )
+"
+# Most entries below are just buildsystem bugs (deps unconditionally
+# inherited from static version of simgear)
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+ media-libs/openal
+ >=media-libs/plib-1.8.5
+ jpeg? ( virtual/jpeg )
+ subversion? (
+ dev-libs/apr
+ dev-vcs/subversion
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ ~games-simulation/${PN}-data-${PV}
+"
+
+DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}
+ -DENABLE_FGADMIN=OFF
+ -DENABLE_PROFILE=OFF
+ -DENABLE_RTI=OFF
+ -DFG_DATA_DIR="${GAMES_DATADIR}"/${PN}
+ -DSIMGEAR_SHARED=ON
+ -DSP_FDMS=OFF
+ -DSYSTEM_SQLITE=ON
+ $(cmake-utils_use_with fgpanel)
+ $(cmake-utils_use jpeg JPEG_FACTORY)
+ $(cmake-utils_use_enable jsbsim)
+ $(cmake-utils_use_enable oldfdm LARCSIM)
+ $(cmake-utils_use_enable oldfdm UIUC_MODEL)
+ $(cmake-utils_use_enable subversion LIBSVN)
+ $(cmake-utils_use test LOGGING)
+ $(cmake-utils_use_enable test TESTS)
+ $(cmake-utils_use udev EVENT_INPUT)
+ $(cmake-utils_use_enable yasim)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newicon -s 48 icons/fg-48.png ${PN}.png
+ newmenu package/${PN}.desktop ${PN}.desktop
+
+ prepgamesdirs
+}
diff --git a/games-simulation/flightgear/flightgear-2.4.0.ebuild b/games-simulation/flightgear/flightgear-2.4.0.ebuild
deleted file mode 100644
index 2a4b48d0e0de..000000000000
--- a/games-simulation/flightgear/flightgear-2.4.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-2.4.0.ebuild,v 1.5 2012/08/21 07:08:05 xmw Exp $
-
-EAPI=3
-
-inherit autotools eutils games
-
-DESCRIPTION="Open Source Flight Simulator"
-HOMEPAGE="http://www.flightgear.org/"
-SRC_URI="mirror://flightgear/Source/${P}.tar.bz2
- mirror://flightgear/Shared/FlightGear-data-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug sdl"
-
-COMMON_DEPEND="
- >=dev-games/openscenegraph-3.0.1[png]
- dev-vcs/subversion
- media-libs/freealut
- media-libs/openal
- sys-libs/zlib
- virtual/jpeg
- x11-libs/libXi
- x11-libs/libXmu
-"
-# Those provide either only C++ headers or static libraries
-DEPEND="${COMMON_DEPEND}
- >=dev-libs/boost-1.37
- ~dev-games/simgear-2.4.0
- >=media-libs/plib-1.8.5
-"
-RDEPEND="${COMMON_DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.0.0-sdl.patch \
- "${FILESDIR}"/${P}-svn.patch
- eautoreconf
-}
-
-src_configure() {
- egamesconf \
- --disable-dependency-tracking \
- --disable-glut \
- $(use_with debug logging) \
- $(use_enable sdl)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r ../data/* || die "doins failed"
- newicon ../data/Aircraft/A6M2/thumbnail.jpg ${PN}.jpg
- make_desktop_entry fgfs FlightGear /usr/share/pixmaps/${PN}.jpg
- dodoc AUTHORS ChangeLog NEWS README Thanks
- prepgamesdirs
-}