summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-12 15:59:24 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-12 15:59:24 +0000
commit48c6f78bbcb5b754c3e1ac7a5c8a2e3c42c91578 (patch)
tree1ca373d1d432eed0f33efe5cb78610df85ba79b0 /games-simulation
parentStable on sparc (diff)
downloadgentoo-2-48c6f78bbcb5b754c3e1ac7a5c8a2e3c42c91578.tar.gz
gentoo-2-48c6f78bbcb5b754c3e1ac7a5c8a2e3c42c91578.tar.bz2
gentoo-2-48c6f78bbcb5b754c3e1ac7a5c8a2e3c42c91578.zip
Install menu entry, bug #160215
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/gl117/ChangeLog7
-rw-r--r--games-simulation/gl117/files/1.3-gcc-3.4-gentoo.patch48
-rw-r--r--games-simulation/gl117/gl117-1.3.2.ebuild9
3 files changed, 11 insertions, 53 deletions
diff --git a/games-simulation/gl117/ChangeLog b/games-simulation/gl117/ChangeLog
index af8a41dc36fe..958a72ed40f8 100644
--- a/games-simulation/gl117/ChangeLog
+++ b/games-simulation/gl117/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/gl117
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/ChangeLog,v 1.18 2006/04/30 09:48:40 blubb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/ChangeLog,v 1.19 2007/03/12 15:59:24 nyhm Exp $
+
+ 12 Mar 2007; Tristan Heaven <nyhm@gentoo.org> gl117-1.3.2.ebuild:
+ Install menu entry, bug #160215
30 Apr 2006; Simon Stelling <blubb@gentoo.org> gl117-1.3.2.ebuild:
stable on amd64
diff --git a/games-simulation/gl117/files/1.3-gcc-3.4-gentoo.patch b/games-simulation/gl117/files/1.3-gcc-3.4-gentoo.patch
deleted file mode 100644
index 7981c9277e9a..000000000000
--- a/games-simulation/gl117/files/1.3-gcc-3.4-gentoo.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -ur gl-117-1.3-src.orig/src/3ds.cpp gl-117-1.3-src/src/3ds.cpp
---- gl-117-1.3-src.orig/src/3ds.cpp 2004-06-12 00:44:13.000000000 -0500
-+++ gl-117-1.3-src/src/3ds.cpp 2004-06-13 13:29:13.191525808 -0500
-@@ -759,7 +759,7 @@
- v->vector.z /= sc;
- }
- }
--};
-+}
-
- #endif
-
-diff -ur gl-117-1.3-src.orig/src/audio.cpp gl-117-1.3-src/src/audio.cpp
---- gl-117-1.3-src.orig/src/audio.cpp 2004-06-12 00:44:13.000000000 -0500
-+++ gl-117-1.3-src/src/audio.cpp 2004-06-13 13:28:17.695962416 -0500
-@@ -322,7 +322,7 @@
- wavemissile1->setVolume (110);
- waveclick1->setVolume (80);
- #endif
--};
-+}
-
- SoundSystem::~SoundSystem ()
- {
-diff -ur gl-117-1.3-src.orig/src/model.cpp gl-117-1.3-src/src/model.cpp
---- gl-117-1.3-src.orig/src/model.cpp 2004-06-12 00:44:13.000000000 -0500
-+++ gl-117-1.3-src/src/model.cpp 2004-06-13 13:27:52.980719704 -0500
-@@ -57,7 +57,7 @@
- c [0] = cr; c [1] = cg; c [2] = cb; c [3] = ca;
- }
-
--CColor::~CColor () {};
-+CColor::~CColor () {}
-
- void CColor::setColor (CColor *col)
- {
-diff -ur gl-117-1.3-src.orig/src/objload.cpp gl-117-1.3-src/src/objload.cpp
---- gl-117-1.3-src.orig/src/objload.cpp 2004-06-12 00:44:13.000000000 -0500
-+++ gl-117-1.3-src/src/objload.cpp 2004-06-13 13:28:21.967313072 -0500
-@@ -247,7 +247,7 @@
- }
-
- // model->scale = sc;
--};
-+}
-
- bool CLoadOBJ::ImportOBJ (CModel *model, char *filename)
- {
diff --git a/games-simulation/gl117/gl117-1.3.2.ebuild b/games-simulation/gl117/gl117-1.3.2.ebuild
index ac609bc74d95..43538f741aee 100644
--- a/games-simulation/gl117/gl117-1.3.2.ebuild
+++ b/games-simulation/gl117/gl117-1.3.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/gl117-1.3.2.ebuild,v 1.6 2006/12/19 22:52:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/gl117-1.3.2.ebuild,v 1.7 2007/03/12 15:59:24 nyhm Exp $
inherit eutils games
@@ -31,6 +31,9 @@ pkg_setup() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog FAQ NEWS README
+ newicon doc/src/falcon.jpg ${PN}.jpg
+ make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ doman doc/gl-117.6
+ dodoc doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README
prepgamesdirs
}