summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-12 20:42:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-12 20:42:02 +0000
commit415a38b441d9b24ccd8542c140b1f7a9952942b6 (patch)
tree1cea9b2857b5e5555079159ec674e913dce977cb /games-simulation
parentRun ebegin message through eval so the output is expanded #442374 by Toralf F... (diff)
downloadgentoo-2-415a38b441d9b24ccd8542c140b1f7a9952942b6.tar.gz
gentoo-2-415a38b441d9b24ccd8542c140b1f7a9952942b6.tar.bz2
gentoo-2-415a38b441d9b24ccd8542c140b1f7a9952942b6.zip
version bump (bug #520650)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/simutrans/ChangeLog12
-rw-r--r--games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch4
-rw-r--r--games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch4
-rw-r--r--games-simulation/simutrans/files/simutrans-0.120.0.1-Makefile.patch89
-rw-r--r--games-simulation/simutrans/simutrans-0.120.0.1.ebuild54
5 files changed, 157 insertions, 6 deletions
diff --git a/games-simulation/simutrans/ChangeLog b/games-simulation/simutrans/ChangeLog
index e5ce394e6f8a..cc7999d8b6f4 100644
--- a/games-simulation/simutrans/ChangeLog
+++ b/games-simulation/simutrans/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-simulation/simutrans
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.37 2014/10/27 18:51:36 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.38 2015/04/12 20:42:02 mr_bones_ Exp $
+
+*simutrans-0.120.0.1 (12 Apr 2015)
+
+ 12 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/simutrans-0.120.0.1-Makefile.patch, +simutrans-0.120.0.1.ebuild,
+ files/simutrans-0.112.3-Makefile.patch,
+ files/simutrans-0.112.3-overflow.patch:
+ version bump (bug #520650)
27 Oct 2014; Michael Sterrett <mr_bones_@gentoo.org>
-files/simutrans-0.102.2.2-gcc46.patch,
diff --git a/games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch b/games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch
index 3becef9ae9eb..a27316438002 100644
--- a/games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch
+++ b/games-simulation/simutrans/files/simutrans-0.112.3-Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2013-05-28 17:58:03.379228527 -0400
-+++ Makefile 2013-05-28 17:58:24.768491369 -0400
+--- Makefile.orig
++++ Makefile
@@ -88,8 +88,6 @@
endif
endif
diff --git a/games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch b/games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch
index 6597ca071f92..b50f3b888422 100644
--- a/games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch
+++ b/games-simulation/simutrans/files/simutrans-0.112.3-overflow.patch
@@ -1,5 +1,5 @@
---- besch/reader/obj_reader.cc.orig 2013-01-22 17:22:02.509818038 -0500
-+++ besch/reader/obj_reader.cc 2013-01-22 17:22:58.650846577 -0500
+--- besch/reader/obj_reader.cc.orig
++++ besch/reader/obj_reader.cc
@@ -308,7 +308,7 @@
void obj_reader_t::skip_nodes(FILE *fp,uint32 version)
{
diff --git a/games-simulation/simutrans/files/simutrans-0.120.0.1-Makefile.patch b/games-simulation/simutrans/files/simutrans-0.120.0.1-Makefile.patch
new file mode 100644
index 000000000000..d1ff41f33feb
--- /dev/null
+++ b/games-simulation/simutrans/files/simutrans-0.120.0.1-Makefile.patch
@@ -0,0 +1,89 @@
+--- Makefile.orig
++++ Makefile
+@@ -81,8 +81,6 @@
+ ifeq ($(findstring $(OSTYPE), amiga haiku mac),)
+ CFLAGS += -minline-all-stringops
+ endif
+-else
+- CFLAGS += -O
+ endif
+
+ ifdef DEBUG
+@@ -101,6 +99,7 @@
+ endif
+ else
+ CFLAGS += -DNDEBUG
++ CXXFLAGS += -DNDEBUG
+ endif
+
+ ifneq ($(PROFILE),)
+@@ -114,6 +113,7 @@
+ ifneq ($(MULTI_THREAD),)
+ ifeq ($(shell expr $(MULTI_THREAD) \>= 1), 1)
+ CFLAGS += -DMULTI_THREAD
++ CXXFLAGS += -DMULTI_THREAD
+ ifeq ($(OSTYPE),mingw)
+ #use lpthreadGC2d for debug alternatively
+ LDFLAGS += -lpthreadGC2
+@@ -132,11 +132,13 @@
+ endif
+ ifneq ($(REV),)
+ CFLAGS += -DREVISION="$(REV)"
++ CXXFLAGS += -DREVISION="$(REV)"
+ endif
+ endif
+ endif
+
+ CFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
++CXXFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
+ CCFLAGS += -Wstrict-prototypes
+
+
+@@ -492,6 +494,7 @@
+ SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS)
+ endif
+
+@@ -523,6 +526,7 @@
+ SDL_LDFLAGS := $(shell $(SDL2_CONFIG) --libs)
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS)
+ endif
+
+@@ -538,6 +542,7 @@
+ SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS) -lSDL_mixer
+ endif
+
+@@ -564,6 +569,7 @@
+ SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS) -lglew32
+ ifeq ($(OSTYPE),mingw)
+ LIBS += -lopengl32
+@@ -579,6 +585,7 @@
+ endif
+
+ CFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
++CXXFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
+
+ ifneq ($(findstring $(OSTYPE), cygwin mingw),)
+ SOURCES += simres.rc
+@@ -586,7 +593,6 @@
+ endif
+
+ CCFLAGS += $(CFLAGS)
+-CXXFLAGS += $(CFLAGS)
+
+ BUILDDIR ?= build/$(CFG)
+ PROGDIR ?= $(BUILDDIR)
diff --git a/games-simulation/simutrans/simutrans-0.120.0.1.ebuild b/games-simulation/simutrans/simutrans-0.120.0.1.ebuild
new file mode 100644
index 000000000000..263c2535901a
--- /dev/null
+++ b/games-simulation/simutrans/simutrans-0.120.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/simutrans-0.120.0.1.ebuild,v 1.1 2015/04/12 20:42:02 mr_bones_ Exp $
+
+EAPI=5
+inherit flag-o-matic eutils games
+
+MY_PV=${PV/0./}
+MY_PV=${MY_PV//./-}
+DESCRIPTION="A free Transport Tycoon clone"
+HOMEPAGE="http://www.simutrans.com/"
+SRC_URI="mirror://sourceforge/simutrans/simutrans-src-${MY_PV}.zip
+ mirror://sourceforge/simutrans/simupak64-${MY_PV}.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[sound,video]
+ sys-libs/zlib
+ app-arch/bzip2
+ media-libs/libpng:0
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ strip-flags # bug #293927
+ echo "BACKEND=mixer_sdl
+COLOUR_DEPTH=16
+OSTYPE=linux
+VERBOSE=1" > config.default || die
+
+ # make it look in the install location for the data
+ sed -i \
+ -e "s:argv\[0\]:\"${GAMES_DATADIR}/${PN}/\":" \
+ simmain.cc || die
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ rm -f simutrans/{simutrans,*.txt}
+}
+
+src_install() {
+ newgamesbin build/default/sim ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r simutrans/*
+ dodoc documentation/*
+ doicon simutrans.ico
+ make_desktop_entry simutrans Simutrans /usr/share/pixmaps/simutrans.ico
+ prepgamesdirs
+}