summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-27 08:31:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-27 08:31:05 +0000
commit1caf14bcdb6ffad12e6e0e93c2695c1666cba8e8 (patch)
tree1ed2fe87ba9774a999b0a697b8783c69c6d50050 /games-simulation
parentRemoving old ebuilds. (Manifest recommit) (diff)
downloadgentoo-2-1caf14bcdb6ffad12e6e0e93c2695c1666cba8e8.tar.gz
gentoo-2-1caf14bcdb6ffad12e6e0e93c2695c1666cba8e8.tar.bz2
gentoo-2-1caf14bcdb6ffad12e6e0e93c2695c1666cba8e8.zip
version bump (bug #45699)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/cannonsmash/ChangeLog10
-rw-r--r--games-simulation/cannonsmash/Manifest4
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild59
-rw-r--r--games-simulation/cannonsmash/files/digest-cannonsmash-0.6.62
4 files changed, 72 insertions, 3 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index 0634f6d6def4..e9c5069a567e 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/cannonsmash
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.2 2003/09/12 15:44:09 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.3 2004/03/27 08:31:05 mr_bones_ Exp $
+
+*cannonsmash-0.6.6 (27 Mar 2004)
+
+ 27 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ cannonsmash-0.6.6.ebuild:
+ version bump (bug #45699)
*cannonsmash-0.6.5 (05 Mar 2003)
diff --git a/games-simulation/cannonsmash/Manifest b/games-simulation/cannonsmash/Manifest
index df171acc1116..feb09ea7d77e 100644
--- a/games-simulation/cannonsmash/Manifest
+++ b/games-simulation/cannonsmash/Manifest
@@ -1,5 +1,7 @@
MD5 645c9cc258ba9f9f6f96b38aa989c6ad ChangeLog 1013
MD5 218ac220d591a63a4d94e6be205c152f cannonsmash-0.6.5.ebuild 1358
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 218ac220d591a63a4d94e6be205c152f cannonsmash-0.6.6.ebuild 1358
MD5 2ca70e3856451ca1226bb3461a653895 files/0.6.5-loadparts.patch 348
MD5 fbc7d2161999a96e4c8cd035592ba8d5 files/digest-cannonsmash-0.6.5 134
+MD5 e82483f8829d68c4582a2b5ea52ba427 files/digest-cannonsmash-0.6.6 134
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
new file mode 100644
index 000000000000..943e44c55d11
--- /dev/null
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.1 2004/03/27 08:31:05 mr_bones_ Exp $
+
+inherit games
+
+MY_OGG=danslatristesse2-48.ogg
+DESCRIPTION="3D tabletennis game"
+HOMEPAGE="http://cannonsmash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cannonsmash/csmash-${PV}.tar.gz
+ oggvorbis? ( http://nan.p.utmc.or.jp/${MY_OGG} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="oggvorbis nls"
+
+RDEPEND="virtual/glibc
+ virtual/x11
+ virtual/opengl
+ >=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-mixer-1.2.3
+ >=media-libs/sdl-image-1.2.2
+ =x11-libs/gtk+-1.2*"
+DEPEND="${RDEPEND}
+ oggvorbis? ( >=sys-apps/sed-4 )"
+
+S="${WORKDIR}/csmash-${PV}"
+
+src_unpack() {
+ unpack csmash-${PV}.tar.gz
+ cd ${S}
+ if use oggvorbis ; then
+ cp ${DISTDIR}/${MY_OGG} ${S}/ || die "cp failed"
+ sed -i \
+ -e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
+ || die "setting ogg loc"
+ fi
+}
+
+src_compile() {
+ egamesconf \
+ `use_enable nls` \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ egamesinstall \
+ datadir="${D}/${GAMES_DATADIR_BASE}" \
+ || die
+ if use oggvorbis ; then
+ insinto "${GAMES_DATADIR}/csmash"
+ doins "${MY_OGG}"
+ fi
+ dodoc AUTHORS CREDITS README*
+ prepgamesdirs
+}
diff --git a/games-simulation/cannonsmash/files/digest-cannonsmash-0.6.6 b/games-simulation/cannonsmash/files/digest-cannonsmash-0.6.6
new file mode 100644
index 000000000000..43c2257f9d53
--- /dev/null
+++ b/games-simulation/cannonsmash/files/digest-cannonsmash-0.6.6
@@ -0,0 +1,2 @@
+MD5 bcf2eddd0f04d58e5dac6d767f41d9af csmash-0.6.6.tar.gz 1989943
+MD5 d574b304d427a9b3c6d775af95ecbe8d danslatristesse2-48.ogg 1070787