summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-19 05:16:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-19 05:16:43 +0000
commitcff34f8817a5ea3818ead2416246b5b169d9aa75 (patch)
tree1e7eaf6c6c5e937bd90640873d2b64943cadc2e5 /games-simulation/openttd
parent+games-simulation/openttd:timidity; sort (diff)
downloadgentoo-2-cff34f8817a5ea3818ead2416246b5b169d9aa75.tar.gz
gentoo-2-cff34f8817a5ea3818ead2416246b5b169d9aa75.tar.bz2
gentoo-2-cff34f8817a5ea3818ead2416246b5b169d9aa75.zip
version bump - bug #64056
Diffstat (limited to 'games-simulation/openttd')
-rw-r--r--games-simulation/openttd/ChangeLog7
-rw-r--r--games-simulation/openttd/Manifest14
-rw-r--r--games-simulation/openttd/files/digest-openttd-0.3.42
-rw-r--r--games-simulation/openttd/openttd-0.3.4.ebuild70
4 files changed, 81 insertions, 12 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 0ba76bf462e3..986ad406e968 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.6 2004/09/06 21:25:10 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.7 2004/09/19 05:16:43 mr_bones_ Exp $
+
+*openttd-0.3.4 (18 Sep 2004)
+
+ 18 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +openttd-0.3.4.ebuild:
+ version bump - bug #64056
06 Sep 2004; Tom Martin <slarti@gentoo.org> openttd-0.3.3.ebuild:
Marked ~amd64, resolving bug 63029. Thanks to E. Papegaaij
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index 7debb4de1095..996f4566f252 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 25944d17686e962c3d5b922e39cb2ba4 openttd-0.3.3.ebuild 2118
MD5 0135671719faaf58e47e0803b01f5c21 ChangeLog 1185
MD5 7efefbbe81a05cbc5d4e96203f047fda metadata.xml 245
+MD5 a3d253bd19f4ad6f2201b1a29dc7b6f3 openttd-0.3.4.ebuild 2117
+MD5 25944d17686e962c3d5b922e39cb2ba4 openttd-0.3.3.ebuild 2118
+MD5 4fcd4d28183ae8fbc7b0727685de0271 files/digest-openttd-0.3.4 130
MD5 211d365a1cdda11aa6e5e2f7fb307579 files/digest-openttd-0.3.3 130
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBPNYhCHk4+ZoBpvsRAvGBAJ9trcUtQ9JttRWFCt2+9LwQyTfaJACbBlJQ
-2OjjcU5R6EIBm2S31yQc9zU=
-=YBgP
------END PGP SIGNATURE-----
diff --git a/games-simulation/openttd/files/digest-openttd-0.3.4 b/games-simulation/openttd/files/digest-openttd-0.3.4
new file mode 100644
index 000000000000..8ef8db157c4f
--- /dev/null
+++ b/games-simulation/openttd/files/digest-openttd-0.3.4
@@ -0,0 +1,2 @@
+MD5 14a4761593ac31418454c9cc1fe8a8bb openttd-0.3.4.tar.bz2 1394627
+MD5 070d66ed5086515a45f0a40a25c28771 openttd-useful.zip 366311
diff --git a/games-simulation/openttd/openttd-0.3.4.ebuild b/games-simulation/openttd/openttd-0.3.4.ebuild
new file mode 100644
index 000000000000..37cb4297fd97
--- /dev/null
+++ b/games-simulation/openttd/openttd-0.3.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.3.4.ebuild,v 1.1 2004/09/19 05:16:43 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.com/"
+SRC_URI="mirror://sourceforge/openttd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="debug png zlib"
+
+DEPEND="virtual/libc
+ media-libs/libsdl
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ timidity? ( media-sound/timidity++ )"
+
+src_compile() {
+ local myopts="MANUAL_CONFIG=1 UNIX=1 WITH_SDL=1 WITH_NETWORK=1 USE_HOMEDIR=1 PERSONAL_DIR=.openttd GAME_DATA_DIR=${GAMES_DATADIR}/${PN}/"
+ use debug && myopts="${myopts} DEBUG=1"
+ use png && myopts="${myopts} WITH_PNG=1"
+ use zlib && myopts="${myopts} WITH_ZLIB=1"
+
+ emake -j1 ${myopts} || die "emake failed"
+}
+
+src_install() {
+ dogamesbin openttd || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}/${PN}/data"
+ doins data/* || die "doins failed"
+
+ insinto "${GAMES_DATADIR}/${PN}/lang"
+ doins lang/*.lng || die "doins failed"
+
+ insinto /usr/share/pixmaps
+ newins media/icon128.png openttd.png || die "doins failed"
+
+ make_desktop_entry openttd "OpenTTD" openttd.png
+ dodoc readme.txt changelog.txt docs/Manual.txt docs/console.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ echo
+ einfo "In order to play, you must copy the following 6 files from "
+ einfo "the *WINDOWS* version of TTD to ${GAMES_DATADIR}/${PN}/data/"
+ echo
+ einfo "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ echo
+ if use timidity ; then
+ einfo "If you want music, you must copy the gm/ directory"
+ einfo "to ${GAMES_DATADIR}/${PN}/"
+ echo
+ einfo "You also need soundfonts for timidity, if you don't"
+ einfo "know what that is, do:"
+ echo
+ einfo "emerge media-sound/timidity-eawpatches"
+ else
+ einfo "timidity not in USE so music will not be played during the game."
+ fi
+ echo
+}