summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-04-21 14:28:05 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-04-21 14:28:05 +0000
commit96621fc35b87f1449cefa039e12f28ae7ac1bc9d (patch)
tree1d725c6e3def4a20b0ba35fb9e76d508731fd311 /games-rpg
parentStable on sparc (diff)
downloadgentoo-2-96621fc35b87f1449cefa039e12f28ae7ac1bc9d.tar.gz
gentoo-2-96621fc35b87f1449cefa039e12f28ae7ac1bc9d.tar.bz2
gentoo-2-96621fc35b87f1449cefa039e12f28ae7ac1bc9d.zip
Fixing unpacking. This resolves the issue where /opt/nwn/nwn is a directory since we were erroneously unpacking nwresources129.tar.gz twice.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/nwn/ChangeLog6
-rw-r--r--games-rpg/nwn/nwn-1.66.ebuild13
2 files changed, 10 insertions, 9 deletions
diff --git a/games-rpg/nwn/ChangeLog b/games-rpg/nwn/ChangeLog
index f37396e74545..06b774de12d3 100644
--- a/games-rpg/nwn/ChangeLog
+++ b/games-rpg/nwn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/nwn
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/ChangeLog,v 1.40 2006/03/31 21:38:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/ChangeLog,v 1.41 2006/04/21 14:28:05 wolf31o2 Exp $
+
+ 21 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org> nwn-1.66.ebuild:
+ Fixing unpacking. This resolves the issue where /opt/nwn/nwn is a directory
+ since we were erroneously unpacking nwresources129.tar.gz twice.
31 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org> nwn-1.66.ebuild,
nwn-1.66-r1.ebuild:
diff --git a/games-rpg/nwn/nwn-1.66.ebuild b/games-rpg/nwn/nwn-1.66.ebuild
index 241be9000b57..1a882d3e6cd2 100644
--- a/games-rpg/nwn/nwn-1.66.ebuild
+++ b/games-rpg/nwn/nwn-1.66.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/nwn-1.66.ebuild,v 1.14 2006/03/31 21:38:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/nwn-1.66.ebuild,v 1.15 2006/04/21 14:28:05 wolf31o2 Exp $
inherit eutils games
@@ -64,17 +64,14 @@ src_unpack() {
mkdir -p "${S}"
cd "${S}"
unpack nwclient129.tar.gz
- if use nowin
- then
- cd "${WORKDIR}"
- unpack nwresources129.tar.gz
- cd "${S}"
- fi
rm -rf override/*
# the following is so ugly, please pretend it doesnt exist
declare -a Aarray=(${A})
- use nowin && if [ "${#Aarray[*]}" == "5" ]; then
+ use nowin && if [ "${#Aarray[*]}" == "5" ]
+ then
+ cd "${WORKDIR}"
unpack ${Aarray[3]}
+ cd "${S}"
fi
unpack ${Aarray[1]}
unpack ${Aarray[2]}