summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-07-03 07:02:40 +0000
committerRoy Marples <uberlord@gentoo.org>2006-07-03 07:02:40 +0000
commit7cc4fff012049d940938f82e2330294e055de865 (patch)
tree414f2b7dbef9e60fcbccd4eb3e5e09a030f9c120 /games-rpg/eternal-lands
parentversion bump to 2.0.3, see ChangeLog for more details (diff)
downloadgentoo-2-7cc4fff012049d940938f82e2330294e055de865.tar.gz
gentoo-2-7cc4fff012049d940938f82e2330294e055de865.tar.bz2
gentoo-2-7cc4fff012049d940938f82e2330294e055de865.zip
Add a patch to create the directories required for files being auto-updated
if they do not exist. (Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'games-rpg/eternal-lands')
-rw-r--r--games-rpg/eternal-lands/ChangeLog10
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r4.ebuild115
-rw-r--r--games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r46
-rw-r--r--games-rpg/eternal-lands/files/eternal-lands-1.2.0-update-createdir.patch86
4 files changed, 216 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index 7cf684fc6b0c..f4caf41e545f 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.17 2006/05/21 11:34:06 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.18 2006/07/03 07:02:39 uberlord Exp $
+
+*eternal-lands-1.2.0_p1-r4 (03 Jul 2006)
+
+ 03 Jul 2006; Roy Marples <uberlord@gentoo.org>
+ +files/eternal-lands-1.2.0-update-createdir.patch,
+ +eternal-lands-1.2.0_p1-r4.ebuild:
+ Add a patch to create the directories required for files being auto-updated
+ if they do not exist.
*eternal-lands-1.2.0_p1-r3 (21 May 2006)
diff --git a/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r4.ebuild b/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r4.ebuild
new file mode 100644
index 000000000000..02511a001adc
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r4.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.2.0_p1-r4.ebuild,v 1.1 2006/07/03 07:02:39 uberlord Exp $
+
+inherit eutils games
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+S="${WORKDIR}/elc"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="mirror://gentoo/elc_${MY_PV}.tgz
+ mirror://gentoo/eternal-lands.png"
+
+# NOTE: Sometimes you'll have to roll your own elc tarball from their CVS
+# tree as they don't always release one.
+# If they do then use this in SRC_URI instead
+# ftp://ftp.berlios.de/pub/elc/elc_${MY_PV}.tgz
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext )
+ virtual/x11 )
+ virtual/opengl
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.5
+ ~media-libs/openal-0.0.8
+ media-libs/freealut
+ media-libs/libvorbis
+ >=dev-libs/libxml2-2.6.7
+ =media-libs/cal3d-0.10.0
+ >=media-libs/libpng-1.2.8
+ ~games-rpg/${PN}-data-${PV}"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-apps/findutils
+ doc? ( >=app-doc/doxygen-1.3.8
+ >=media-gfx/graphviz-1.10 )"
+
+src_unpack() {
+ OPTIONS="OPTIONS=-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="konqueror"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Allow compiled vertex arrays to be togglable as they don't seem to work
+ # with xorg drivers on IGP style cards.
+ epatch "${FILESDIR}/${PN}-1.2.0-vertex-array.patch"
+ epatch "${FILESDIR}/${PN}-1.2.0-update-createdir.patch"
+
+ # Remove CVS entries
+ find . -type d -name CVS -exec rm -rf {} \; 2>/dev/null
+
+ use amd64 && OPTIONS="${OPTIONS} -DX86_64"
+ sed \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O -ggdb -pipe@CFLAGS=${CFLAGS} @g"\
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O -ggdb -pipe@CXXFLAGS=${CXXFLAGS} @g"\
+ -e "s@OPTIONS=@${OPTIONS} @g" \
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ newgamesbin el.x86.linux.bin el || die "newgamesbin failed"
+ doicon "${DISTDIR}/eternal-lands.png"
+ make_desktop_entry el "Eternal Lands"
+
+ rm -f books/*.c books/*.o books/*.h
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r *.ini *.txt *.lst \
+ actor_defs books languages \
+ || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${MY_PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${MY_PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r4 b/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r4
new file mode 100644
index 000000000000..ec8e42ae0a6d
--- /dev/null
+++ b/games-rpg/eternal-lands/files/digest-eternal-lands-1.2.0_p1-r4
@@ -0,0 +1,6 @@
+MD5 15492252c997253a90e6eec4f9edfeae elc_120p1.tgz 731594
+RMD160 a06be332015a8db57c3455f9918e3b58cfe92a41 elc_120p1.tgz 731594
+SHA256 a610102e92e91c6c69c4ceef906ae5010280267a1b9f55ec71f172e3691f0674 elc_120p1.tgz 731594
+MD5 059df8128b11b19a76b54e9907072f00 eternal-lands.png 9955
+RMD160 2f9c8acd96214577cf8b8027f0d20fb1fe7574ff eternal-lands.png 9955
+SHA256 dd7d45cd9948fe7875ebd0bfcd1925d9b34e7606a223faf61d37a6dd2cd433fb eternal-lands.png 9955
diff --git a/games-rpg/eternal-lands/files/eternal-lands-1.2.0-update-createdir.patch b/games-rpg/eternal-lands/files/eternal-lands-1.2.0-update-createdir.patch
new file mode 100644
index 000000000000..5d8fc689f7c2
--- /dev/null
+++ b/games-rpg/eternal-lands/files/eternal-lands-1.2.0-update-createdir.patch
@@ -0,0 +1,86 @@
+--- update.c 2006-07-03 07:30:09.154559449 +0100
++++ update.c 2006-07-03 07:57:31.000000000 +0100
+@@ -7,6 +7,7 @@
+ #include "asc.h"
+ #include <stdio.h>
+ #include <ctype.h>
++#include <sys/stat.h>
+ #ifdef WINDOWS
+ #define strdup _strdup
+ #endif //WINDOWS
+@@ -153,6 +154,8 @@
+ ++temp_counter;
+ fp= my_fopen(filename, "wb+");
+ if(fp){
++ chmod (filename,
++ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP);
+ sprintf(filename, "http://%s/updates/files.lst", update_server);
+ http_threaded_get_file(update_server, filename, fp, NULL, EVENT_UPDATES_DOWNLOADED);
+ }
+@@ -265,6 +268,7 @@
+ buffer[sizeof(buffer)-1]= '\0';
+ fp= my_fopen(download_temp_file, "wb+");
+ if(fp){
++
+ // build the prope URL to download
+ download_cur_file= download_queue[--download_queue_size];
+ download_cur_md5= download_MD5s[download_queue_size];
+@@ -291,9 +295,47 @@
+ if(get->status == 0){
+ // the download was successful
+ // replace the current file
+- // TODO: check for remove/rename errors
++ // First, check directory exists
++ char *dir = (char *) malloc (strlen (download_cur_file) + 1);
++ char *slash;
++ struct stat stats;
++
++ strcpy (dir, download_cur_file);
++ slash = dir;
++
++ // Skip over leading slashes.
++ while (*slash == '/')
++ slash++;
++
++ while (1)
++ {
++ slash = strchr (slash, '/');
++ if (slash == NULL)
++ break;
++
++ *slash = '\0';
++ if (! (stat (dir, &stats) == 0 && S_ISDIR (stats.st_mode) ) )
++ {
++ if (mkdir (dir, 0770) != 0)
++ {
++ log_error("cannot create directory %s", dir);
++ break;
++ }
++ else
++ chmod (dir, S_IRWXU | S_IRWXG | S_ISGID);
++ }
++
++ *slash++ = '/';
++
++ // Avoid unnecessary calls to mkdir when given
++ // file names containing multiple adjacent slashes.
++ while (*slash == '/')
++ slash++;
++ }
++
+ remove(download_cur_file);
+- rename(download_temp_file, download_cur_file);
++ if ( ! rename(download_temp_file, download_cur_file) )
++ remove(download_temp_file);
+
+ // TODO: make the restart more intelligent
+ if(allow_restart){
+@@ -325,6 +367,8 @@
+ sprintf(download_temp_file, "temp%03d.dat", ++temp_counter);
+ fp= my_fopen(download_temp_file, "wb+");
+ if(fp){
++ chmod (download_temp_file,
++ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP);
+ // build the prope URL to download
+ download_cur_file= download_queue[--download_queue_size];
+ download_cur_md5= download_MD5s[download_queue_size];