summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-04-26 06:49:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-04-26 06:49:38 +0000
commit7bf2030c9326a6b39fefdefb0b06cad983a0f862 (patch)
tree3db4e09b22216299218aa93cfd085a272b59afef /games-rpg/egoboo
parentMake sure we use --version when checking binutils-config #131133 by Brett Joh... (diff)
downloadgentoo-2-7bf2030c9326a6b39fefdefb0b06cad983a0f862.tar.gz
gentoo-2-7bf2030c9326a6b39fefdefb0b06cad983a0f862.tar.bz2
gentoo-2-7bf2030c9326a6b39fefdefb0b06cad983a0f862.zip
use games_make_wrapper; fix perms on binary in the data directory
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'games-rpg/egoboo')
-rw-r--r--games-rpg/egoboo/egoboo-2.22.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/games-rpg/egoboo/egoboo-2.22.ebuild b/games-rpg/egoboo/egoboo-2.22.ebuild
index 2877e9a7e698..c8dbe792ad48 100644
--- a/games-rpg/egoboo/egoboo-2.22.ebuild
+++ b/games-rpg/egoboo/egoboo-2.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.22.ebuild,v 1.16 2006/04/24 20:07:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.22.ebuild,v 1.17 2006/04/26 06:49:38 mr_bones_ Exp $
inherit eutils flag-o-matic toolchain-funcs games
@@ -25,10 +25,6 @@ src_unpack() {
unpack ${A}
cd "${S}"
- sed \
- -e "s:GENTOODIR:${GAMES_DATADIR}:" "${FILESDIR}/${P}.sh" \
- > "${T}/egoboo" || die "sed wrapper failed"
-
# Fix endianess using SDL
# amd64 patch must be applied after ${PV}-endian.patch
# this addresses bug #104271
@@ -44,12 +40,14 @@ src_compile() {
}
src_install () {
- dogamesbin "${T}/egoboo" || die "dogamesbin failed"
+ games_make_wrapper ${PN} ./${PN} "${GAMES_DATADIR}/${PN}"
dodoc egoboo.txt
insinto "${GAMES_DATADIR}/${PN}"
doins -r basicdat/ import/ modules/ players/ text/ \
code/egoboo controls.txt setup.txt \
|| die "doins failed"
+ # FIXME: this is stupid. should be patched to run out of GAMES_BINDIR
+ fperms 750 "${GAMES_DATADIR}/${PN}/${PN}"
prepgamesdirs
# ugly, but the game needs write here.