summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 01:58:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 01:58:28 +0000
commitcc2350cc5220a8ab72578f0cdb2d0510f484e5be (patch)
tree2e472292760b249a2fd55b52bb0c991df2715ab8 /games-roguelike
parentold (diff)
downloadgentoo-2-cc2350cc5220a8ab72578f0cdb2d0510f484e5be.tar.gz
gentoo-2-cc2350cc5220a8ab72578f0cdb2d0510f484e5be.tar.bz2
gentoo-2-cc2350cc5220a8ab72578f0cdb2d0510f484e5be.zip
version bump (bug #506932)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog10
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild79
2 files changed, 87 insertions, 2 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index 2b24aba94d99..35c1204b49f0 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/crossfire-client
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.37 2014/08/28 06:51:25 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.38 2015/02/19 01:58:28 mr_bones_ Exp $
+
+*crossfire-client-1.71.0 (19 Feb 2015)
+
+ 19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +crossfire-client-1.71.0.ebuild:
+ version bump (bug #506932)
28 Aug 2014; Michael Sterrett <mr_bones_@gentoo.org>
-crossfire-client-1.12.0.ebuild,
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild
new file mode 100644
index 000000000000..df5f87b32889
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.71.0.ebuild,v 1.1 2015/02/19 01:58:28 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools eutils toolchain-funcs gnome2-utils games
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa lua opengl oss sdl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ opengl? ( virtual/opengl
+ media-libs/freeglut )
+ x11-libs/gtk+:2
+ gnome-base/libglade
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image[png] )
+ lua? ( dev-lang/lua )
+ net-misc/curl
+ media-libs/libpng:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf
+
+ use sdl || myconf="${myconf} --disable-sdl"
+ use alsa || myconf="${myconf} --disable-alsa9 --disable-alsa"
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
+ egamesconf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use alsa || use oss ; then
+ emake -j1 -C sound-src AR="$(tc-getAR)"
+ fi
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local s
+
+ default
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}