summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-15 03:01:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-15 03:01:36 +0000
commit4a519a3ed90dcea8edb00aecd3a97ec1e45d8168 (patch)
tree9a67c8e16a826d2ee039d20085eec14f9943f011 /games-roguelike
parentFix building with libpng15 wrt #378239 by Diego Elio Pettenò (diff)
downloadgentoo-2-4a519a3ed90dcea8edb00aecd3a97ec1e45d8168.tar.gz
gentoo-2-4a519a3ed90dcea8edb00aecd3a97ec1e45d8168.tar.bz2
gentoo-2-4a519a3ed90dcea8edb00aecd3a97ec1e45d8168.zip
Fix building with libpng15 wrt #378409 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog7
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild8
-rw-r--r--games-roguelike/crossfire-client/files/crossfire-client-1.12.0-libpng15.patch31
3 files changed, 42 insertions, 4 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index c63c07555fb6..64267457f7ed 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.26 2011/08/07 06:45:58 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.27 2011/09/15 03:01:36 ssuominen Exp $
+
+ 15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+ crossfire-client-1.12.0.ebuild,
+ +files/crossfire-client-1.12.0-libpng15.patch:
+ Fix building with libpng15 wrt #378409 by Diego Elio Pettenò
07 Aug 2011; Christoph Mende <angelos@gentoo.org>
crossfire-client-1.12.0.ebuild,
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
index daa676c5fdb5..de2d61af6252 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild,v 1.7 2011/08/07 06:45:58 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild,v 1.8 2011/09/15 03:01:36 ssuominen Exp $
EAPI=2
inherit eutils autotools games
@@ -30,9 +30,11 @@ src_prepare() {
-r '/^.TH/s:$: 6:' \
$(find . -name "*man") \
|| die "sed failed"
- epatch "${FILESDIR}/${P}-lua.patch" \
+ epatch \
+ "${FILESDIR}"/${P}-lua.patch \
"${FILESDIR}"/${P}-underlink.patch \
- "${FILESDIR}"/${P}-curl-headers.patch
+ "${FILESDIR}"/${P}-curl-headers.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
eautoreconf
}
diff --git a/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-libpng15.patch b/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-libpng15.patch
new file mode 100644
index 000000000000..c5644e80bfe5
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-libpng15.patch
@@ -0,0 +1,31 @@
+--- gtk-v2/src/png.c
++++ gtk-v2/src/png.c
+@@ -571,7 +571,7 @@
+ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ return PNGX_OUTOFMEM;
+ }
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct (&png_ptr, &info_ptr,NULL);
+ return PNGX_DATA;
+ }
+--- x11/png.c
++++ x11/png.c
+@@ -88,7 +88,7 @@
+ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ return NULL;
+ }
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct (&png_ptr, &info_ptr, NULL);
+ return NULL;
+ }
+@@ -600,7 +600,7 @@
+ png_destroy_read_struct (&png_ptr, NULL, NULL);
+ return PNGX_OUTOFMEM;
+ }
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct (&png_ptr, &info_ptr, NULL);
+ return PNGX_DATA;
+ }