summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-31 06:33:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-31 06:33:28 +0000
commit6701b4f4f855aa3cbbb15b255ebee140269a664c (patch)
tree6241ef3c0f8f7da785778729d05ed2d1febb38e1 /games-roguelike/slashem
parentremove version 1 (Manifest recommit) (diff)
downloadgentoo-2-6701b4f4f855aa3cbbb15b255ebee140269a664c.tar.gz
gentoo-2-6701b4f4f855aa3cbbb15b255ebee140269a664c.tar.bz2
gentoo-2-6701b4f4f855aa3cbbb15b255ebee140269a664c.zip
virtual/x11; error check sed; tidy DEPEND; tidy use; append-flags into src_unpack
Diffstat (limited to 'games-roguelike/slashem')
-rw-r--r--games-roguelike/slashem/ChangeLog6
-rw-r--r--games-roguelike/slashem/slashem-0.0.648.ebuild64
2 files changed, 43 insertions, 27 deletions
diff --git a/games-roguelike/slashem/ChangeLog b/games-roguelike/slashem/ChangeLog
index 0ed22c205ef7..c900fa50a748 100644
--- a/games-roguelike/slashem/ChangeLog
+++ b/games-roguelike/slashem/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/slashem
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/slashem/ChangeLog,v 1.4 2004/03/15 16:28:34 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/slashem/ChangeLog,v 1.5 2004/03/31 06:33:27 mr_bones_ Exp $
+
+ 30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> slashem-0.0.648.ebuild:
+ virtual/x11; error check sed; tidy DEPEND; tidy use; append-flags into
+ src_unpack
15 Mar 2004; David Holm <dholm@gentoo.org> slashem-0.0.648.ebuild:
Added to ~ppc.
diff --git a/games-roguelike/slashem/slashem-0.0.648.ebuild b/games-roguelike/slashem/slashem-0.0.648.ebuild
index 5cc96a77050f..fbca3046edbd 100644
--- a/games-roguelike/slashem/slashem-0.0.648.ebuild
+++ b/games-roguelike/slashem/slashem-0.0.648.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/slashem/slashem-0.0.648.ebuild,v 1.5 2004/03/15 16:28:35 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/slashem/slashem-0.0.648.ebuild,v 1.6 2004/03/31 06:33:28 mr_bones_ Exp $
-inherit games eutils flag-o-matic
-append-flags -I../include -I/usr/X11R6/include
+inherit eutils flag-o-matic games
-SE_VER=0.0.6E4F8
-SE_PN=se006e4f8.tar.gz
-SE_CONF=conf111s.tar.gz
+SE_VER="0.0.6E4F8"
+SE_PN="se006e4f8.tar.gz"
+SE_CONF="conf111s.tar.gz"
DESCRIPTION="Super Lotsa Added Stuff Hack - Extended Magic. A Nethack Variant."
HOMEPAGE="http://www.slashem.org/"
@@ -20,24 +19,29 @@ SLOT="0"
KEYWORDS="x86 amd64 ~ppc"
IUSE="X qt gnome gtk"
-DEPEND="virtual/glibc
- dev-util/yacc
+RDEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r5
- X? ( x11-base/xfree )
+ X? ( virtual/x11 )
qt? ( =x11-libs/qt-2* )
gnome? ( >=gnome-base/gnome-libs-1.4.1.4-r2 )
gtk? ( =x11-libs/gtk+-1.2* )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ dev-util/yacc"
HACKDIR=${GAMES_STATEDIR}/${PN}
S=${WORKDIR}/slashem-${SE_VER}
src_unpack() {
+ append-flags -I../include -I/usr/X11R6/include
unpack ${SE_PN}
epatch ${FILESDIR}/${SE_VER}-makefile.patch
epatch ${FILESDIR}/${SE_VER}-errno.patch
cd ${S}
epatch ${FILESDIR}/${SE_VER}-gentoo-paths.patch
- sed -i "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h
+ sed -i \
+ -e "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h \
+ || die "sed include/unixconf.h failed"
# This copies the /sys/unix Makefile.*s to their correct places for
# seding and compiling.
@@ -50,18 +54,24 @@ src_unpack() {
./config RedHat ../..
./config FHS20 ../..
- if [ `use X` ] ; then
+ if use X ; then
./config X11 ../.. || die "X config"
- [ `use qt` ] && { ./config qt ../.. || die "qt config"; }
- [ `use gtk` ] && { ./config gtk ../.. || die "gtk config"; }
- [ `use gnome` ] && { ./config gnome ../.. || die "gnome config"; }
+ use qt && { ./config qt ../.. || die "qt config"; }
+ use gtk && { ./config gtk ../.. || die "gtk config"; }
+ use gnome && { ./config gnome ../.. || die "gnome config"; }
fi
cd ${S}
- sed -i -e "s:^\(\# define HACKDIR \).*:\1 \"${HACKDIR}\":" include/config.h || die "config.h sed"
+ sed -i \
+ -e "s:^\(\# define HACKDIR \).*:\1 \"${HACKDIR}\":" include/config.h \
+ || die "config.h sed"
sed -i -e "s:^\(CFLAGS =\).*:\1 ${CFLAGS}:" src/Makefile || die "src/makefile sed"
- sed -i -e "s:^\(FILE_AREA_UNSHARE =\).*:\1 ${GAMES_LIBDIR}/${PN}:" Makefile || die "makefile sed"
- sed -i -e "s:^\(\#define FILE_AREA_UNSHARE \).*:\1\"${GAMES_LIBDIR}/${PN}/\":" include/unixconf.h || die "unixconf.h sed"
+ sed -i \
+ -e "s:^\(FILE_AREA_UNSHARE =\).*:\1 ${GAMES_LIBDIR}/${PN}:" Makefile \
+ || die "makefile sed"
+ sed -i \
+ -e "s:^\(\#define FILE_AREA_UNSHARE \).*:\1\"${GAMES_LIBDIR}/${PN}/\":" include/unixconf.h \
+ || die "unixconf.h sed"
}
src_compile() {
@@ -91,7 +101,7 @@ src_install() {
newgamesbin util/recover recover-slashem
- if [ `use X` ] ; then
+ if use X ; then
# install slashem fonts
dodir ${GAMES_DATADIR}/${PN}/fonts
cd ${S}/win/X11
@@ -104,25 +114,27 @@ src_install() {
# copy slashem X application defaults
cd ${S}/win/X11
- cp SlashEM.ad SlashEM.ad.orig
- sed -e 's/^\(SlashEM\*font:\).*/\1 fixed/' \
+ sed -i \
+ -e 's/^\(SlashEM\*font:\).*/\1 fixed/' \
-e 's/^\(SlashEM\*map\*font:\).*/\1 fixed/' \
-e 's:^!\(SlashEM.tile_file.*\):\1:' \
- SlashEM.ad.orig >SlashEM.ad || die "Patching SlashEM.ad for X failed"
+ SlashEM.ad \
+ || die "Patching SlashEM.ad for X failed"
cp SlashEM.ad SlashEM
insinto /etc/X11/app-defaults
- newins SlashEM.ad SlashEM || die "Failed to install SlashEM X app defaults"
+ newins SlashEM.ad SlashEM \
+ || die "Failed to install SlashEM X app defaults"
fi
insinto ${GAMES_DATADIR}/${PN}
doins ${FILESDIR}/dot.slashemrc
local windowtypes="tty"
- [ `use gnome` ] && windowtypes="${windowtypes} gnome"
- [ `use qt` ] && windowtypes="${windowtypes} qt"
- [ `use X` ] && windowtypes="${windowtypes} x11"
- [ `use gtk` ] && windowtypes="${windowtypes} gtk"
+ use gnome && windowtypes="${windowtypes} gnome"
+ use qt && windowtypes="${windowtypes} qt"
+ use X && windowtypes="${windowtypes} x11"
+ use gtk && windowtypes="${windowtypes} gtk"
set -- ${windowtypes}
dosed "s:GENTOO_WINDOWTYPES:${windowtypes}:" ${GAMES_DATADIR}/${PN}/dot.slashemrc
insinto /etc/skel