summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-05-07 23:29:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-05-07 23:29:09 +0000
commit2de029d1a5b06fc291c1ce39b75a5e5f0d051cdc (patch)
treefa7bc5e63d077a1f8f1f16e0ad0daa765b6d14fc /games-roguelike/scourge
parentRevbump for previous change. (diff)
downloadgentoo-2-2de029d1a5b06fc291c1ce39b75a5e5f0d051cdc.tar.gz
gentoo-2-2de029d1a5b06fc291c1ce39b75a5e5f0d051cdc.tar.bz2
gentoo-2-2de029d1a5b06fc291c1ce39b75a5e5f0d051cdc.zip
fix build with automake-1.13
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-roguelike/scourge')
-rw-r--r--games-roguelike/scourge/ChangeLog8
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch11
-rw-r--r--games-roguelike/scourge/scourge-0.21.1.ebuild8
3 files changed, 22 insertions, 5 deletions
diff --git a/games-roguelike/scourge/ChangeLog b/games-roguelike/scourge/ChangeLog
index f59fdf03bfd7..9dc552732b38 100644
--- a/games-roguelike/scourge/ChangeLog
+++ b/games-roguelike/scourge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/scourge
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.38 2012/08/31 19:37:57 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.39 2013/05/07 23:29:09 hasufell Exp $
+
+ 07 May 2013; Julian Ospald <hasufell@gentoo.org> scourge-0.21.1.ebuild,
+ +files/scourge-0.21.1-automake-1.13.patch:
+ fix build with automake-1.13
31 Aug 2012; Alfredo Tupone <tupone@gentoo.org> scourge-0.21.1.ebuild,
+files/scourge-0.21.1-gcc47.patch:
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch b/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch
new file mode 100644
index 000000000000..44b817e55cb3
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- scourge-0.21.1.src/scourge/configure.in
++++ scourge-0.21.1.src/scourge/configure.in
+@@ -4,7 +4,7 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(src/scourge.h)
+ AM_INIT_AUTOMAKE(scourge, "0.21")
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ dnl internationalization macros
+ AC_GNU_SOURCE
diff --git a/games-roguelike/scourge/scourge-0.21.1.ebuild b/games-roguelike/scourge/scourge-0.21.1.ebuild
index b1d15014f8a7..c4ad9284e7c6 100644
--- a/games-roguelike/scourge/scourge-0.21.1.ebuild
+++ b/games-roguelike/scourge/scourge-0.21.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.21.1.ebuild,v 1.7 2012/08/31 19:37:57 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.21.1.ebuild,v 1.8 2013/05/07 23:29:09 hasufell Exp $
EAPI=2
inherit autotools eutils wxwidgets games
@@ -38,7 +38,9 @@ src_prepare() {
sed -i \
-e '/snprintf/s/tmp, 256/tmp, sizeof(tmp)/' \
src/scourgehandler.cpp || die
- epatch "${FILESDIR}"/${P}-gcc47.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ mv configure.{in,ac} || die
eautoreconf
}