summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2015-02-20 16:29:51 +0000
committerSven Vermeulen <swift@gentoo.org>2015-02-20 16:29:51 +0000
commitadbd346592095641b540f48d219c0dca1ebe5357 (patch)
tree42e77abcbc12e5de5b0577122e948436c00b7e81 /games-roguelike/nethack
parentUpdate ebuild to reflect QA policy on games and gamestats, with thanks to Lui... (diff)
downloadgentoo-2-adbd346592095641b540f48d219c0dca1ebe5357.tar.gz
gentoo-2-adbd346592095641b540f48d219c0dca1ebe5357.tar.bz2
gentoo-2-adbd346592095641b540f48d219c0dca1ebe5357.zip
Dropping vulnerable nethack (-r1) and older ebuild (-r2) that did not comply with the policy on gamestats
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'games-roguelike/nethack')
-rw-r--r--games-roguelike/nethack/ChangeLog7
-rw-r--r--games-roguelike/nethack/nethack-3.4.3-r1.ebuild183
-rw-r--r--games-roguelike/nethack/nethack-3.4.3-r2.ebuild185
3 files changed, 6 insertions, 369 deletions
diff --git a/games-roguelike/nethack/ChangeLog b/games-roguelike/nethack/ChangeLog
index b12b7cffc742..4edb80284761 100644
--- a/games-roguelike/nethack/ChangeLog
+++ b/games-roguelike/nethack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/nethack
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/ChangeLog,v 1.39 2015/02/20 16:24:58 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/ChangeLog,v 1.40 2015/02/20 16:29:51 swift Exp $
+
+ 20 Feb 2015; Sven Vermeulen <swift@gentoo.org> -nethack-3.4.3-r1.ebuild,
+ -nethack-3.4.3-r2.ebuild:
+ Dropping vulnerable nethack (-r1) and older ebuild (-r2) that did not comply
+ with the policy on gamestats
*nethack-3.4.3-r3 (20 Feb 2015)
diff --git a/games-roguelike/nethack/nethack-3.4.3-r1.ebuild b/games-roguelike/nethack/nethack-3.4.3-r1.ebuild
deleted file mode 100644
index 00e0f703772b..000000000000
--- a/games-roguelike/nethack/nethack-3.4.3-r1.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.3-r1.ebuild,v 1.28 2014/03/21 05:11:09 jer Exp $
-
-EAPI=2
-inherit eutils toolchain-funcs flag-o-matic games
-
-MY_PV=${PV//.}
-DESCRIPTION="The ultimate old-school single player dungeon exploration game"
-HOMEPAGE="http://www.nethack.org/"
-SRC_URI="mirror://sourceforge/nethack/${PN}-${MY_PV}-src.tgz"
-
-LICENSE="nethack"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc sparc x86 ~x86-fbsd"
-IUSE="X"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r5
- X? (
- x11-libs/libXaw
- x11-libs/libXpm
- x11-libs/libXt
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- X? (
- x11-proto/xproto
- x11-apps/bdftopcf
- x11-apps/mkfontdir
- )"
-
-HACKDIR=${GAMES_DATADIR}/${PN}
-
-src_prepare() {
- # This copies the /sys/unix Makefile.*s to their correct places for
- # seding and compiling.
- cd "sys/unix"
- source setup.sh || die
-
- cd ../..
- epatch \
- "${FILESDIR}"/${PV}-gentoo-paths.patch \
- "${FILESDIR}"/${PV}-default-options.patch \
- "${FILESDIR}"/${PV}-bison.patch \
- "${FILESDIR}"/${PV}-macos.patch \
- "${FILESDIR}"/${P}-gibc210.patch \
- "${FILESDIR}"/${P}-recover.patch
-
- mv doc/recover.6 doc/nethack-recover.6
-
- sed -i \
- -e "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h \
- || die "setting statedir"
- sed -i \
- -e "s:GENTOO_HACKDIR:${HACKDIR}:" include/config.h \
- || die "setting hackdir"
- # set the default pager from the environment bug #52122
- if [[ -n "${PAGER}" ]] ; then
- sed -i \
- -e "115c\#define DEF_PAGER \"${PAGER}\"" \
- include/unixconf.h \
- || die "setting statedir"
- # bug #57410
- sed -i \
- -e "s/^DATNODLB =/DATNODLB = \$(DATHELP)/" Makefile \
- || die "sed Makefile failed"
- fi
-
- # sys-libs/ncurses[tinfo]
- sed -i \
- -e '/^WINTTYLIB/s| = .*| = '"$(
- $(tc-getPKG_CONFIG) --libs ncurses
- )"'|g' \
- src/Makefile || die
-
- if use X ; then
- epatch "${FILESDIR}/${PV}-X-support.patch"
- fi
-}
-
-src_compile() {
- local lflags="${LDFLAGS}"
-
- cd "${S}"/src
- append-flags -I../include
-
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LFLAGS="${lflags}" \
- ../util/makedefs \
- || die "initial makedefs build failed"
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LFLAGS="${lflags}" \
- || die "main build failed"
- cd "${S}"/util
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LFLAGS="${lflags}" \
- recover || die "util build failed"
-}
-
-src_install() {
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LFLAGS="-L/usr/X11R6/lib" \
- GAMEPERM=0755 \
- GAMEUID="${GAMES_USER}" GAMEGRP="${GAMES_GROUP}" \
- PREFIX="${D}/usr" \
- GAMEDIR="${D}${HACKDIR}" \
- SHELLDIR="${D}/${GAMES_BINDIR}" \
- install \
- || die "emake install failed"
-
- # We keep this stuff in ${GAMES_STATEDIR} instead so tidy up.
- rm -rf "${D}/usr/share/games/nethack/save"
-
- newgamesbin util/recover recover-nethack || die "newgamesbin failed"
-
- # The final nethack is a sh script. This fixes the hard-coded
- # HACKDIR directory so it doesn't point to ${D}/usr/share/nethackdir
- sed -i \
- -e "s:^\(HACKDIR=\).*:\1${HACKDIR}:" \
- "${D}${GAMES_BINDIR}/nethack" \
- || die "sed ${GAMES_BINDIR}/nethack failed"
-
- doman doc/*.6
- dodoc doc/*.txt
-
- # Can be copied to ~/.nethackrc to set options
- # Add this to /etc/.skel as well, thats the place for default configs
- insinto "${HACKDIR}"
- doins "${FILESDIR}/dot.nethackrc"
-
- local windowtypes="tty"
- use X && windowtypes="${windowtypes} x11"
- set -- ${windowtypes}
- sed -i \
- -e "s:GENTOO_WINDOWTYPES:${windowtypes}:" \
- -e "s:GENTOO_DEFWINDOWTYPE:$1:" \
- "${D}${HACKDIR}/dot.nethackrc" \
- || die "sed ${HACKDIR}/dot.nethackrc failed"
- insinto /etc/skel
- newins "${D}/${HACKDIR}/dot.nethackrc" .nethackrc
-
- if use X ; then
- # install nethack fonts
- cd "${S}/win/X11"
- bdftopcf -o nh10.pcf nh10.bdf || die "Converting fonts failed"
- bdftopcf -o ibm.pcf ibm.bdf || die "Converting fonts failed"
- insinto "${HACKDIR}/fonts"
- doins *.pcf
- cd "${D}/${HACKDIR}/fonts"
- mkfontdir || die "The action mkfontdir ${HACKDIR}/fonts failed"
-
- # copy nethack x application defaults
- cd "${S}/win/X11"
- insinto /etc/X11/app-defaults
- newins NetHack.ad NetHack || die "Failed to install NetHack X app defaults"
- sed -i \
- -e 's:^!\(NetHack.tile_file.*\):\1:' \
- "${D}/etc/X11/app-defaults/NetHack" \
- || die "sed /etc/X11/app-defaults/NetHack failed"
- fi
-
- local statedir="${GAMES_STATEDIR}/${PN}"
- keepdir "${statedir}/save"
- mv "${D}/${HACKDIR}/"{record,logfile,perm} "${D}/${statedir}/"
- make_desktop_entry nethack "Nethack"
-
- prepgamesdirs
- chmod -R 660 "${D}/${statedir}"
- chmod 770 "${D}/${statedir}" "${D}/${statedir}/save"
-}
-
-pkg_postinst() {
- games_pkg_postinst
- elog "You may want to look at /etc/skel/.nethackrc for interesting options"
-}
diff --git a/games-roguelike/nethack/nethack-3.4.3-r2.ebuild b/games-roguelike/nethack/nethack-3.4.3-r2.ebuild
deleted file mode 100644
index e4be4e943820..000000000000
--- a/games-roguelike/nethack/nethack-3.4.3-r2.ebuild
+++ /dev/null
@@ -1,185 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.3-r2.ebuild,v 1.2 2015/02/20 09:40:11 ulm Exp $
-
-EAPI=5
-inherit eutils toolchain-funcs flag-o-matic user
-
-MY_PV=${PV//.}
-DESCRIPTION="The ultimate old-school single player dungeon exploration game"
-HOMEPAGE="http://www.nethack.org/"
-SRC_URI="mirror://sourceforge/nethack/${PN}-${MY_PV}-src.tgz"
-
-LICENSE="nethack"
-SLOT="0"
-#KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="X"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r5
- X? (
- x11-libs/libXaw
- x11-libs/libXpm
- x11-libs/libXt
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- X? (
- x11-proto/xproto
- x11-apps/bdftopcf
- x11-apps/mkfontdir
- )"
-
-HACKDIR="/usr/share/${PN}"
-STATEDIR="/var/lib/${PN}"
-
-pkg_setup() {
- enewgroup nethack
-}
-
-src_prepare() {
- # This copies the /sys/unix Makefile.*s to their correct places for
- # seding and compiling.
- cd "sys/unix"
- source setup.sh || die
-
- cd ../..
- epatch \
- "${FILESDIR}"/${PV}-gentoo-paths.patch \
- "${FILESDIR}"/${PV}-default-options.patch \
- "${FILESDIR}"/${PV}-bison.patch \
- "${FILESDIR}"/${PV}-macos.patch \
- "${FILESDIR}"/${P}-gibc210.patch \
- "${FILESDIR}"/${P}-recover.patch
-
- epatch_user
-
- mv doc/recover.6 doc/nethack-recover.6
-
- sed -i \
- -e "s:GENTOO_STATEDIR:${STATEDIR}:" include/unixconf.h \
- || die "setting statedir"
- sed -i \
- -e "s:GENTOO_HACKDIR:${HACKDIR}:" include/config.h \
- || die "setting hackdir"
- # set the default pager from the environment bug #52122
- if [[ -n "${PAGER}" ]] ; then
- sed -i \
- -e "115c\#define DEF_PAGER \"${PAGER}\"" \
- include/unixconf.h \
- || die "setting statedir"
- # bug #57410
- sed -i \
- -e "s/^DATNODLB =/DATNODLB = \$(DATHELP)/" Makefile \
- || die "sed Makefile failed"
- fi
-
- # sys-libs/ncurses[tinfo]
- sed -i \
- -e '/^WINTTYLIB/s| = .*| = '"$(
- $(tc-getPKG_CONFIG) --libs ncurses
- )"'|g' \
- src/Makefile || die
-
- if use X ; then
- epatch "${FILESDIR}/${PV}-X-support.patch"
- fi
-}
-
-src_compile() {
- local lflags="${LDFLAGS}"
-
- cd "${S}"/src
- append-flags -I../include
-
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LFLAGS="${lflags}" \
- ../util/makedefs
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LFLAGS="${lflags}"
- cd "${S}"/util
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LFLAGS="${lflags}" \
- recover
-}
-
-src_install() {
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LFLAGS="-L/usr/X11R6/lib" \
- GAMEPERM=02755 \
- GAMEUID="root" GAMEGRP="nethack" \
- PREFIX="${D}/usr" \
- GAMEDIR="${D}${HACKDIR}" \
- SHELLDIR="${D}/usr/bin" \
- install
-
- # We keep this stuff in STATEDIR instead so tidy up.
- rm -rf "${D}/usr/share/nethack/"{recover,save}
-
- newbin util/recover recover-nethack
-
- # The final nethack is a sh script. This fixes the hard-coded
- # HACKDIR directory so it doesn't point to ${D}/usr/share/nethackdir
- sed -i \
- -e "s:^\(HACKDIR=\).*:\1${HACKDIR}:" \
- "${D}/usr/bin/nethack" \
- || die "sed /usr/bin/nethack failed"
-
- doman doc/*.6
- dodoc doc/*.txt
-
- # Can be copied to ~/.nethackrc to set options
- # Add this to /etc/.skel as well, thats the place for default configs
- insinto "${HACKDIR}"
- doins "${FILESDIR}/dot.nethackrc"
-
- local windowtypes="tty"
- use X && windowtypes="${windowtypes} x11"
- set -- ${windowtypes}
- sed -i \
- -e "s:GENTOO_WINDOWTYPES:${windowtypes}:" \
- -e "s:GENTOO_DEFWINDOWTYPE:$1:" \
- "${D}${HACKDIR}/dot.nethackrc" \
- || die "sed ${HACKDIR}/dot.nethackrc failed"
- insinto /etc/skel
- newins "${D}/${HACKDIR}/dot.nethackrc" .nethackrc
-
- if use X ; then
- # install nethack fonts
- cd "${S}/win/X11"
- bdftopcf -o nh10.pcf nh10.bdf || die "Converting fonts failed"
- bdftopcf -o ibm.pcf ibm.bdf || die "Converting fonts failed"
- insinto "${HACKDIR}/fonts"
- doins *.pcf
- cd "${D}/${HACKDIR}/fonts"
- mkfontdir || die "The action mkfontdir ${HACKDIR}/fonts failed"
-
- # copy nethack x application defaults
- cd "${S}/win/X11"
- insinto /etc/X11/app-defaults
- newins NetHack.ad NetHack
- sed -i \
- -e 's:^!\(NetHack.tile_file.*\):\1:' \
- "${D}/etc/X11/app-defaults/NetHack" \
- || die "sed /etc/X11/app-defaults/NetHack failed"
- fi
-
- keepdir "${STATEDIR}/save"
- mv "${D}/${HACKDIR}/"{record,logfile,perm} "${D}/${STATEDIR}/"
- make_desktop_entry nethack "Nethack"
-
- chgrp -R nethack "${D}/${STATEDIR}"
- chmod -R 660 "${D}/${STATEDIR}"
- chmod 770 "${D}/${STATEDIR}" "${D}/${STATEDIR}/save"
-}
-
-pkg_postinst() {
- elog "You may want to look at /etc/skel/.nethackrc for interesting options"
-}