summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-21 00:43:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-21 00:43:58 +0000
commitfc3771fb42ec284635f44c2a1a352b1775cab5d1 (patch)
tree89e86a8460b108986114f7bc424378750c227119 /games-puzzle
parentVersion bump. (diff)
downloadgentoo-2-fc3771fb42ec284635f44c2a1a352b1775cab5d1.tar.gz
gentoo-2-fc3771fb42ec284635f44c2a1a352b1775cab5d1.tar.bz2
gentoo-2-fc3771fb42ec284635f44c2a1a352b1775cab5d1.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/kiki/ChangeLog8
-rw-r--r--games-puzzle/kiki/kiki-1.0.2-r2.ebuild19
2 files changed, 14 insertions, 13 deletions
diff --git a/games-puzzle/kiki/ChangeLog b/games-puzzle/kiki/ChangeLog
index 38d42b3c1fb9..745f120041ae 100644
--- a/games-puzzle/kiki/ChangeLog
+++ b/games-puzzle/kiki/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/kiki
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.19 2012/04/13 19:21:33 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.20 2015/04/21 00:43:58 mr_bones_ Exp $
+
+ 21 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org> kiki-1.0.2-r2.ebuild:
+ EAPI=5
13 Apr 2012; Ulrich Müller <ulm@gentoo.org> kiki-1.0.2-r2.ebuild:
Move EAPI assignment to top of ebuild, bug 411875.
@@ -70,4 +73,3 @@
05 Aug 2003; Michael Sterrett <msterret@gentoo.org> kiki-0.9.0.ebuild:
initial commit. ebuild supplied by Brent Kelly and modified. (bug 25977)
-
diff --git a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
index b6b0f93c24c1..3b731861475d 100644
--- a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
+++ b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2-r2.ebuild,v 1.8 2012/04/13 19:21:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2-r2.ebuild,v 1.9 2015/04/21 00:43:58 mr_bones_ Exp $
-EAPI=2
+EAPI=5
PYTHON_DEPEND="2"
-
inherit eutils python toolchain-funcs games
DESCRIPTION="Fun 3D puzzle game using SDL/OpenGL"
@@ -41,8 +40,7 @@ src_prepare() {
-e "s:kiki_home += \"/\";:kiki_home = \"${GAMES_DATADIR}/${PN}/\";:g" \
-e "s:KConsole\:\:printf(\"WARNING \:\: environment variable KIKI_HOME not set ...\");::g" \
-e "s:KConsole\:\:printf(\" ... assuming resources in current directory\");::g" \
- src/main/KikiController.cpp \
- || die "sed KikiController.cpp failed"
+ src/main/KikiController.cpp || die
# Bug 139570
cd SWIG
@@ -52,21 +50,22 @@ src_prepare() {
}
src_compile() {
- emake -C kodilib/linux AR="$(tc-getAR)" || die "emake kodilib failed"
- emake -C linux PYTHON_VERSION="$(python_get_version)" || die "emake linux failed"
+ emake -C kodilib/linux AR="$(tc-getAR)"
+ emake -C linux PYTHON_VERSION="$(python_get_version)"
}
src_install() {
- dogamesbin linux/kiki || die "dogamesbin failed"
+ dogamesbin linux/kiki
insinto "${GAMES_DATADIR}"/${PN}
- doins -r py sound || die "doins failed"
+ doins -r py sound
dodoc Readme.txt Thanks.txt
prepgamesdirs
}
pkg_setup() {
+ python_pkg_setup
python_set_active_version 2
games_pkg_setup
}