summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-29 15:32:40 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-29 15:32:40 +0000
commitd8c9f89dc6d5c9494d0ff7b66f9c96fce51a5cbf (patch)
treead0861d0aca58383df64dec88366da1f7bee465a /games-puzzle
parentFix ampersand handling thanks to clotho in bug #132527. Also drop arm keyword... (diff)
downloadgentoo-2-d8c9f89dc6d5c9494d0ff7b66f9c96fce51a5cbf.tar.gz
gentoo-2-d8c9f89dc6d5c9494d0ff7b66f9c96fce51a5cbf.tar.bz2
gentoo-2-d8c9f89dc6d5c9494d0ff7b66f9c96fce51a5cbf.zip
Fixed binaries being pre-stripped. Thanks to Tristan Heaven <tristanheaven@gmail.com> for the patch. Closing bug #137711.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ensemblist/ChangeLog7
-rw-r--r--games-puzzle/ensemblist/ensemblist-040126.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/games-puzzle/ensemblist/ChangeLog b/games-puzzle/ensemblist/ChangeLog
index 8066bbc0873f..741876227bb6 100644
--- a/games-puzzle/ensemblist/ChangeLog
+++ b/games-puzzle/ensemblist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/ensemblist
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ChangeLog,v 1.4 2006/02/16 20:33:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ChangeLog,v 1.5 2006/06/29 15:32:40 wolf31o2 Exp $
+
+ 29 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ ensemblist-040126.ebuild:
+ Fixed binaries being pre-stripped. Thanks to Tristan Heaven
+ <tristanheaven@gmail.com> for the patch. Closing bug #137711.
16 Feb 2006; <Tupone@gentoo.org> ensemblist-040126.ebuild:
modular X dependency fix
diff --git a/games-puzzle/ensemblist/ensemblist-040126.ebuild b/games-puzzle/ensemblist/ensemblist-040126.ebuild
index c1e2177e6beb..697e12db679b 100644
--- a/games-puzzle/ensemblist/ensemblist-040126.ebuild
+++ b/games-puzzle/ensemblist/ensemblist-040126.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ensemblist-040126.ebuild,v 1.4 2006/02/16 20:33:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ensemblist-040126.ebuild,v 1.5 2006/06/29 15:32:40 wolf31o2 Exp $
inherit games
@@ -25,6 +25,7 @@ src_unpack() {
cd "${S}"
sed -i \
-e '/^CC/d' \
+ -e '/strip/d' \
-e "s:^DATADIR=.*:DATADIR=${GAMES_DATADIR}/${PN}/datas:" \
-e "/^COMPILE_FLAGS/s/-Wall -O3 -fomit-frame-pointer/${CFLAGS}/" \
Makefile || die "sed failed"
@@ -32,8 +33,8 @@ src_unpack() {
src_install() {
dogamesbin ensemblist || die "dogamesbin failed"
- dodir "${GAMES_DATADIR}/${PN}"
- cp -r datas/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r datas || die "doins failed"
dodoc README Changelog
prepgamesdirs
}