summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-30 05:00:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-30 05:00:28 +0000
commit38e2d2b5b882a09f711909dc4fb2e2d6415af34d (patch)
treea73a3d142f1fe59bb76a51f069166a3a4239b5d7 /games-puzzle
parentversion bump (diff)
downloadgentoo-2-38e2d2b5b882a09f711909dc4fb2e2d6415af34d.tar.gz
gentoo-2-38e2d2b5b882a09f711909dc4fb2e2d6415af34d.tar.bz2
gentoo-2-38e2d2b5b882a09f711909dc4fb2e2d6415af34d.zip
fix USE=-opengl compile (bug #404425)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pingus/ChangeLog6
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch10
-rw-r--r--games-puzzle/pingus/pingus-0.7.6.ebuild3
3 files changed, 17 insertions, 2 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index 93e71cc13c63..8ce3b900592f 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/pingus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.41 2012/06/29 20:11:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.42 2012/06/30 05:00:28 mr_bones_ Exp $
+
+ 30 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/pingus-0.7.6-noopengl.patch, pingus-0.7.6.ebuild:
+ fix USE=-opengl compile (bug #404425)
29 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.7.6.ebuild:
use the latest boost
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch b/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch
new file mode 100644
index 000000000000..e474ef7376e5
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch
@@ -0,0 +1,10 @@
+--- src/engine/display/display.cpp.orig 2012-06-30 00:30:13.043995049 -0400
++++ src/engine/display/display.cpp 2012-06-30 00:30:28.194501544 -0400
+@@ -28,6 +28,7 @@
+ #include "engine/display/delta/delta_framebuffer.hpp"
+ #include "engine/display/null_framebuffer.hpp"
+ #include "util/log.hpp"
++#include "util/raise_exception.hpp"
+
+ std::unique_ptr<Framebuffer> Display::s_framebuffer;
+
diff --git a/games-puzzle/pingus/pingus-0.7.6.ebuild b/games-puzzle/pingus/pingus-0.7.6.ebuild
index 8e725811d6cd..9ec8604cd3d4 100644
--- a/games-puzzle/pingus/pingus-0.7.6.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.6.ebuild,v 1.6 2012/06/29 20:11:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.6.ebuild,v 1.7 2012/06/30 05:00:28 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic scons-utils toolchain-funcs games
@@ -38,6 +38,7 @@ src_prepare() {
export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
strip-flags
+ epatch "${FILESDIR}"/${P}-noopengl.patch
}
src_compile() {