summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-06 18:56:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-06 18:56:45 +0000
commit2ed5a2dce6b837cd11cda054fa8704bc2bebb90c (patch)
tree8818b0efa539dd9dc62256fd3443b620c9962865 /games-puzzle
parentRemove short <longdescription>. (diff)
downloadgentoo-2-2ed5a2dce6b837cd11cda054fa8704bc2bebb90c.tar.gz
gentoo-2-2ed5a2dce6b837cd11cda054fa8704bc2bebb90c.tar.bz2
gentoo-2-2ed5a2dce6b837cd11cda054fa8704bc2bebb90c.zip
use epatch
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/icebreaker/ChangeLog8
-rw-r--r--games-puzzle/icebreaker/icebreaker-1.9.6.ebuild15
2 files changed, 14 insertions, 9 deletions
diff --git a/games-puzzle/icebreaker/ChangeLog b/games-puzzle/icebreaker/ChangeLog
index 88e4596e78f3..3f623c27abcb 100644
--- a/games-puzzle/icebreaker/ChangeLog
+++ b/games-puzzle/icebreaker/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/icebreaker
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/ChangeLog,v 1.18 2013/06/24 20:45:12 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/ChangeLog,v 1.19 2015/01/06 18:56:45 mr_bones_ Exp $
+
+ 06 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> icebreaker-1.9.6.ebuild:
+ use epatch
24 Jun 2013; Tupone Alfredo <tupone@gentoo.org> icebreaker-1.9.6.ebuild,
+files/icebreaker-1.9.6-ovfl.patch:
@@ -88,4 +91,3 @@
files/digest-icebreaker-1.2.1 :
New game
-
diff --git a/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild b/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
index 246169fcc72f..c90a01c54ebd 100644
--- a/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
+++ b/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild,v 1.2 2013/06/24 20:45:12 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/icebreaker-1.9.6.ebuild,v 1.3 2015/01/06 18:56:45 mr_bones_ Exp $
EAPI=5
inherit eutils games
@@ -18,10 +18,13 @@ RDEPEND="media-libs/libsdl[video]
media-libs/sdl-mixer"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-ldflags.patch
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-parallell-install.patch
- "${FILESDIR}"/${P}-ovfl.patch )
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-parallell-install.patch \
+ "${FILESDIR}"/${P}-ovfl.patch
+}
src_compile() {
emake \