summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-06-13 15:50:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-06-13 15:50:01 +0000
commiteb209c277b801e79d7b9e77b5472c0a7b89cbfb3 (patch)
tree6f97fc7af4dd09b3fecb66ef45f5b8c86a9564dc /games-puzzle/zaz
parentFix year on openswan mask. (diff)
downloadgentoo-2-eb209c277b801e79d7b9e77b5472c0a7b89cbfb3.tar.gz
gentoo-2-eb209c277b801e79d7b9e77b5472c0a7b89cbfb3.tar.bz2
gentoo-2-eb209c277b801e79d7b9e77b5472c0a7b89cbfb3.zip
EAPI=5; fix build (bug #510432)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle/zaz')
-rw-r--r--games-puzzle/zaz/ChangeLog6
-rw-r--r--games-puzzle/zaz/zaz-1.0.0.ebuild14
2 files changed, 12 insertions, 8 deletions
diff --git a/games-puzzle/zaz/ChangeLog b/games-puzzle/zaz/ChangeLog
index 57a64a009bfb..0cf88c3fd361 100644
--- a/games-puzzle/zaz/ChangeLog
+++ b/games-puzzle/zaz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/zaz
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/ChangeLog,v 1.18 2014/05/15 16:55:29 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/ChangeLog,v 1.19 2014/06/13 15:50:01 mr_bones_ Exp $
+
+ 13 Jun 2014; Michael Sterrett <mr_bones_@gentoo.org> zaz-1.0.0.ebuild:
+ EAPI=5; fix build (bug #510432)
15 May 2014; Ulrich Müller <ulm@gentoo.org> zaz-1.0.0.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
@@ -76,4 +79,3 @@
26 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org> +zaz-0.2.8.ebuild,
+files/zaz-0.2.8-build.patch, +metadata.xml:
Initial commit (bug #282349)
-
diff --git a/games-puzzle/zaz/zaz-1.0.0.ebuild b/games-puzzle/zaz/zaz-1.0.0.ebuild
index 88d09c63357c..ed50f831561e 100644
--- a/games-puzzle/zaz/zaz-1.0.0.ebuild
+++ b/games-puzzle/zaz/zaz-1.0.0.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/zaz-1.0.0.ebuild,v 1.7 2014/05/15 16:55:29 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/zaz-1.0.0.ebuild,v 1.8 2014/06/13 15:50:01 mr_bones_ Exp $
-EAPI=2
-inherit autotools eutils games
+EAPI=5
+inherit autotools flag-o-matic eutils games
DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
HOMEPAGE="http://sourceforge.net/projects/zaz/"
SRC_URI="mirror://sourceforge/zaz/${P}.tar.bz2"
-LICENSE="GPL-3 CC-BY-SA-3.0"
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 OFL"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
@@ -35,6 +35,9 @@ src_prepare() {
}
src_configure() {
+ append-libs -lvorbis
+ append-cflags $(pkg-config sdl --cflags)
+ append-cxxflags $(pkg-config sdl --cflags)
egamesconf \
--disable-dependency-tracking \
--with-applicationdir=/usr/share/applications \
@@ -44,7 +47,6 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake failed"
- dodoc AUTHORS ChangeLog
+ default
prepgamesdirs
}