summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-17 21:25:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-17 21:25:39 +0000
commit3704eaeff6c179e211c9a743371db1da6dc7427f (patch)
treee3ef565bf86822414bdc409f4a0ef617664b79c4 /games-puzzle/xye
parentFix changelog. (diff)
downloadgentoo-2-3704eaeff6c179e211c9a743371db1da6dc7427f.tar.gz
gentoo-2-3704eaeff6c179e211c9a743371db1da6dc7427f.tar.bz2
gentoo-2-3704eaeff6c179e211c9a743371db1da6dc7427f.zip
version bump (bug #452318)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle/xye')
-rw-r--r--games-puzzle/xye/ChangeLog12
-rw-r--r--games-puzzle/xye/files/xye-0.12.0-gcc47.patch8
-rw-r--r--games-puzzle/xye/files/xye-0.12.1-gcc47.patch22
-rw-r--r--games-puzzle/xye/xye-0.12.1.ebuild41
4 files changed, 76 insertions, 7 deletions
diff --git a/games-puzzle/xye/ChangeLog b/games-puzzle/xye/ChangeLog
index 82aee808deef..b2c94e230269 100644
--- a/games-puzzle/xye/ChangeLog
+++ b/games-puzzle/xye/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-puzzle/xye
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/ChangeLog,v 1.31 2012/10/17 08:05:17 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/ChangeLog,v 1.32 2013/01/17 21:25:39 mr_bones_ Exp $
+
+*xye-0.12.1 (17 Jan 2013)
+
+ 17 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/xye-0.12.1-gcc47.patch, +xye-0.12.1.ebuild,
+ files/xye-0.12.0-gcc47.patch:
+ version bump (bug #452318)
17 Oct 2012; Tupone Alfredo <tupone@gentoo.org> xye-0.12.0.ebuild,
+files/xye-0.12.0-gcc47.patch:
@@ -129,4 +136,3 @@
02 May 2006; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+xye-0.7.5.ebuild:
initial commit - ebuild submitted by Cristiano Chiucchiolo via bug #131564
-
diff --git a/games-puzzle/xye/files/xye-0.12.0-gcc47.patch b/games-puzzle/xye/files/xye-0.12.0-gcc47.patch
index f638968dd404..04414abc6a2b 100644
--- a/games-puzzle/xye/files/xye-0.12.0-gcc47.patch
+++ b/games-puzzle/xye/files/xye-0.12.0-gcc47.patch
@@ -1,5 +1,5 @@
---- src/editorsave.cpp.old 2012-10-17 09:47:46.413566575 +0200
-+++ src/editorsave.cpp 2012-10-17 09:48:17.314366174 +0200
+--- src/editorsave.cpp.old
++++ src/editorsave.cpp
@@ -642,7 +642,8 @@
file << "<?xml version=\"1.0\" encoding=\"ISO-8859-1\"?>\n";
file << "<pack>\n<name>"<< stripXML(editorboard::filetitle) <<"</name><author>"<< stripXML(editorboard::author) <<"</author>\n<description>"<< stripXML(editorboard::description) <<"</description>\n";
@@ -10,8 +10,8 @@
editorboard::LoadLevelNumber(board, i);
file << "\n<level>\n";
file << "<title>"<< stripXML(board->title) <<"</title>\n";
---- src/gen.cpp.old 2012-10-17 09:41:40.825540267 +0200
-+++ src/gen.cpp 2012-10-17 09:41:57.087387319 +0200
+--- src/gen.cpp.old
++++ src/gen.cpp
@@ -21,6 +21,7 @@
#include<cstdio>
#include<iostream>
diff --git a/games-puzzle/xye/files/xye-0.12.1-gcc47.patch b/games-puzzle/xye/files/xye-0.12.1-gcc47.patch
new file mode 100644
index 000000000000..04414abc6a2b
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.1-gcc47.patch
@@ -0,0 +1,22 @@
+--- src/editorsave.cpp.old
++++ src/editorsave.cpp
+@@ -642,7 +642,8 @@
+ file << "<?xml version=\"1.0\" encoding=\"ISO-8859-1\"?>\n";
+ file << "<pack>\n<name>"<< stripXML(editorboard::filetitle) <<"</name><author>"<< stripXML(editorboard::author) <<"</author>\n<description>"<< stripXML(editorboard::description) <<"</description>\n";
+
+- for (int i=first; i<editorboard::CountLevels(); i++) {
++ int i;
++ for (i=first; i<editorboard::CountLevels(); i++) {
+ editorboard::LoadLevelNumber(board, i);
+ file << "\n<level>\n";
+ file << "<title>"<< stripXML(board->title) <<"</title>\n";
+--- src/gen.cpp.old
++++ src/gen.cpp
+@@ -21,6 +21,7 @@
+ #include<cstdio>
+ #include<iostream>
+ #include<fstream>
++#include <unistd.h>
+
+ const float F_RAND_MAX = (float)(RAND_MAX);
+
diff --git a/games-puzzle/xye/xye-0.12.1.ebuild b/games-puzzle/xye/xye-0.12.1.ebuild
new file mode 100644
index 000000000000..6806a345ac15
--- /dev/null
+++ b/games-puzzle/xye/xye-0.12.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/xye-0.12.1.ebuild,v 1.1 2013/01/17 21:25:39 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="Free version of the classic game Kye"
+HOMEPAGE="http://xye.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xye/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ media-fonts/dejavu"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ sed -i -e '/^xye_LDFLAGS/d' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ dogamesbin "${PN}"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r levels res
+ rm -f "${D}${GAMES_DATADIR}/${PN}"/res/DejaVuSans*
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}/${PN}"/res/DejaVuSans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}/${PN}"/res/DejaVuSans-Bold.ttf
+ dodoc AUTHORS ChangeLog README NEWS
+ dohtml ReadMe.html
+ doicon xye.svg
+ make_desktop_entry ${PN} Xye
+ prepgamesdirs
+}