summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-07-29 05:00:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-07-29 05:00:18 +0000
commit34a3d51844b0717856723c29421bf714a7391ef8 (patch)
treeafdd65bfb249d802c7c90f3791aa061c5eda1896 /games-puzzle/wizznic
parentRemove old non-fakegem ebuild. (diff)
downloadgentoo-2-34a3d51844b0717856723c29421bf714a7391ef8.tar.gz
gentoo-2-34a3d51844b0717856723c29421bf714a7391ef8.tar.bz2
gentoo-2-34a3d51844b0717856723c29421bf714a7391ef8.zip
initial commit
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/wizznic')
-rw-r--r--games-puzzle/wizznic/ChangeLog10
-rw-r--r--games-puzzle/wizznic/metadata.xml5
-rw-r--r--games-puzzle/wizznic/wizznic-0.9.ebuild50
3 files changed, 65 insertions, 0 deletions
diff --git a/games-puzzle/wizznic/ChangeLog b/games-puzzle/wizznic/ChangeLog
new file mode 100644
index 000000000000..3dae7657a137
--- /dev/null
+++ b/games-puzzle/wizznic/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-puzzle/wizznic
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wizznic/ChangeLog,v 1.1 2010/07/29 05:00:18 mr_bones_ Exp $
+
+*wizznic-0.9 (29 Jul 2010)
+
+ 29 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org> +wizznic-0.9.ebuild,
+ +metadata.xml:
+ initial commit
+
diff --git a/games-puzzle/wizznic/metadata.xml b/games-puzzle/wizznic/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/wizznic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/wizznic/wizznic-0.9.ebuild b/games-puzzle/wizznic/wizznic-0.9.ebuild
new file mode 100644
index 000000000000..86e1d9116dc8
--- /dev/null
+++ b/games-puzzle/wizznic/wizznic-0.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wizznic/wizznic-0.9.ebuild,v 1.1 2010/07/29 05:00:18 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+EXTRA_PV="_feedback_version-src"
+DESCRIPTION="Block-clearing puzzle game"
+HOMEPAGE="http://wizznic.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wizznic/${P}${EXTRA_PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[audio,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+
+S=${WORKDIR}/${P}${EXTRA_PV}
+
+src_prepare() {
+ sed \
+ -e '/^\(CC\|LD\|STRIP\)/d' \
+ -e 's/(LD)/(CC)/g' \
+ Makefile.linux > Makefile \
+ || die
+}
+
+src_compile() {
+ emake \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ BINDIR="${GAMES_BINDIR}" \
+ STRIP=true \
+ || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ BINDIR="${GAMES_BINDIR}" \
+ install || die
+ dodoc doc/{changelog.txt,credits.txt,media-licenses.txt,ports.txt,readme.txt}
+ newicon data/wmicon.png ${PN}.png
+ make_desktop_entry wizznic "Wizznic!"
+ prepgamesdirs
+}