summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-13 02:23:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-13 02:23:56 +0000
commit1a74104b32ec38a103a42a6df2d6aba73d6033bc (patch)
tree56d6c280801a64307a77a2beac63f171efc474a4 /games-puzzle/pingus
parentRevision bump to fix linking issue. Only changes in files/id3lib-3.8.3-zlib.... (diff)
downloadgentoo-2-1a74104b32ec38a103a42a6df2d6aba73d6033bc.tar.gz
gentoo-2-1a74104b32ec38a103a42a6df2d6aba73d6033bc.tar.bz2
gentoo-2-1a74104b32ec38a103a42a6df2d6aba73d6033bc.zip
Add gcc43 patch from Peter `MathFox' Roozemaal via bug #63773
Diffstat (limited to 'games-puzzle/pingus')
-rw-r--r--games-puzzle/pingus/ChangeLog6
-rw-r--r--games-puzzle/pingus/files/0.6.0-gcc34.patch11
-rw-r--r--games-puzzle/pingus/pingus-0.6.0-r1.ebuild9
3 files changed, 21 insertions, 5 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index 65bbb8955a4b..8d6c9c735a10 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/pingus
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.4 2004/06/24 23:08:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.5 2004/09/13 02:23:56 mr_bones_ Exp $
+
+ 12 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.6.0-gcc34.patch, pingus-0.6.0-r1.ebuild:
+ Add gcc43 patch from Peter `MathFox' Roozemaal via bug #63773
09 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.6.0-r1.ebuild,
files/0.6.0-gcc3.patch:
diff --git a/games-puzzle/pingus/files/0.6.0-gcc34.patch b/games-puzzle/pingus/files/0.6.0-gcc34.patch
new file mode 100644
index 000000000000..b0f52ed4084d
--- /dev/null
+++ b/games-puzzle/pingus/files/0.6.0-gcc34.patch
@@ -0,0 +1,11 @@
+--- src/story_screen.cxx.orig 2004-09-12 17:09:51.000000000 -0700
++++ src/story_screen.cxx 2004-09-12 17:10:43.000000000 -0700
+@@ -142,7 +142,7 @@
+
+ if (!page_displayed_completly)
+ {
+- unsigned int len = static_cast<unsigned int>(20.0f * time_passed);
++ size_t len = static_cast<size_t>(20.0f * time_passed);
+ display_text = current_page.text.substr(0, Math::min(current_page.text.length(), len));
+
+ if (current_page.text.length() < len)
diff --git a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
index 3f14500bc311..29e2dbc66b06 100644
--- a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
+++ b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.7 2004/08/15 08:53:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.8 2004/09/13 02:23:56 mr_bones_ Exp $
-inherit games eutils flag-o-matic
+inherit eutils flag-o-matic games
DESCRIPTION="free Lemmings clone"
HOMEPAGE="http://pingus.seul.org/"
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch "${FILESDIR}/${PV}-gcc3.patch"
+ epatch "${FILESDIR}/${PV}-gcc34.patch" # bug 63773
autoconf || die
}
@@ -39,8 +40,8 @@ src_compile() {
src_install() {
make install DESTDIR=${D} || die "make install failed"
# pos install process ... FIXME
- mv ${D}/usr/games/{games,bin}
- cd ${D}/usr/share/games
+ mv "${D}/usr/games/"{games,bin}
+ cd "${D}/usr/share/games"
use nls && mv locale ../
mv games/pingus .
rm -rf games