summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-13 04:04:16 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-13 04:04:16 +0000
commitf9b84b860cfcd8f18df99d0f95d7b2c033bc576a (patch)
tree29466642fbe7350c463d36bae4c0a49630cd1a97 /games-misc
parentfake out a usr symlink so that --with-sysroot works with gcc (diff)
downloadgentoo-2-f9b84b860cfcd8f18df99d0f95d7b2c033bc576a.tar.gz
gentoo-2-f9b84b860cfcd8f18df99d0f95d7b2c033bc576a.tar.bz2
gentoo-2-f9b84b860cfcd8f18df99d0f95d7b2c033bc576a.zip
Add a gcc4 fix by Jason Bucata #102311.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/bsd-games/ChangeLog8
-rw-r--r--games-misc/bsd-games/bsd-games-2.13-r1.ebuild7
-rw-r--r--games-misc/bsd-games/files/bsd-games-2.13-gcc4.patch39
3 files changed, 49 insertions, 5 deletions
diff --git a/games-misc/bsd-games/ChangeLog b/games-misc/bsd-games/ChangeLog
index 9bf3b4b65041..731de7741297 100644
--- a/games-misc/bsd-games/ChangeLog
+++ b/games-misc/bsd-games/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/bsd-games
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/bsd-games/ChangeLog,v 1.11 2005/06/15 18:41:42 wolf31o2 Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/bsd-games/ChangeLog,v 1.12 2005/08/13 04:04:16 vapier Exp $
+
+ 13 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/bsd-games-2.13-gcc4.patch, bsd-games-2.13-r1.ebuild:
+ Add a gcc4 fix by Jason Bucata #102311.
15 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org>
bsd-games-2.13-r1.ebuild:
diff --git a/games-misc/bsd-games/bsd-games-2.13-r1.ebuild b/games-misc/bsd-games/bsd-games-2.13-r1.ebuild
index bcd4c654889c..ee7c307860e4 100644
--- a/games-misc/bsd-games/bsd-games-2.13-r1.ebuild
+++ b/games-misc/bsd-games/bsd-games-2.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/bsd-games/bsd-games-2.13-r1.ebuild,v 1.3 2005/06/15 18:41:42 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/bsd-games/bsd-games-2.13-r1.ebuild,v 1.4 2005/08/13 04:04:16 vapier Exp $
inherit eutils games
@@ -30,17 +30,18 @@ worms wtf wump"}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
epatch "${FILESDIR}"/${PV}-debian-11.patch
epatch "${FILESDIR}"/${PV}-gentoo.patch
epatch "${FILESDIR}"/${PV}-64bit.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
sed -i \
-e "s:/usr/games:${GAMES_BINDIR}:" \
wargames/wargames \
|| die "sed wargames failed"
- cp ${FILESDIR}/config.params-gentoo config.params
+ cp "${FILESDIR}"/config.params-gentoo config.params
echo bsd_games_cfg_build_dirs=\"${GAMES_TO_BUILD}\" >> ./config.params
}
diff --git a/games-misc/bsd-games/files/bsd-games-2.13-gcc4.patch b/games-misc/bsd-games/files/bsd-games-2.13-gcc4.patch
new file mode 100644
index 000000000000..f3a762abb758
--- /dev/null
+++ b/games-misc/bsd-games/files/bsd-games-2.13-gcc4.patch
@@ -0,0 +1,39 @@
+Patch by Jason Bucata to fix gcc4 issues.
+
+http://bugs.gentoo.org/102311
+
+--- trek/getpar.h
++++ trek/getpar.h
+@@ -35,6 +35,9 @@
+ * @(#)getpar.h 8.1 (Berkeley) 5/31/93
+ */
+
++#ifndef __GETPAR_H_
++#define __GETPAR_H_
++
+ typedef void (*cmdfun) __P((int));
+ struct cvntab /* used for getcodpar() paramater list */
+ {
+@@ -52,3 +55,6 @@
+ int testnl __P((void));
+ void skiptonl __P((int));
+ int readdelim __P((int));
++
++#endif /*__GETPAR_H_*/
++
+--- trek/trek.h
++++ trek/trek.h
+@@ -35,6 +35,13 @@
+ * @(#)trek.h 8.1 (Berkeley) 5/31/93
+ */
+
++/* For struct cvntab definition, which is now required for
++ * Skitab and Lentab below. gcc 4.0 and later will emit
++ * "array type has incomplete element type" errors otherwise.
++ * -- Jason Bucata (jbucata@tulsaconnect.com), 12-AUG-2005
++ */
++#include "getpar.h"
++
+ /*
+ ** Global Declarations
+ **