summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-29 05:08:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-29 05:08:17 +0000
commitc425f27d84fcfd1bc42edf87a83e86a64029022d (patch)
tree3a6e2329222e0b03be504b940a1b9ea924bce987 /games-misc/sdljoytest
parentVersion bump (diff)
downloadgentoo-2-c425f27d84fcfd1bc42edf87a83e86a64029022d.tar.gz
gentoo-2-c425f27d84fcfd1bc42edf87a83e86a64029022d.tar.bz2
gentoo-2-c425f27d84fcfd1bc42edf87a83e86a64029022d.zip
add opengl use dep; fix SDL header include
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-misc/sdljoytest')
-rw-r--r--games-misc/sdljoytest/ChangeLog6
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild5
2 files changed, 8 insertions, 3 deletions
diff --git a/games-misc/sdljoytest/ChangeLog b/games-misc/sdljoytest/ChangeLog
index c303cdb1d4dd..5e3e476970a3 100644
--- a/games-misc/sdljoytest/ChangeLog
+++ b/games-misc/sdljoytest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/sdljoytest
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/ChangeLog,v 1.4 2010/06/03 16:10:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/ChangeLog,v 1.5 2010/11/29 05:08:17 mr_bones_ Exp $
+
+ 29 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ sdljoytest-11102003.ebuild:
+ add opengl use dep; fix SDL header include
03 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
sdljoytest-11102003.ebuild:
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
index 7bdb399c4109..e420518d85c0 100644
--- a/games-misc/sdljoytest/sdljoytest-11102003.ebuild
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/sdljoytest-11102003.ebuild,v 1.3 2010/06/03 16:10:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/sdljoytest/sdljoytest-11102003.ebuild,v 1.4 2010/11/29 05:08:17 mr_bones_ Exp $
EAPI=2
inherit toolchain-funcs
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="media-libs/libsdl[joystick,video]
+DEPEND="media-libs/libsdl[joystick,opengl,video]
virtual/opengl
media-libs/sdl-image"
@@ -25,6 +25,7 @@ src_prepare() {
sed -i \
-e 's:/usr/local:/usr:' \
joytest.h || die "seding data path"
+ sed -i -e 's:SDL/::' *.c || die
}
src_compile() {