summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-22 01:33:35 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-22 01:33:35 +0000
commit53ced1a7e368be9a010a0c453a9f39204168888a (patch)
tree9f98c1f0c8a362d366e5739224ec69ae64a6db55 /games-kids
parentVersion bump (diff)
downloadgentoo-2-53ced1a7e368be9a010a0c453a9f39204168888a.tar.gz
gentoo-2-53ced1a7e368be9a010a0c453a9f39204168888a.tar.bz2
gentoo-2-53ced1a7e368be9a010a0c453a9f39204168888a.zip
Version bump
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/tuxmathscrabble/ChangeLog9
-rw-r--r--games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.03
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-4.0.ebuild49
3 files changed, 59 insertions, 2 deletions
diff --git a/games-kids/tuxmathscrabble/ChangeLog b/games-kids/tuxmathscrabble/ChangeLog
index 1af02635b6ad..a0b70a35e15f 100644
--- a/games-kids/tuxmathscrabble/ChangeLog
+++ b/games-kids/tuxmathscrabble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/tuxmathscrabble
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.9 2006/11/01 12:02:48 tupone Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.10 2007/07/22 01:33:35 nyhm Exp $
+
+*tuxmathscrabble-4.0 (22 Jul 2007)
+
+ 22 Jul 2007; Tristan Heaven <nyhm@gentoo.org> +tuxmathscrabble-4.0.ebuild:
+ Version bump
*tuxmathscrabble-3.0.4 (01 Nov 2006)
diff --git a/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.0 b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.0
new file mode 100644
index 000000000000..c34905987bdf
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-4.0
@@ -0,0 +1,3 @@
+MD5 d5673313d044e1df3d598cd52ddbedb7 TuxMathScrabble-4.0LIN.tgz 2334407
+RMD160 ace455853748141e246e536fc44ac5a20938e05e TuxMathScrabble-4.0LIN.tgz 2334407
+SHA256 1989d36841c82640919d4349fed82a75e280456b92b52d8001a5b4dad044181e TuxMathScrabble-4.0LIN.tgz 2334407
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-4.0.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-4.0.ebuild
new file mode 100644
index 000000000000..a7e6161e5145
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-4.0.ebuild,v 1.1 2007/07/22 01:33:35 nyhm Exp $
+
+inherit eutils python multilib games
+
+MY_PN="TuxMathScrabble"
+MY_P=${MY_PN}-${PV}LIN
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="mirror://sourceforge/tuxmathscrabble/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame
+ dev-python/wxpython"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f $(find . -name '*.pyc')
+ mv -f ${MY_PN}/accounts .
+ sed -i "s:'/','var','games':'${GAMES_STATEDIR}':" EduApp/environment.py \
+ || die "sed failed"
+}
+
+src_install() {
+ newgamesbin ${MY_PN}.py ${PN} || die "newgamesbin failed"
+
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins -r ${MY_PN} || die "doins ${MY_PN} failed"
+ doins -r EduApp || die "doins EduApp failed"
+
+ insinto "${GAMES_STATEDIR}"/${MY_PN}
+ doins -r accounts || die "doins accounts failed"
+
+ newicon tms.ico ${PN}.ico
+ make_desktop_entry ${PN} ${MY_PN} /usr/share/pixmaps/${PN}.ico
+
+ dodoc CHANGES README
+ prepgamesdirs
+ fperms -R g+w "${GAMES_STATEDIR}"/${MY_PN}
+}