summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-04 15:30:12 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-04 15:30:12 +0000
commitd210691db7956f79bf8a50b034823f8bde8dff1e (patch)
tree02c160bbba69691fd60429513824edd79d919c07 /games-fps
parentUse mirrors to host foomatic-db-hpijs tarball. This should fix bug 114033 (diff)
downloadgentoo-2-d210691db7956f79bf8a50b034823f8bde8dff1e.tar.gz
gentoo-2-d210691db7956f79bf8a50b034823f8bde8dff1e.tar.bz2
gentoo-2-d210691db7956f79bf8a50b034823f8bde8dff1e.zip
Version bumped to 3369 and closing buf #114321.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2004/ChangeLog7
-rw-r--r--games-fps/ut2004/files/digest-ut2004-33691
-rw-r--r--games-fps/ut2004/ut2004-3369.ebuild107
3 files changed, 114 insertions, 1 deletions
diff --git a/games-fps/ut2004/ChangeLog b/games-fps/ut2004/ChangeLog
index 0554e07d90f9..8064a4791b44 100644
--- a/games-fps/ut2004/ChangeLog
+++ b/games-fps/ut2004/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/ut2004
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.32 2005/10/21 17:56:03 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.33 2005/12/04 15:30:12 wolf31o2 Exp $
+
+*ut2004-3369 (04 Dec 2005)
+
+ 04 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org> +ut2004-3369.ebuild:
+ Version bumped to 3369 and closing buf #114321.
21 Oct 2005; Chris Gianelloni <wolf31o2@gentoo.org> ut2004-3355-r1.ebuild:
Added addition dir variable to games_make_wrapper for bug #109793.
diff --git a/games-fps/ut2004/files/digest-ut2004-3369 b/games-fps/ut2004/files/digest-ut2004-3369
new file mode 100644
index 000000000000..25b16ab5bef6
--- /dev/null
+++ b/games-fps/ut2004/files/digest-ut2004-3369
@@ -0,0 +1 @@
+MD5 be47e16b628a75097a8c82b8513b56d1 ut2004-lnxpatch3369.tar.bz2 22301478
diff --git a/games-fps/ut2004/ut2004-3369.ebuild b/games-fps/ut2004/ut2004-3369.ebuild
new file mode 100644
index 000000000000..f235367c55f3
--- /dev/null
+++ b/games-fps/ut2004/ut2004-3369.ebuild
@@ -0,0 +1,107 @@
+inherit eutils games
+
+MY_P="${PN}-lnxpatch${PV}.tar.bz2"
+DESCRIPTION="Unreal Tournament 2004 - Editor's Choice Edition"
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="mirror://3dgamers/unrealtourn2k4/${MY_P}
+ http://speculum.twistedgamer.com/pub/0day.icculus.org/${PN}/${MY_P}"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="nostrip nomirror"
+IUSE="opengl dedicated"
+
+RDEPEND="games-fps/ut2004-data
+ games-fps/ut2004-bonuspack-ece
+ opengl? ( virtual/opengl )
+ dedicated? ( app-misc/screen )
+ amd64? ( sys-libs/libstdc++-v3 )"
+
+S=${WORKDIR}/UT2004-Patch
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_license ut2003
+ games_pkg_setup
+}
+
+src_install() {
+ # Installing patch files
+ for p in {Animations,Help,Speech,System,Textures,Web}
+ do
+ dodir ${dir}/${p}
+ cp -r ${S}/${p}/* ${Ddir}/${p} \
+ || die "copying ${p} from patch"
+ done
+
+ use amd64 && rm ${Ddir}/System/u{cc,t2004}-bin \
+ && mv ${Ddir}/System/ucc-bin-linux-amd64 ${Ddir}/System/ucc-bin \
+ && mv ${Ddir}/System/ut2004-bin-linux-amd64 ${Ddir}/System/ut2004-bin \
+ && chmod ug+x ${Ddir}/System/ucc-bin ${Ddir}/System/ut2004-bin
+ use x86 && rm ${Ddir}/System/ucc-bin-linux-amd64 \
+ ${Ddir}/System/ut2004-bin-linux-amd64
+
+ # creating .manifest files
+ insinto ${dir}/.manifest
+ doins ${FILESDIR}/${PN}.xml
+
+ # creating .loki/installed links
+ mkdir -p ${D}/root/.loki/installed
+ dosym ${dir}/.manifest/${PN}.xml ${ROOT}/root/.loki/installed/${PN}.xml
+
+ games_make_wrapper ut2004 ./ut2004 "${dir}" "${dir}"
+
+ prepgamesdirs
+ make_desktop_entry ut2004 "Unreal Tournament 2004" ut2004.xpm
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ # here is where we check for the existence of a cdkey...
+ # if we don't find one, we ask the user for it
+ if [ -f ${dir}/System/cdkey ]; then
+ einfo "A cdkey file is already present in ${dir}/System"
+ else
+ ewarn "You MUST run this before playing the game:"
+ ewarn "emerge --config =${CATEGORY}/${PF}"
+ ewarn "That way you can [re]enter your cdkey."
+ fi
+ echo
+ einfo "To play the game run:"
+ einfo " ut2004"
+ echo
+}
+
+pkg_postrm() {
+ ewarn "This package leaves a cdkey file in ${dir}/System that you need"
+ ewarn "to remove to completely get rid of this game's files."
+}
+
+pkg_config() {
+ ewarn "Your CD key is NOT checked for validity here."
+ ewarn " Make sure you type it in correctly."
+ eerror "If you CTRL+C out of this, the game will not run!"
+ echo
+ einfo "CD key format is: XXXXX-XXXXX-XXXXX-XXXXX"
+ while true ; do
+ einfo "Please enter your CD key:"
+ read CDKEY1
+ einfo "Please re-enter your CD key:"
+ read CDKEY2
+ if [ "$CDKEY1" == "" ] ; then
+ echo "You entered a blank CD key. Try again."
+ else
+ if [ "$CDKEY1" == "$CDKEY2" ] ; then
+ echo "$CDKEY1" | tr a-z A-Z > ${dir}/System/cdkey
+ einfo "Thank you!"
+ break
+ else
+ eerror "Your CD key entries do not match. Try again."
+ fi
+ fi
+ done
+}