summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-21 19:27:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-21 19:27:47 +0000
commit9d292d52f2739e65d9f7e74a619e427f84ee861e (patch)
tree480ac3b04ac97545ed9fb6d775452b61fc894ecb /games-fps
parentSet PKG_CONFIG_{LIBDIR,PATH} for multilib builds. Approved by vapier in bug #... (diff)
downloadgentoo-2-9d292d52f2739e65d9f7e74a619e427f84ee861e.tar.gz
gentoo-2-9d292d52f2739e65d9f7e74a619e427f84ee861e.tar.bz2
gentoo-2-9d292d52f2739e65d9f7e74a619e427f84ee861e.zip
old
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/urbanterror/ChangeLog9
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.008-build.patch70
-rw-r--r--games-fps/urbanterror/urbanterror-4.2.008.ebuild124
3 files changed, 6 insertions, 197 deletions
diff --git a/games-fps/urbanterror/ChangeLog b/games-fps/urbanterror/ChangeLog
index 0491438ac3c1..aa98c5428596 100644
--- a/games-fps/urbanterror/ChangeLog
+++ b/games-fps/urbanterror/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/urbanterror
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.17 2012/12/23 16:13:44 hasufell Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.18 2013/01/21 19:27:46 mr_bones_ Exp $
+
+ 21 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/urbanterror-4.2.008-build.patch, -urbanterror-4.2.008.ebuild:
+ old
*urbanterror-4.2.009 (23 Dec 2012)
@@ -87,4 +91,3 @@
+files/urbanterror-4.1.1-build.patch, +files/urbanterror-4.1.1-minizip.patch,
+metadata.xml:
initial import wrt #203296 thanks to Mr_Bones_
-
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.008-build.patch b/games-fps/urbanterror/files/urbanterror-4.2.008-build.patch
deleted file mode 100644
index 9221b671cbed..000000000000
--- a/games-fps/urbanterror/files/urbanterror-4.2.008-build.patch
+++ /dev/null
@@ -1,70 +0,0 @@
---- Makefile
-+++ Makefile
-@@ -213,7 +213,7 @@
- endif
- endif
-
-- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes -pipe
-+ BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes
-
- ifeq ($(USE_OPENAL),1)
- BASE_CFLAGS += -DUSE_OPENAL=1
-@@ -239,19 +239,15 @@
- BASE_CFLAGS += -I/usr/X11R6/include
- endif
-
-- OPTIMIZE = -O3 -ffast-math -funroll-loops -fomit-frame-pointer
-+ OPTIMIZE = -ffast-math -funroll-loops
-
- ifeq ($(ARCH),x86_64)
-- OPTIMIZE = -O3 -fomit-frame-pointer -ffast-math -funroll-loops \
-- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
-- -fstrength-reduce
-+ OPTIMIZE = -ffast-math -funroll-loops
- # experimental x86_64 jit compiler! you need GNU as
- HAVE_VM_COMPILED = true
- else
- ifeq ($(ARCH),i386)
-- OPTIMIZE = -O3 -march=i586 -fomit-frame-pointer -ffast-math \
-- -funroll-loops -falign-loops=2 -falign-jumps=2 \
-- -falign-functions=2 -fstrength-reduce
-+ OPTIMIZE = -ffast-math -funroll-loops
- HAVE_VM_COMPILED=true
- else
- ifeq ($(ARCH),ppc)
-@@ -265,7 +261,7 @@
- BASE_CFLAGS += -DNO_VM_COMPILED
- endif
-
-- DEBUG_CFLAGS = $(BASE_CFLAGS) -g -O0
-+ DEBUG_CFLAGS = $(BASE_CFLAGS) $(OPTIMIZE)
-
- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG $(OPTIMIZE)
-
-@@ -274,7 +270,7 @@
- SHLIBLDFLAGS=-shared $(LDFLAGS)
-
- THREAD_LDFLAGS=-lpthread
-- LDFLAGS=-ldl -lm
-+ LDFLAGS+=-ldl -lm
-
- ifeq ($(USE_SDL),1)
- CLIENT_LDFLAGS=$(shell sdl-config --libs)
-@@ -1153,13 +1149,13 @@
-
- $(B)/Quake3-UrT.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
- $(echo_cmd) "LD $@"
-- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) $(CLIENT_LDFLAGS) \
-- $(LDFLAGS) $(LIBSDLMAIN)
-+ $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) \
-+ $(LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
-
- $(B)/Quake3-UrT-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
- $(echo_cmd) "LD $@"
-- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
-- $(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
-+ $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) \
-+ $(LDFLAGS) $(THREAD_LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
-
- ifneq ($(strip $(LIBSDLMAIN)),)
- ifneq ($(strip $(LIBSDLMAINSRC)),)
diff --git a/games-fps/urbanterror/urbanterror-4.2.008.ebuild b/games-fps/urbanterror/urbanterror-4.2.008.ebuild
deleted file mode 100644
index b4d1ab90e9bb..000000000000
--- a/games-fps/urbanterror/urbanterror-4.2.008.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/urbanterror-4.2.008.ebuild,v 1.2 2012/12/05 20:41:41 hasufell Exp $
-
-EAPI=5
-
-inherit check-reqs eutils gnome2-utils games
-
-DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
-HOMEPAGE="http://www.urbanterror.info/home/"
-SRC_URI="http://download.urbanterror.info/urt/42/zips/UrbanTerror42_full_${PV:4:3}.zip
- https://github.com/Barbatos/ioq3-for-UrbanTerror-4/archive/release-4.2.007.tar.gz
- http://upload.wikimedia.org/wikipedia/en/5/56/Urbanterror.svg -> ${PN}.svg"
-
-LICENSE="GPL-2 Q3AEULA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+curl debug dedicated openal +sdl server smp vorbis"
-RESTRICT="mirror"
-
-RDEPEND="
- !dedicated? (
- virtual/opengl
- curl? ( net-misc/curl )
- openal? ( media-libs/openal )
- sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video] )
- !sdl? ( x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm )
- vorbis? ( media-libs/libogg
- media-libs/libvorbis )
- )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dedicated? ( curl? ( net-misc/curl ) )"
-
-S=${WORKDIR}/ioq3-for-UrbanTerror-4-release-4.2.007
-S_DATA=${WORKDIR}/UrbanTerror42
-
-CHECKREQS_DISK_BUILD="2700M"
-CHECKREQS_DISK_USR="1300M"
-
-pkg_pretend() {
- check-reqs_pkg_pretend
-
- if ! use dedicated ; then
- if ! use sdl && ! use openal ; then
- ewarn
- ewarn "Sound support disabled. Enable 'sdl' or 'openal' useflag."
- ewarn
- fi
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
-}
-
-src_compile() {
- buildit() { use $1 && echo 1 || echo 0 ; }
- nobuildit() { use $1 && echo 0 || echo 1 ; }
-
- emake \
- ARCH=$(usex amd64 "x86_64" "i386") \
- DEFAULT_BASEDIR="${GAMES_DATADIR}/${PN}" \
- BUILD_CLIENT=$(nobuildit dedicated) \
- BUILD_CLIENT_SMP=$(usex smp "$(nobuildit dedicated)" "0") \
- BUILD_SERVER=$(usex dedicated "1" "$(buildit server)") \
- USE_SDL=$(buildit sdl) \
- USE_OPENAL=$(buildit openal) \
- USE_OPENAL_DLOPEN=0 \
- USE_CURL=$(buildit curl) \
- USE_CURL_DLOPEN=0 \
- USE_CODEC_VORBIS=$(buildit vorbis) \
- USE_LOCAL_HEADERS=0 \
- Q="" \
- $(usex debug "debug" "release")
-}
-
-src_install() {
- local my_arch=$(usex amd64 "x86_64" "i386")
-
- doicon -s scalable "${DISTDIR}"/${PN}.svg
- dodoc ChangeLog README md4-readme.txt
- dodoc "${S_DATA}"/q3ut4/readme42.txt
- insinto "${GAMES_DATADIR}"/${PN}/q3ut4
- doins "${S_DATA}"/q3ut4/*.pk3
-
- if use !dedicated ; then
- newgamesbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT$(usex smp "-smp" "").${my_arch} ${PN}
- make_desktop_entry ${PN} "UrbanTerror"
- fi
-
- if use dedicated || use server ; then
- newgamesbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT-Ded.${my_arch} ${PN}-dedicated
- docinto examples
- dodoc "${S_DATA}"/q3ut4/{server.cfg,mapcycle.txt}
- fi
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-
- if use openal && ! use dedicated ; then
- einfo
- elog "You might need to set:"
- elog " seta s_useopenal \"1\""
- elog "in your ~/.q3a/q3ut4/q3config.cfg for openal to work."
- einfo
- fi
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}