summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-09 18:07:58 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-09 18:07:58 +0000
commit9caa040a50484f9c9f91333f6acfca485ce6fa22 (patch)
tree25d6af1a02660816386b6832311b5ecd938749d7 /games-fps/quake3
parentStable on amd64 wrt bug 173819 (diff)
downloadgentoo-2-9caa040a50484f9c9f91333f6acfca485ce6fa22.tar.gz
gentoo-2-9caa040a50484f9c9f91333f6acfca485ce6fa22.tar.bz2
gentoo-2-9caa040a50484f9c9f91333f6acfca485ce6fa22.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/quake3-1.34_rc3.ebuild8
-rw-r--r--games-fps/quake3/quake3-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/games-fps/quake3/quake3-1.34_rc3.ebuild b/games-fps/quake3/quake3-1.34_rc3.ebuild
index 8694a5780aa3..d231d3b9a7ca 100644
--- a/games-fps/quake3/quake3-1.34_rc3.ebuild
+++ b/games-fps/quake3/quake3-1.34_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_rc3.ebuild,v 1.5 2007/01/31 07:59:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_rc3.ebuild,v 1.6 2007/04/09 18:07:58 nyhm Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -71,7 +71,7 @@ src_compile() {
ARCH=$(tc-arch-kernel) \
OPTIMIZE="${CFLAGS}" \
DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
- DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ DEFAULT_LIBDIR="$(games_get_libdir)/quake3" \
|| die
}
@@ -92,9 +92,9 @@ src_install() {
newgamesbin ${old_x} ${x} || die "newgamesbin ${x}"
dosym ${x} "${GAMES_BINDIR}"/${x/io}
done
- exeinto "${GAMES_LIBDIR}"/${PN}/baseq3
+ exeinto "$(games_get_libdir)"/${PN}/baseq3
doexe baseq3/*.so || die "baseq3 .so"
- exeinto "${GAMES_LIBDIR}"/${PN}/missionpack
+ exeinto "$(games_get_libdir)"/${PN}/missionpack
doexe missionpack/*.so || die "missionpack .so"
prepgamesdirs
diff --git a/games-fps/quake3/quake3-9999.ebuild b/games-fps/quake3/quake3-9999.ebuild
index 67f6f5e56841..82e7351580ba 100644
--- a/games-fps/quake3/quake3-9999.ebuild
+++ b/games-fps/quake3/quake3-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.11 2007/01/31 08:04:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.12 2007/04/09 18:07:58 nyhm Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -71,7 +71,7 @@ src_compile() {
ARCH=$(tc-arch-kernel) \
OPTIMIZE="${CFLAGS}" \
DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
- DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ DEFAULT_LIBDIR="$(games_get_libdir)/quake3" \
|| die
}
@@ -92,9 +92,9 @@ src_install() {
newgamesbin ${old_x} ${x} || die "newgamesbin ${x}"
dosym ${x} "${GAMES_BINDIR}"/${x/io}
done
- exeinto "${GAMES_LIBDIR}"/${PN}/baseq3
+ exeinto "$(games_get_libdir)"/${PN}/baseq3
doexe baseq3/*.so || die "baseq3 .so"
- exeinto "${GAMES_LIBDIR}"/${PN}/missionpack
+ exeinto "$(games_get_libdir)"/${PN}/missionpack
doexe missionpack/*.so || die "missionpack .so"
prepgamesdirs