summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-30 06:14:20 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-30 06:14:20 +0000
commite61b7ac5e37d5c2b3eb173a0f179ebad87ae21cc (patch)
tree04a48763748a93f53573040148ff737e20204120 /games-fps/quake2-icculus
parentinitial commit (diff)
downloadgentoo-2-e61b7ac5e37d5c2b3eb173a0f179ebad87ae21cc.tar.gz
gentoo-2-e61b7ac5e37d5c2b3eb173a0f179ebad87ae21cc.tar.bz2
gentoo-2-e61b7ac5e37d5c2b3eb173a0f179ebad87ae21cc.zip
On amd64, select the glx video renderer by default until the software renderers work #86552.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'games-fps/quake2-icculus')
-rw-r--r--games-fps/quake2-icculus/ChangeLog9
-rw-r--r--games-fps/quake2-icculus/files/quake2-icculus-0.16.1-amd64.patch18
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild4
3 files changed, 28 insertions, 3 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index d3e2168d9e8c..2bfde4df2d15 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/quake2-icculus
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.12 2005/03/11 01:47:50 vapier Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.13 2005/04/30 06:14:20 vapier Exp $
+
+ 30 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/quake2-icculus-0.16.1-amd64.patch, quake2-icculus-0.16.1.ebuild:
+ On amd64, select the glx video renderer by default until the software
+ renderers work #86552.
*quake2-icculus-0.16.1 (10 Mar 2005)
diff --git a/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-amd64.patch b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-amd64.patch
new file mode 100644
index 000000000000..b3291827996c
--- /dev/null
+++ b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-amd64.patch
@@ -0,0 +1,18 @@
+The default video renderers (softx / soft) currently do not work
+on amd64. So for now we add a little hack which will select the
+glx renderer by default.
+
+http://bugs.gentoo.org/show_bug.cgi?id=86552
+
+--- src/linux/vid_so.c
++++ src/linux/vid_so.c
+@@ -435,6 +440,9 @@ VID_Init
+ */
+ void VID_Init (void)
+ {
++#if defined __x86_64__
++ vid_ref = Cvar_Get ("vid_ref", "glx", CVAR_ARCHIVE);
++#endif
+ /* Create the video variables so we know how to start the graphics drivers */
+ // if DISPLAY is defined, try X
+ if (getenv("DISPLAY"))
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild
index 80efbf21006c..28512af55112 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.3 2005/04/29 02:32:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.4 2005/04/30 06:14:20 vapier Exp $
inherit eutils games
@@ -34,6 +34,8 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${MY_P}.tar.gz
cd "${S}"
+ sed -i -e 's:BUILD_SOFTX:BUILD_X11:' Makefile
+ epatch "${FILESDIR}"/${P}-amd64.patch # make sure this is still needed in future versions
epatch "${FILESDIR}"/0.16-Makefile-gentoo-opts.patch
epatch "${FILESDIR}"/0.16-gentoo-path.patch
cat << EOF > src/linux/gentoo-paths.h