summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-27 17:46:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-27 17:46:00 +0000
commit870d3ade6c5c361639e7e1d7704a83b838e4964c (patch)
treeef9b566bf9a28734081cfec27f506f5190700ad6 /games-fps/legends
parentKeywording ncbi-tools-20060507 ~ppc64 for bug #138082 (diff)
downloadgentoo-2-870d3ade6c5c361639e7e1d7704a83b838e4964c.tar.gz
gentoo-2-870d3ade6c5c361639e7e1d7704a83b838e4964c.tar.bz2
gentoo-2-870d3ade6c5c361639e7e1d7704a83b838e4964c.zip
version bump
(Portage version: 2.1.1_pre1-r4)
Diffstat (limited to 'games-fps/legends')
-rw-r--r--games-fps/legends/ChangeLog8
-rw-r--r--games-fps/legends/files/digest-legends-0.4.1.406
-rw-r--r--games-fps/legends/legends-0.4.1.40.ebuild78
3 files changed, 91 insertions, 1 deletions
diff --git a/games-fps/legends/ChangeLog b/games-fps/legends/ChangeLog
index fac025a412c3..480e55f51f96 100644
--- a/games-fps/legends/ChangeLog
+++ b/games-fps/legends/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/legends
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/legends/ChangeLog,v 1.17 2006/05/11 16:29:03 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/legends/ChangeLog,v 1.18 2006/06/27 17:46:00 mr_bones_ Exp $
+
+*legends-0.4.1.40 (27 Jun 2006)
+
+ 27 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +legends-0.4.1.40.ebuild:
+ version bump
11 May 2006; Chris Gianelloni <wolf31o2@gentoo.org>
legends-0.4.1.39.ebuild:
diff --git a/games-fps/legends/files/digest-legends-0.4.1.40 b/games-fps/legends/files/digest-legends-0.4.1.40
new file mode 100644
index 000000000000..38b49e5ae050
--- /dev/null
+++ b/games-fps/legends/files/digest-legends-0.4.1.40
@@ -0,0 +1,6 @@
+MD5 c9f9604ff10219479dc33a4213dc30bd legends.png 5092
+RMD160 81aee5b6dbbca35011da2c665f8126fd01230d2a legends.png 5092
+SHA256 f4ac0db949c2f0a373f331a7a7528ef17c674a226c2366a5a443b5b5a44b6ce2 legends.png 5092
+MD5 46c0ef14be6251edbfa895de11f0cc80 legends_linux_0.4.1.40.sh 121687045
+RMD160 d4c4b3231e8e9587249908f6ce04300f799bb68c legends_linux_0.4.1.40.sh 121687045
+SHA256 858fb8b38b582c407d9975a86d910f4dab9dd8c6c8028aa3d52a46ca28af3d0a legends_linux_0.4.1.40.sh 121687045
diff --git a/games-fps/legends/legends-0.4.1.40.ebuild b/games-fps/legends/legends-0.4.1.40.ebuild
new file mode 100644
index 000000000000..fc714ea4b551
--- /dev/null
+++ b/games-fps/legends/legends-0.4.1.40.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/legends/legends-0.4.1.40.ebuild,v 1.1 2006/06/27 17:46:00 mr_bones_ Exp $
+
+inherit games
+
+MY_P=${PN}_linux_${PV}
+DESCRIPTION="A fast-paced first-person-perspective online multiplayer game similar to Tribes"
+HOMEPAGE="http://legendsthegame.net/"
+SRC_URI="http://www.legendsthegame.net/files/${MY_P}.sh
+ mirror://gentoo/${PN}.png
+ http://dev.gentoo.org/~wolf31o2/sources/dump/${PN}.png"
+
+KEYWORDS="-* ~amd64 x86"
+LICENSE="as-is"
+SLOT="0"
+IUSE="dedicated"
+RESTRICT="strip"
+QA_TEXTRELS="opt/legends/libSDL-1.3.so.0"
+
+DEPEND=""
+RDEPEND=">=media-libs/libsdl-1.2
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ amd64? ( >=app-emulation/emul-linux-x86-sdl-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1 )
+ || (
+ media-fonts/font-adobe-75dpi
+ virtual/x11 )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ local LIBSDL=libSDL-1.3.so.0
+ SKIP=$(awk '/^__ARCHIVE_FOLLOWS__/ { print NR + 1; exit 0; }' \
+ ${DISTDIR}/${MY_P}.sh)
+ tail -n +${SKIP} ${DISTDIR}/${MY_P}.sh | tar -C ${WORKDIR} -xjf - \
+ || die "unpacking"
+
+ cd "${S}"
+ # keep libSDL-1.3.so because legends requires it as of 0.4.0, and
+ # 1.2.6 is highest in portage
+ # rm libSDL-*.so*
+ rm runlegends libSDL-1.2.so.0 libopenal.so libogg.so.0 libvorbis.so.0 *.DLL
+ find . -type f -exec chmod a-x '{}' \;
+ chmod a+x lindedicated LinLegends
+ cp "${FILESDIR}"/legends{,-ded} "${T}" || die "cp failed"
+ sed -i \
+ -e "s:GENTOO_DIR:${GAMES_PREFIX_OPT}/${PN}:" \
+ -e "s:LIBSDL:${LIBSDL}:" \
+ "${T}"/legends{,-ded} \
+ || die "sed failed"
+}
+
+src_install() {
+ cd "${S}"
+ dogamesbin "${T}/legends" || die "dogamesbin failed (1)"
+ keepdir "${dir}/"{show/ui,show/scripts,legends/scripts,legends/data,common/server,common/edit,common/client}
+ cp -rPp * "${Ddir}/" || die "cp failed"
+ if use dedicated ; then
+ dogamesbin "${T}"/legends-ded || die "dogamesbin failed (2)"
+ fi
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry legends "Legends"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "Version ${PV} of ${PN} may give problems if there are"
+ einfo "config-files from earlier versions. Removing the ~/.legends dir"
+ einfo "and restarting will solve this."
+ echo
+}