summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-09-17 21:41:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-09-17 21:41:36 +0000
commit0f8d14e78d217f6095e176ecf717a912e89adb0a (patch)
tree1a5e1b287bc156e2194c5a95a0afeea4082e6eef /games-fps/legends/legends-0.4.1.43.ebuild
parentx86 stable, security bug #192197 (diff)
downloadgentoo-2-0f8d14e78d217f6095e176ecf717a912e89adb0a.tar.gz
gentoo-2-0f8d14e78d217f6095e176ecf717a912e89adb0a.tar.bz2
gentoo-2-0f8d14e78d217f6095e176ecf717a912e89adb0a.zip
version bump
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-fps/legends/legends-0.4.1.43.ebuild')
-rw-r--r--games-fps/legends/legends-0.4.1.43.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-fps/legends/legends-0.4.1.43.ebuild b/games-fps/legends/legends-0.4.1.43.ebuild
new file mode 100644
index 000000000000..d186aed6f1ff
--- /dev/null
+++ b/games-fps/legends/legends-0.4.1.43.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/legends/legends-0.4.1.43.ebuild,v 1.1 2007/09/17 21:41:36 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P=${PN}_linux-${PV}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+DESCRIPTION="Fast-paced first-person-shooter online multiplayer game, similar to Tribes"
+HOMEPAGE="http://legendsthegame.net/"
+SRC_URI="http://legendsthegame.net/files/${MY_P}.run
+ mirror://gentoo/${PN}.png
+ http://dev.gentoo.org/~wolf31o2/sources/dump/${PN}.png"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="dedicated"
+RESTRICT="strip"
+
+QA_TEXTRELS="${dir:1}/libSDL-1.3.so.0"
+
+DEPEND=""
+RDEPEND=">=media-libs/libsdl-1.2
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ amd64? ( >=app-emulation/emul-linux-x86-sdl-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1 )
+ media-fonts/font-adobe-75dpi"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself ${MY_P}.run
+ cd "${S}"
+
+ # keep libSDL-1.3.so because legends requires it as of 0.4.0, and
+ # 1.2.6 is highest in portage
+ # rm libSDL-*.so*
+ rm runlegends libSDL-1.2.so.0 libopenal.so libogg.so.0 libvorbis.so.0 *.DLL
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r * || die "doins * failed"
+
+ rm "${D}/${dir}/"/{lindedicated,LinLegends,*.so.0}
+ exeinto "${dir}"
+ doexe lindedicated LinLegends *.so.0 || die "doexe failed"
+
+ games_make_wrapper ${PN} "./LinLegends" "${dir}" "${dir}"
+ if use dedicated ; then
+ games_make_wrapper ${PN}-ded "./lindedicated" "${dir}" "${dir}"
+ fi
+
+ doicon "${DISTDIR}"/${PN}.png || die "doicon failed"
+ make_desktop_entry legends "Legends"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ ewarn "Version ${PV} of ${PN} may give problems if there are"
+ ewarn "config-files from earlier versions. Removing the ~/.legends dir"
+ ewarn "and restarting will solve this."
+ echo
+}