summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-09-07 18:38:49 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-09-07 18:38:49 +0000
commit46fcf10f2e4c51f7052b23f1afd3262c3048c6a9 (patch)
tree2c9c9d6f7018c26e14395ca89340b56c801933f2 /games-fps/avp/avp-20070130-r1.ebuild
parentcorrected license s/as-is/public-domain/ (diff)
downloadgentoo-2-46fcf10f2e4c51f7052b23f1afd3262c3048c6a9.tar.gz
gentoo-2-46fcf10f2e4c51f7052b23f1afd3262c3048c6a9.tar.bz2
gentoo-2-46fcf10f2e4c51f7052b23f1afd3262c3048c6a9.zip
Fixing gcc-4.2 compilation problem. Bug #184423
(Portage version: 2.1.2.12)
Diffstat (limited to 'games-fps/avp/avp-20070130-r1.ebuild')
-rw-r--r--games-fps/avp/avp-20070130-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-fps/avp/avp-20070130-r1.ebuild b/games-fps/avp/avp-20070130-r1.ebuild
new file mode 100644
index 000000000000..badec70c00c8
--- /dev/null
+++ b/games-fps/avp/avp-20070130-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/avp/avp-20070130-r1.ebuild,v 1.1 2007/09/07 18:38:49 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="Linux port of Aliens vs Predator"
+HOMEPAGE="http://www.icculus.org/avp/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="AvP"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/openal
+ media-libs/libsdl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc42.patch
+ sed -i \
+ -e "/^CFLAGS/s/-g.*/${CFLAGS}/" \
+ -e "/^LDLIBS/s/$/${LDFLAGS}/" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ newgamesbin AvP.bin AvP || die "newgamesbin failed"
+ dodoc README TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "please follow the instructions in"
+ elog "/usr/share/doc/${PF}/README.gz"
+ elog "to install the rest of the game"
+}