summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-05 20:09:32 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-05 20:09:32 +0000
commitedc34efd72046d07cd62a882d743b9476337e732 (patch)
tree7529344cdf71781276ea9e7d942e8ce1b95b96a9 /games-fps/aaquake2
parentfix installing info pages #132255 (diff)
downloadgentoo-2-edc34efd72046d07cd62a882d743b9476337e732.tar.gz
gentoo-2-edc34efd72046d07cd62a882d743b9476337e732.tar.bz2
gentoo-2-edc34efd72046d07cd62a882d743b9476337e732.zip
Fix for gcc-4.1
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'games-fps/aaquake2')
-rw-r--r--games-fps/aaquake2/ChangeLog6
-rw-r--r--games-fps/aaquake2/aaquake2-0.1.ebuild8
-rw-r--r--games-fps/aaquake2/files/0.1-gentoo.patch20
-rw-r--r--games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch39
-rw-r--r--games-fps/aaquake2/files/digest-aaquake2-0.14
5 files changed, 61 insertions, 16 deletions
diff --git a/games-fps/aaquake2/ChangeLog b/games-fps/aaquake2/ChangeLog
index 46dc70f68528..19553bdc1137 100644
--- a/games-fps/aaquake2/ChangeLog
+++ b/games-fps/aaquake2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/aaquake2
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/ChangeLog,v 1.5 2006/03/15 22:35:53 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/ChangeLog,v 1.6 2006/05/05 20:09:32 tupone Exp $
+
+ 05 May 2006; <Tupone@gentoo.org> +files/aaquake2-0.1-gcc41.patch,
+ files/0.1-gentoo.patch, aaquake2-0.1.ebuild:
+ Fix for gcc-4.1
15 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org> aaquake2-0.1.ebuild:
Changed to use idsoftware thirdpartymirror.
diff --git a/games-fps/aaquake2/aaquake2-0.1.ebuild b/games-fps/aaquake2/aaquake2-0.1.ebuild
index 8e1643b79a78..0d88758bea82 100644
--- a/games-fps/aaquake2/aaquake2-0.1.ebuild
+++ b/games-fps/aaquake2/aaquake2-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.8 2006/03/15 22:35:53 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.9 2006/05/05 20:09:32 tupone Exp $
inherit eutils games
@@ -22,8 +22,10 @@ S=${WORKDIR}/quake2-3.21/linux
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${PV}-gentoo.patch
- cd quake2-3.21/linux
+ cd "${WORKDIR}/quake2-3.21"
+ epatch "${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}/${P}"-gcc41.patch
+ cd linux
sed -i \
-e "s:GENTOO_DIR:${GAMES_LIBDIR}/${PN}:" sys_linux.c
sed -i \
diff --git a/games-fps/aaquake2/files/0.1-gentoo.patch b/games-fps/aaquake2/files/0.1-gentoo.patch
index 0c02710e89f6..30379cb2c2dc 100644
--- a/games-fps/aaquake2/files/0.1-gentoo.patch
+++ b/games-fps/aaquake2/files/0.1-gentoo.patch
@@ -1,6 +1,5 @@
-diff -ur orig/quake2-3.21/linux/Makefile work-mywork/quake2-3.21/linux/Makefile
---- orig/quake2-3.21/linux/Makefile 2001-12-29 20:37:22.000000000 -0500
-+++ work-mywork/quake2-3.21/linux/Makefile 2003-07-17 22:14:50.000000000 -0400
+--- linux/Makefile.old 2001-12-29 20:37:22.000000000 -0500
++++ linux/Makefile 2003-07-17 22:14:50.000000000 -0400
@@ -54,7 +54,7 @@
RELEASE_CFLAGS=$(BASE_CFLAGS) -O6 -ffast-math -funroll-loops \
-fomit-frame-pointer -fexpensive-optimizations
@@ -41,9 +40,8 @@ diff -ur orig/quake2-3.21/linux/Makefile work-mywork/quake2-3.21/linux/Makefile
$(BUILD_RELEASE_DIR)/game \
$(BUILD_RELEASE_DIR)/ctf \
# $(BUILD_RELEASE_DIR)/xatrix \
-diff -ur orig/quake2-3.21/linux/sys_linux.c work-mywork/quake2-3.21/linux/sys_linux.c
---- orig/quake2-3.21/linux/sys_linux.c 2001-12-22 18:45:58.000000000 -0500
-+++ work-mywork/quake2-3.21/linux/sys_linux.c 2003-07-17 22:34:11.000000000 -0400
+--- linux/sys_linux.c.old 2001-12-22 18:45:58.000000000 -0500
++++ linux/sys_linux.c 2003-07-17 22:34:11.000000000 -0400
@@ -220,7 +220,7 @@
char curpath[MAX_OSPATH];
char *path;
@@ -68,9 +66,8 @@ diff -ur orig/quake2-3.21/linux/sys_linux.c work-mywork/quake2-3.21/linux/sys_li
}
}
-diff -ur orig/quake2-3.21/qcommon/files.c work-mywork/quake2-3.21/qcommon/files.c
---- orig/quake2-3.21/qcommon/files.c 2001-12-22 16:32:26.000000000 -0500
-+++ work-mywork/quake2-3.21/qcommon/files.c 2003-07-17 22:34:29.000000000 -0400
+--- qcommon/files.c.old 2001-12-22 16:32:26.000000000 -0500
++++ qcommon/files.c 2003-07-17 22:34:29.000000000 -0400
@@ -865,7 +865,7 @@
//
// start up with baseq2 by default
@@ -80,9 +77,8 @@ diff -ur orig/quake2-3.21/qcommon/files.c work-mywork/quake2-3.21/qcommon/files.
// any set gamedirs will be freed up to here
fs_base_searchpaths = fs_searchpaths;
-diff -ur orig/quake2-3.21/qcommon/qcommon.h work-mywork/quake2-3.21/qcommon/qcommon.h
---- orig/quake2-3.21/qcommon/qcommon.h 2001-12-22 16:32:26.000000000 -0500
-+++ work-mywork/quake2-3.21/qcommon/qcommon.h 2003-07-17 21:20:03.000000000 -0400
+--- qcommon/qcommon.h.old 2001-12-22 16:32:26.000000000 -0500
++++ qcommon/qcommon.h 2003-07-17 21:20:03.000000000 -0400
@@ -25,7 +25,7 @@
#define VERSION 3.21
diff --git a/games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch b/games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch
new file mode 100644
index 000000000000..0871d2c17389
--- /dev/null
+++ b/games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch
@@ -0,0 +1,39 @@
+--- game/g_local.h.old 2006-05-05 21:26:25.000000000 +0200
++++ game/g_local.h 2006-05-05 21:26:48.000000000 +0200
+@@ -458,11 +458,6 @@
+ extern int sm_meat_index;
+ extern int snd_fry;
+
+-extern int jacket_armor_index;
+-extern int combat_armor_index;
+-extern int body_armor_index;
+-
+-
+ // means of death
+ #define MOD_UNKNOWN 0
+ #define MOD_BLASTER 1
+--- ctf/g_local.h.old 2006-05-05 21:41:10.000000000 +0200
++++ ctf/g_local.h 2006-05-05 21:41:23.000000000 +0200
+@@ -466,11 +466,6 @@
+ extern int sm_meat_index;
+ extern int snd_fry;
+
+-extern int jacket_armor_index;
+-extern int combat_armor_index;
+-extern int body_armor_index;
+-
+-
+ // means of death
+ #define MOD_UNKNOWN 0
+ #define MOD_BLASTER 1
+@@ -556,10 +556,6 @@
+
+ extern cvar_t *sv_maplist;
+
+-//ZOID
+-extern qboolean is_quad;
+-//ZOID
+-
+ #define world (&g_edicts[0])
+
+ // item spawnflags
diff --git a/games-fps/aaquake2/files/digest-aaquake2-0.1 b/games-fps/aaquake2/files/digest-aaquake2-0.1
index ce25dadff841..815fa5c90145 100644
--- a/games-fps/aaquake2/files/digest-aaquake2-0.1
+++ b/games-fps/aaquake2/files/digest-aaquake2-0.1
@@ -1,2 +1,6 @@
MD5 3ac9ac6a833b9c049a9f763c3137b86f q2source-3.21.zip 1477764
+RMD160 c23beea8062c94ef5d45f9acf3d884961b8d8564 q2source-3.21.zip 1477764
+SHA256 c9200316de189638d0d997a0092f36b85f2c3f9e4ebe30f4b1c356745ad676ca q2source-3.21.zip 1477764
MD5 2f9df6fca3b06d380f21f644105a30e7 quake2-ref_softaa-0.1.tar.gz 12931
+RMD160 79086b65413eabc5e7200abda6c968e6a425ff4c quake2-ref_softaa-0.1.tar.gz 12931
+SHA256 e848919804e65c99dc900b640e5d5c6f018d2181908a48bb1b0330efa90d3a6a quake2-ref_softaa-0.1.tar.gz 12931