summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-01 04:25:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-01 04:25:34 +0000
commitb2afd911f376dd913222bc112e2f28527bf67934 (patch)
treea2456608f10f825ef85d79aaa6294412a2c0aea0 /games-engines
parentStable on amd64. (Manifest recommit) (diff)
downloadgentoo-2-b2afd911f376dd913222bc112e2f28527bf67934.tar.gz
gentoo-2-b2afd911f376dd913222bc112e2f28527bf67934.tar.bz2
gentoo-2-b2afd911f376dd913222bc112e2f28527bf67934.zip
Add gcc-3.4 patch #49304 by Robert Führicht.
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog6
-rw-r--r--games-engines/scummvm/files/0.6.0-gcc34.patch53
-rw-r--r--games-engines/scummvm/scummvm-0.6.0.ebuild21
3 files changed, 71 insertions, 9 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 85a0c10f22de..f9a807257b6e 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/scummvm
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.7 2004/04/12 03:23:19 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.8 2004/06/01 04:25:34 vapier Exp $
+
+ 01 Jun 2004; Mike Frysinger <vapier@gentoo.org> +files/0.6.0-gcc34.patch,
+ scummvm-0.6.0.ebuild:
+ Add gcc-3.4 patch #49304 by Robert Führicht.
11 Apr 2004; Jason Wever <weeve@gentoo.org> scummvm-0.6.0.ebuild:
Added ~sparc keyword.
diff --git a/games-engines/scummvm/files/0.6.0-gcc34.patch b/games-engines/scummvm/files/0.6.0-gcc34.patch
new file mode 100644
index 000000000000..e0c07cf2ade3
--- /dev/null
+++ b/games-engines/scummvm/files/0.6.0-gcc34.patch
@@ -0,0 +1,53 @@
+diff -Naur scummvm-0.6.0.orig/base/main.cpp scummvm-0.6.0/base/main.cpp
+--- scummvm-0.6.0.orig/base/main.cpp 2004-04-28 19:48:07.199890232 +0200
++++ scummvm-0.6.0/base/main.cpp 2004-04-28 19:51:21.806305560 +0200
+@@ -262,7 +262,7 @@
+
+ // Free up memory
+ delete engine;
+-};
++}
+
+ #ifndef _WIN32_WCE
+ int main(int argc, char *argv[]) {
+diff -Naur scummvm-0.6.0.orig/scumm/actor.cpp scummvm-0.6.0/scumm/actor.cpp
+--- scummvm-0.6.0.orig/scumm/actor.cpp 2004-04-28 19:48:07.272879136 +0200
++++ scummvm-0.6.0/scumm/actor.cpp 2004-04-28 19:48:55.117605632 +0200
+@@ -789,14 +789,14 @@
+ return _V1_talkingActor;
+ else
+ return VAR(VAR_TALK_ACTOR);
+-};
++}
+
+ void ScummEngine::talkingActor(int value) {
+ if (_gameId == GID_MANIAC && _version == 1)
+ _V1_talkingActor = value;
+ else
+ VAR(VAR_TALK_ACTOR) = value;
+-};
++}
+
+ void ScummEngine::showActors() {
+ int i;
+diff -Naur scummvm-0.6.0.orig/scumm/debugger.cpp scummvm-0.6.0/scumm/debugger.cpp
+--- scummvm-0.6.0.orig/scumm/debugger.cpp 2004-04-28 19:48:07.256881568 +0200
++++ scummvm-0.6.0/scumm/debugger.cpp 2004-04-28 19:49:32.345946064 +0200
+@@ -57,7 +57,7 @@
+ va_end(va);
+
+ debug(buf);
+-};
++}
+
+ ScummDebugger::ScummDebugger(ScummEngine *s)
+ : Common::Debugger<ScummDebugger>() {
+@@ -592,7 +592,7 @@
+
+ DebugPrintf("Unknown flag. Type 'Debug ?' for syntax\n");
+ return true;
+-};
++}
+
+ bool ScummDebugger::Cmd_DebugLevel(int argc, const char **argv) {
+ if (argc == 1) {
diff --git a/games-engines/scummvm/scummvm-0.6.0.ebuild b/games-engines/scummvm/scummvm-0.6.0.ebuild
index eb3fa8e3b6d8..770d17784283 100644
--- a/games-engines/scummvm/scummvm-0.6.0.ebuild
+++ b/games-engines/scummvm/scummvm-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.6.0.ebuild,v 1.4 2004/05/10 02:29:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.6.0.ebuild,v 1.5 2004/06/01 04:25:34 vapier Exp $
inherit games
@@ -8,10 +8,9 @@ DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventu
HOMEPAGE="http://scummvm.sourceforge.net/"
SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
-use debug && RESTRICT="nostrip"
-KEYWORDS="x86 ppc ~amd64 ~sparc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc ~amd64 ~sparc"
IUSE="alsa debug mad oggvorbis sdl zlib"
DEPEND="virtual/glibc
@@ -26,6 +25,12 @@ DEPEND="virtual/glibc
mad? ( media-libs/libmad )
zlib? ( sys-libs/zlib )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc34.patch
+}
+
src_compile() {
local myconf=
@@ -35,21 +40,21 @@ src_compile() {
use debug \
|| myconf="${myconf} --disable-debug"
- # not an autoconf script.
+ # not an autoconf script so dont call econf
./configure \
`use_enable alsa` \
`use_enable mad` \
`use_enable oggvorbis vorbis` \
`use_enable zlib` \
${myconf} \
- || die "configure failed"
+ || die "configure failed"
emake || die "emake failed"
}
src_install() {
- dogamesbin scummvm || die "dobin failed"
- doman scummvm.6 || die "doman failed"
- dodoc NEWS README TODO || die "dodoc failed"
+ dogamesbin scummvm || die "dobin failed"
+ doman scummvm.6
+ dodoc NEWS README TODO
insinto /usr/share/pixmaps
doins scummvm.xpm || die "doins failed"
make_desktop_entry scummvm ScummVM