summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-05 19:14:10 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-05 19:14:10 +0000
commit657b97965fcb126b05c3b27a408ed733d11a50a1 (patch)
treef3102a8fbcdecd593762c39a56194d540bdba37e /games-engines
parentFix building with GCC 4.3 wrt #219875 by Martin Väth. (diff)
downloadgentoo-2-657b97965fcb126b05c3b27a408ed733d11a50a1.tar.gz
gentoo-2-657b97965fcb126b05c3b27a408ed733d11a50a1.tar.bz2
gentoo-2-657b97965fcb126b05c3b27a408ed733d11a50a1.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/qtads/ChangeLog6
-rw-r--r--games-engines/qtads/files/qtads-1.6c-gcc43.patch20
-rw-r--r--games-engines/qtads/qtads-1.6c.ebuild9
3 files changed, 30 insertions, 5 deletions
diff --git a/games-engines/qtads/ChangeLog b/games-engines/qtads/ChangeLog
index 8278766ff1a4..9a55b873834c 100644
--- a/games-engines/qtads/ChangeLog
+++ b/games-engines/qtads/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/qtads
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/ChangeLog,v 1.4 2008/01/02 07:21:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/ChangeLog,v 1.5 2008/05/05 19:14:09 nyhm Exp $
+
+ 05 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/qtads-1.6c-gcc43.patch, qtads-1.6c.ebuild:
+ Fix building with gcc-4.3
02 Jan 2008; Michael Sterrett <mr_bones_@gentoo.org> qtads-1.6c.ebuild:
use eqmake3 to avoid trying to build against qt4
diff --git a/games-engines/qtads/files/qtads-1.6c-gcc43.patch b/games-engines/qtads/files/qtads-1.6c-gcc43.patch
new file mode 100644
index 000000000000..9c0b04e3ef4d
--- /dev/null
+++ b/games-engines/qtads/files/qtads-1.6c-gcc43.patch
@@ -0,0 +1,20 @@
+--- src/osqt3.cc
++++ src/osqt3.cc
+@@ -43,6 +43,7 @@
+ #include <qfileinfo.h>
+ #include <qdir.h>
+ #include <qtextcodec.h>
++#include <cstring>
+
+ #include "os.h"
+ #include "qtadswarning.h"
+--- src/osqt.cc
++++ src/osqt.cc
+@@ -103,6 +103,7 @@
+ #include <cstring>
+ #include <cstdio>
+ #include <cctype>
++#include <ctime>
+
+ #include "os.h"
+
diff --git a/games-engines/qtads/qtads-1.6c.ebuild b/games-engines/qtads/qtads-1.6c.ebuild
index 6ff5eb5369b4..bed3a621a660 100644
--- a/games-engines/qtads/qtads-1.6c.ebuild
+++ b/games-engines/qtads/qtads-1.6c.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/qtads-1.6c.ebuild,v 1.5 2008/01/02 07:21:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/qtads-1.6c.ebuild,v 1.6 2008/05/05 19:14:09 nyhm Exp $
-inherit flag-o-matic qt3 games
+inherit eutils flag-o-matic qt3 games
DESCRIPTION="QT based GUI interpreter for Tads2/Tads3 games"
HOMEPAGE="http://qtads.sourceforge.net/"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/qtads/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE=""
DEPEND="$(qt_min_version 3)"
@@ -18,7 +18,8 @@ DEPEND="$(qt_min_version 3)"
src_unpack() {
unpack ${A}
cd "${S}"
- gunzip qtads.6.gz || die
+ unpack ./qtads.6.gz
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile () {